[8.6] 'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[8.6] 'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

jtuchel
Hi,

when playing with 8.6.3 and its openSSL support, I also tried a few things in 8.6

Like this:

(SstHttpsUrl fromString: 'https://app.kontolino.de') fetchMessage

which brings up a debugger with this:

'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

What does it mean?
I've copied the two dlls of openSSL into the VAST runtime directory as described in the VAST 8.6.3 documentation, but obviously, that is not the way 8.6 expects this to be.
But since this is an upgraded installation form 8.6 to 8.6.3, I am sure there must be something that can heal this.

Joachim

--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [8.6] 'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

Richard Sargent
Administrator
On Friday, February 17, 2017 at 1:59:06 PM UTC-8, Joachim Tuchel wrote:
Hi,

when playing with 8.6.3 and its openSSL support, I also tried a few things in 8.6

Like this:

(SstHttpsUrl fromString: '<a href="https://app.kontolino.de" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;">https://app.kontolino.de') fetchMessage

which brings up a debugger with this:

'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

What does it mean?
I've copied the two dlls of openSSL into the VAST runtime directory as described in the VAST 8.6.3 documentation, but obviously, that is not the way 8.6 expects this to be.
But since this is an upgraded installation form 8.6 to 8.6.3, I am sure there must be something that can heal this.

I recall seeing messages (probably from Seth) pointing out that the DLL name mapping stanza in the ini file has differences between 8.6.2 and 8.6.3. So, I think you need to be certain you start with an 8.6.3 .ini file and add whatever changes you know you need (e.g., your ENVY server and path).

I am uncertain whether what was previously posted had anything to do with SSL.

 

Joachim

--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [8.6] 'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

Seth Berman
In reply to this post by jtuchel
Hi Joachim,

Copied the two dlls from where?

I'm confused, are you trying to get OpenSSL working in 8.6 or 8.6.3?

8.6 uses an old OpenSSL binding...it does not understand how to bind to any recent version of OpenSSL without patching it.
On the flip side, 8.6.3 would not understand how to bind to anything older than OpenSSL 1.0.0, which came out in 2010.
That function, OpenSSL_add_all_algorithms, is not even a real function anymore in OpenSSL, it's a macro and can not be bound to.

So, I'm guessing you are trying to use newer OpenSSL libraries in 8.6?  You must patch it if you want to do this.

-- Seth

On Friday, February 17, 2017 at 4:59:06 PM UTC-5, Joachim Tuchel wrote:
Hi,

when playing with 8.6.3 and its openSSL support, I also tried a few things in 8.6

Like this:

(SstHttpsUrl fromString: '<a href="https://app.kontolino.de" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;">https://app.kontolino.de') fetchMessage

which brings up a debugger with this:

'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

What does it mean?
I've copied the two dlls of openSSL into the VAST runtime directory as described in the VAST 8.6.3 documentation, but obviously, that is not the way 8.6 expects this to be.
But since this is an upgraded installation form 8.6 to 8.6.3, I am sure there must be something that can heal this.

Joachim

--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [8.6] 'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

jtuchel
Hi Seth

Am Samstag, 18. Februar 2017 01:24:33 UTC+1 schrieb Seth Berman:
Hi Joachim,

Copied the two dlls from where?

From a download of OpenSSL 1.0.2k. Which is obviously not what I should have done for VAST 8.6 ;-)

 
I'm confused, are you trying to get OpenSSL working in 8.6 or 8.6.3?

Well, actually, I wanted to try some SSL stuff on 8.6.3,because I need to port to 8.6.3 soon anyways. But since it didn't work well (see my other thread and support request), I wnated to give it a try in 8.6 as well. 8.6 already had HTTPS client implementation. I just couldn't get it to run, neither before I had installed 8.6.3 nor after. Both had an OS Error with OpenSSL_add_all_algorithms but I only remember which one I had after upgrading to 8.6.3 and copying the two DLLs. The one before was, I think, 126.

So what your questions seem to tell me is that since an upgrade to 8.6.3 uses the same runtime directory, it is not possible to use 8.6.0 anyways, because VM-wise it is 8.6.3 after installing 8.6.3, right? Only the image can be either 8.6.x or 8.6.y. So I won't be able to test


 

8.6 uses an old OpenSSL binding...it does not understand how to bind to any recent version of OpenSSL without patching it.
On the flip side, 8.6.3 would not understand how to bind to anything older than OpenSSL 1.0.0, which came out in 2010.
That function, OpenSSL_add_all_algorithms, is not even a real function anymore in OpenSSL, it's a macro and can not be bound to.

So, I'm guessing you are trying to use newer OpenSSL libraries in 8.6?  You must patch it if you want to do this.

I don't really need to sun an old openSSL, so this is not really an issue. Apart from the fact, that we need to port our code to 8.6.3 which may take a little while because of a few Seaside, Glorp and other fixes that we had and need to be checked. And we'll have to see if we are hit by some of the changes in Seaside between 3.0.7 and 3.2 (like configuring the session timeout etc.).

We need to implement HTTPS clients for web services we want to connect to, so it is probably just best to go forward and port to 8.6.3 and not worry about 8.6.0.


Joachim


 

-- Seth

On Friday, February 17, 2017 at 4:59:06 PM UTC-5, Joachim Tuchel wrote:
Hi,

when playing with 8.6.3 and its openSSL support, I also tried a few things in 8.6

Like this:

(SstHttpsUrl fromString: '<a href="https://app.kontolino.de" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.kontolino.de\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEXqnL4B2l_Xxf0zLnlEcLJTORUyQ&#39;;return true;">https://app.kontolino.de') fetchMessage

which brings up a debugger with this:

'Primitive failed calling ''CRYPTO_LIB'':OpenSSL_add_all_algorithms from PlatformFunction>>#primitiveAsyncCallSetUp:asyncBlock:inFuture: due to OS error4'

What does it mean?
I've copied the two dlls of openSSL into the VAST runtime directory as described in the VAST 8.6.3 documentation, but obviously, that is not the way 8.6 expects this to be.
But since this is an upgraded installation form 8.6 to 8.6.3, I am sure there must be something that can heal this.

Joachim

--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Loading...