The message is problematic for me.
I said that a long time ago, when I did not have the power to change things http://bugs.squeak.org/view.php?id=2689
Now I may change things, here is what I think:
1) It causes compatibility nightmares
- isComplex exists in Pharo2.0
- has been removed from Pharo 3.0
2) It is way too broadband semantically, many things are complex, so it may cause false polymorphism at best and bugs at worse
- example a) parse nodes can currently be isComplex - case of false polymorphism
- example b) imagine that I have a complex matrix. Will it answer true to isComplex? I'd say yes...
but then, the implementation of Complex>>+ expects that isComplex means isComplexNumber, not isComplexSomething...
So I suggest to rename it to isComplexNumber as it means to be.
I did it in http://www.squeaksource.com/Complex and it would be good to converge on such basics.
Agree?
--
You received this message because you are subscribed to the Google Groups "SciSmalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
[hidden email].
For more options, visit
https://groups.google.com/d/optout.