Accessing web service via a pac file. proxy

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Accessing web service via a pac file. proxy

Klaus Breker-2
Hello,

I've tried the NeoJSON examples in the VAST 9.1 Beta. It works fine, when I do it in my private environment.
I tried the SST-example from the old VAST-forum http://forums.instantiations.com/topic-12-2393.html

'https://api.predic8.de/shop/products/' sstAsUrl fetch.
This works fine.at home.

But in my customers environment http(s) connections are directed through a PAC-file. The example works in Firefox, IE, Chrome. But not in a VAST-Workspace.
I could download this file and tried to configure the #SstClient

This does not work:
SstHttpClient
      initializeTransportScheme: 'local_https_tunnel'
      forHttpsTunnelThrough: 'every.ipadress.from.pac:portnumber' 
      proxyAuth: nil
"I filled proxyAuth too.. Or tried the pac-file-url. "
'https://api.predic8.de/shop/products/' sstAsUrl fetch.

What did I wrong?

Kind regards and a nice sunny day

Klaus


--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Accessing web service via a pac file. proxy

Seth Berman
Hello Klaus,

I *think* you are running into what I just ran into recently and fixed in our latests builds.
In my scenario, when using a proxy server only the one-shot #fetch: message would work.
The first call to #get: would pass, but subsequent calls to #get: would fail because the client did not remember that it already established a secure tunnel.
As a result the client would keep trying to establish a secure connection on every get: request resulting in an conn refused.

Just to see if it's the same thing...can you try using SstHttpClient fetch: instead as a test?


On Monday, June 4, 2018 at 8:37:45 AM UTC-4, Klaus Breker wrote:
Hello,

I've tried the NeoJSON examples in the VAST 9.1 Beta. It works fine, when I do it in my private environment.
I tried the SST-example from the old VAST-forum <a href="http://forums.instantiations.com/topic-12-2393.html" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;">http://forums.instantiations.com/topic-12-2393.html

'<a href="https://api.predic8.de/shop/products/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/' sstAsUrl fetch.
This works fine at home.

But in my customers environment http(s) connections are directed through a PAC-file. The example works in Firefox, IE, Chrome. But not in a VAST-Workspace.
I could download this file and tried to configure the #SstClient

This does not work and returns with error: ECONNREFUSED (10061): Connection refused.
SstHttpClient
      initializeTransportScheme: 'local_https_tunnel'
      forHttpsTunnelThrough: 'every.ipadress.from.pac:portnumber' 
      proxyAuth: nil
"I filled proxyAuth too.. Or tried the pac-file-url. "

|client|
    (client := SstHttpClient forTransportScheme: 'local_https_tunnel') startUp.
    [client get: '<a href="https://api.predic8.de/shop/products/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/']
        ensure: [client shutDown]

What did I wrong?

Kind regards and a nice sunny day

Klaus


--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Accessing web service via a pac file. proxy

Klaus Breker-2
Hello Seth,

thanks for your quick reply. I'm sure there is the firewall in my customer's company, which blocks any request of such a strange browser like "abt.exe". 
I remember, that I had to allow abt.exe through my firewall on my Windows 10 system.

So I have to deal with the network admins to make me hole. 

 Kind regards

Klaus

Am Montag, 4. Juni 2018 15:09:00 UTC+2 schrieb Seth Berman:
Hello Klaus,

I *think* you are running into what I just ran into recently and fixed in our latests builds.
In my scenario, when using a proxy server only the one-shot #fetch: message would work.
The first call to #get: would pass, but subsequent calls to #get: would fail because the client did not remember that it already established a secure tunnel.
As a result the client would keep trying to establish a secure connection on every get: request resulting in an conn refused.

Just to see if it's the same thing...can you try using SstHttpClient fetch: instead as a test?


On Monday, June 4, 2018 at 8:37:45 AM UTC-4, Klaus Breker wrote:
Hello,

I've tried the NeoJSON examples in the VAST 9.1 Beta. It works fine, when I do it in my private environment.
I tried the SST-example from the old VAST-forum <a href="http://forums.instantiations.com/topic-12-2393.html" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;">http://forums.instantiations.com/topic-12-2393.html

'<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/' sstAsUrl fetch.
This works fine at home.

But in my customers environment http(s) connections are directed through a PAC-file. The example works in Firefox, IE, Chrome. But not in a VAST-Workspace.
I could download this file and tried to configure the #SstClient

This does not work and returns with error: ECONNREFUSED (10061): Connection refused.
SstHttpClient
      initializeTransportScheme: 'local_https_tunnel'
      forHttpsTunnelThrough: 'every.ipadress.from.pac:portnumber' 
      proxyAuth: nil
"I filled proxyAuth too.. Or tried the pac-file-url. "

|client|
    (client := SstHttpClient forTransportScheme: 'local_https_tunnel') startUp.
    [client get: '<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/']
        ensure: [client shutDown]

What did I wrong?

Kind regards and a nice sunny day

Klaus


--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Accessing web service via a pac file. proxy

Klaus Breker-2
In reply to this post by Seth Berman
Hello Seth,

I've got it. No dealing with network admins, but patching #SstHttpClient -> class #fetch. I added a call to the client before the #get.

    sem := Semaphore new.
    workBlock := [| client |
        (client := SstHttpClient forTransportScheme: 'httpl') startUp.
        client proxyEnabled: true.
        response := [client get: aUrlObject] ensure: [client shutDown].
        sem signal].

This works.

Kind regards

Klaus

Am Montag, 4. Juni 2018 15:09:00 UTC+2 schrieb Seth Berman:
Hello Klaus,

I *think* you are running into what I just ran into recently and fixed in our latests builds.
In my scenario, when using a proxy server only the one-shot #fetch: message would work.
The first call to #get: would pass, but subsequent calls to #get: would fail because the client did not remember that it already established a secure tunnel.
As a result the client would keep trying to establish a secure connection on every get: request resulting in an conn refused.

Just to see if it's the same thing...can you try using SstHttpClient fetch: instead as a test?


On Monday, June 4, 2018 at 8:37:45 AM UTC-4, Klaus Breker wrote:
Hello,

I've tried the NeoJSON examples in the VAST 9.1 Beta. It works fine, when I do it in my private environment.
I tried the SST-example from the old VAST-forum <a href="http://forums.instantiations.com/topic-12-2393.html" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;">http://forums.instantiations.com/topic-12-2393.html

'<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/' sstAsUrl fetch.
This works fine at home.

But in my customers environment http(s) connections are directed through a PAC-file. The example works in Firefox, IE, Chrome. But not in a VAST-Workspace.
I could download this file and tried to configure the #SstClient

This does not work and returns with error: ECONNREFUSED (10061): Connection refused.
SstHttpClient
      initializeTransportScheme: 'local_https_tunnel'
      forHttpsTunnelThrough: 'every.ipadress.from.pac:portnumber' 
      proxyAuth: nil
"I filled proxyAuth too.. Or tried the pac-file-url. "

|client|
    (client := SstHttpClient forTransportScheme: 'local_https_tunnel') startUp.
    [client get: '<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/']
        ensure: [client shutDown]

What did I wrong?

Kind regards and a nice sunny day

Klaus


--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Accessing web service via a pac file. proxy

Seth Berman
Great to hear Klaus,

Glad it's working and thanks for the update.

-- Seth

On Wednesday, June 6, 2018 at 10:49:40 AM UTC-4, Klaus Breker wrote:
Hello Seth,

I've got it. No dealing with network admins, but patching #SstHttpClient -> class #fetch. I added a call to the client before the #get.

    sem := Semaphore new.
    workBlock := [| client |
        (client := SstHttpClient forTransportScheme: 'httpl') startUp.
        client proxyEnabled: true.
        response := [client get: aUrlObject] ensure: [client shutDown].
        sem signal].

This works. This no general patch ;-) It is only a quick and dirty solution for demonstration in our customers network.

Kind regards

Klaus

Am Montag, 4. Juni 2018 15:09:00 UTC+2 schrieb Seth Berman:
Hello Klaus,

I *think* you are running into what I just ran into recently and fixed in our latests builds.
In my scenario, when using a proxy server only the one-shot #fetch: message would work.
The first call to #get: would pass, but subsequent calls to #get: would fail because the client did not remember that it already established a secure tunnel.
As a result the client would keep trying to establish a secure connection on every get: request resulting in an conn refused.

Just to see if it's the same thing...can you try using SstHttpClient fetch: instead as a test?


On Monday, June 4, 2018 at 8:37:45 AM UTC-4, Klaus Breker wrote:
Hello,

I've tried the NeoJSON examples in the VAST 9.1 Beta. It works fine, when I do it in my private environment.
I tried the SST-example from the old VAST-forum <a href="http://forums.instantiations.com/topic-12-2393.html" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fforums.instantiations.com%2Ftopic-12-2393.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFVtJStRcB92hKp9h3O-pOzf9SW8w&#39;;return true;">http://forums.instantiations.com/topic-12-2393.html

'<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/' sstAsUrl fetch.
This works fine at home.

But in my customers environment http(s) connections are directed through a PAC-file. The example works in Firefox, IE, Chrome. But not in a VAST-Workspace.
I could download this file and tried to configure the #SstClient

This does not work and returns with error: ECONNREFUSED (10061): Connection refused.
SstHttpClient
      initializeTransportScheme: 'local_https_tunnel'
      forHttpsTunnelThrough: 'every.ipadress.from.pac:portnumber' 
      proxyAuth: nil
"I filled proxyAuth too.. Or tried the pac-file-url. "

|client|
    (client := SstHttpClient forTransportScheme: 'local_https_tunnel') startUp.
    [client get: '<a href="https://api.predic8.de/shop/products/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapi.predic8.de%2Fshop%2Fproducts%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHRf8XSjuzvNJerv45BcwEsebbf6Q&#39;;return true;">https://api.predic8.de/shop/products/']
        ensure: [client shutDown]

What did I wrong?

Kind regards and a nice sunny day

Klaus


--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.