[BUG] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

[BUG] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3

I decide move all my stuff to 5.3 as see a lot is changing.
And revive a 2010 mac mini with Snow Leopard

http://ftp.squeak.org/5.3alpha/Squeak5.3alpha-18222-32bit/Squeak5.3alpha-182
22-32bit-201810071412-macOS.dmg

This links do not work

But
http://ftp.squeak.org/5.0/Squeak-5.0-All-in-One.zip works and moving the
relevant part to Applications , this VM launchs Squeak5.3alpha-18222-32bit
.image

No idea how many users of old Apple stuff, but is good have next Squeak
running running on it.


Edgar
@morplenauta



Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Hannes Hirzel
Hi Edgar

On 8/21/19, Edgar J. De Cleene <[hidden email]> wrote:
>
> I decide move all my stuff to 5.3 as see a lot is changing.
> And revive a 2010 mac mini with Snow Leopard
>
> http://ftp.squeak.org/5.3alpha/Squeak5.3alpha-18222-32bit/Squeak5.3alpha-182
> 22-32bit-201810071412-macOS.dmg

So I understand you tested Squeak5.3a on MacOS Snow Leopard on a 2010
machine. And it did not work.

>
> But
> http://ftp.squeak.org/5.0/Squeak-5.0-All-in-One.zip works and moving the
> relevant part to Applications , this VM launchs Squeak5.3alpha-18222-32bit
> .image


I understand that if you take the VM from a Squeak5.0-All-InOne 32 bit
release and use a Squeak5.3alpha-18222 image it runs fine.


Does this mean that the VMs includes in the releases 5.1 and 5.2 do
not work on MacOS Snow leopard with a Squeak5.3alpha-18222-32bit?


Kind regards
Hannes


P.S. Please note that the current Squeak5.3 alpha image has the build
number 18879. For testing it is good to go for the latests version.

P.S. 2   I changed the subject line [Bug] --> [Test]. It is about
testing which old OS is supported or no longer supported. The other
issue is finding a workaround for your problem. For example it might
be a solution for you to run the very recent Squeak5.3a image with a
Squeak 5.0VM.
But maybe the fixes needed are not many.

Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3
On 08/09/2019, 12:23, "H. Hirzel" <[hidden email]> wrote:

> I understand that if you take the VM from a Squeak5.0-All-InOne 32 bit
release
> and use a Squeak5.3alpha-18222 image it runs fine.



Yes
>Does this mean that the
> VMs includes in the releases 5.1 and 5.2 do
not work on MacOS Snow leopard
> with a Squeak5.3alpha-18222-32bit?

Yes
I could made soon the Excel table with all computers , VM and .image
combinations.
For 5.2 and 5.3 and the special case of Snow Leopard.
Could be useful for someone.

Edgar
@morplenauta



Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

David T. Lewis
On Sun, Sep 08, 2019 at 07:16:19PM -0300, Edgar J. De Cleene wrote:

> On 08/09/2019, 12:23, "H. Hirzel" <[hidden email]> wrote:
>
> > I understand that if you take the VM from a Squeak5.0-All-InOne 32 bit
> release
> > and use a Squeak5.3alpha-18222 image it runs fine.
>
>
>
> Yes
> >Does this mean that the
> > VMs includes in the releases 5.1 and 5.2 do
> not work on MacOS Snow leopard
> > with a Squeak5.3alpha-18222-32bit?
>
> Yes
> I could made soon the Excel table with all computers , VM and .image
> combinations.
> For 5.2 and 5.3 and the special case of Snow Leopard.
> Could be useful for someone.
>

Hi Edgar,

I think that it would be a lot of work to come up with such an Excel
table, but yes it would be very helpful if you can do it :-)

Dave



Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3
Mi pleasure
And I add which image could run in MacOS
As example
Catalina force to use only 64 bit
High Sierra can't open very old stuff like 3.10 and older (reason for have
the Mac Mini 2010  running Snow Leopard)
I need as ScarletSmalltalk uses some of Alejandro S8 and this have roots in
his Fenix (3.0)
Also Exupery is very old.


On 08/09/2019, 20:21, "David T. Lewis" <[hidden email]> wrote:

> Hi Edgar,

I think that it would be a lot of work to come up with such an
> Excel
table, but yes it would be very helpful if you can do it :-)

Dave




Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Squeak - Dev mailing list
I can open Squeak3.0 image with Squeak 4.2.2beta1U VM in High Sierra without problems.

> On 9 Sep 2019, at 05:08, Edgar J. De Cleene <[hidden email]> wrote:
>
> Mi pleasure
> And I add which image could run in MacOS
> As example
> Catalina force to use only 64 bit
> High Sierra can't open very old stuff like 3.10 and older (reason for have
> the Mac Mini 2010  running Snow Leopard)
> I need as ScarletSmalltalk uses some of Alejandro S8 and this have roots in
> his Fenix (3.0)
> Also Exupery is very old.


Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3
This is a very good info
Link ?
I add to VM&.image table
Very thanks

Sent from my iPhone

> On 9 Sep 2019, at 12:02, Javier Diaz-Reinoso via Squeak-dev <[hidden email]> wrote:
>
> I can open Squeak3.0 image with Squeak 4.2.2beta1U VM in High Sierra without problems.
>
>> On 9 Sep 2019, at 05:08, Edgar J. De Cleene <[hidden email]> wrote:
>>
>> Mi pleasure
>> And I add which image could run in MacOS
>> As example
>> Catalina force to use only 64 bit
>> High Sierra can't open very old stuff like 3.10 and older (reason for have
>> the Mac Mini 2010  running Snow Leopard)
>> I need as ScarletSmalltalk uses some of Alejandro S8 and this have roots in
>> his Fenix (3.0)
>> Also Exupery is very old.
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Squeak - Dev mailing list
Well I have screenshots:


on the other hand Squeak 4.2.2beta1U. don't work with Squeak2.8.image but Squeak 3.8.19beta1U VM can open it:

On 9 Sep 2019, at 10:48, Edgar De Cleene <[hidden email]> wrote:

This is a very good info
Link ?
I add to VM&.image table
Very thanks

Sent from my iPhone



Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3
On which macOS ?


Sent from my iPhone

On 9 Sep 2019, at 13:12, Javier Diaz-Reinoso via Squeak-dev <[hidden email]> wrote:

Well I have screenshots:

<Screen Shot 2019-09-09 at 11.04.07.png>

on the other hand Squeak 4.2.2beta1U. don't work with Squeak2.8.image but Squeak 3.8.19beta1U VM can open it:

On 9 Sep 2019, at 10:48, Edgar De Cleene <[hidden email]> wrote:

This is a very good info
Link ?
I add to VM&.image table
Very thanks

Sent from my iPhone




Reply | Threaded
Open this post in threaded view
|

Re: [Test] 5.3 alpha 32 bit for macOS fails in SnowLeopard

Edgar J. De Cleene-3
In reply to this post by Squeak - Dev mailing list
Confirmed
The relevant link is
http://ftp.squeak.org/4.0alpha/Squeak4.0.rc3.tar.gz
http://ftp.squeak.org/4.0alpha/rc3/
Open the zip and navigate into for  Squeak 4.2.2beta1U VM
Javier sos mi ídolo :=)


Question of ignorant person.
If you compile the sources today with XCODE in Catalina you get a 64 bit VM
which could open a lot of old code ?


On 09/09/2019, 12:02, "Javier Diaz-Reinoso via Squeak-dev"
<[hidden email]> wrote:

> I can open Squeak3.0 image with Squeak 4.2.2beta1U VM in High Sierra without
> problems.