ConfigurationOfIliad load fails

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ConfigurationOfIliad load fails

Runar Jordahl
Using a fresh Pharo 1.4 image and the following load script, I get an
error during load:

Gofer new
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfIliad';
    load.
(Smalltalk at: #ConfigurationOfIliad) load.

I wonder if ConfigurationOfIliad>>load is using a depreciated method,
and should be changed to the following:

ConfigurationOfIliad>>load
        "self load"

        self project lastVersion load

However, even with this change the load stops with a missing dependency.

Kind regards
Runar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

Bernat Romagosa
Hi Runar,

You should load the dev version:


Gofer new
   squeaksource: 'IliadDev';
   package: 'ConfigurationOfIliad';
   load.
((Smalltalk at: #ConfigurationOfIliad) project version: '0.9.1.2') load.


p.s. Maybe we should specify this somewhere?

2012/5/21 Runar Jordahl <[hidden email]>
Using a fresh Pharo 1.4 image and the following load script, I get an
error during load:

Gofer new
   squeaksource: 'MetacelloRepository';
   package: 'ConfigurationOfIliad';
   load.
(Smalltalk at: #ConfigurationOfIliad) load.

I wonder if ConfigurationOfIliad>>load is using a depreciated method,
and should be changed to the following:

ConfigurationOfIliad>>load
       "self load"

       self project lastVersion load

However, even with this change the load stops with a missing dependency.

Kind regards
Runar



--
Bernat Romagosa.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

Runar Jordahl
The instructions on the following page should state how to load the
current, stable version of Iliad:
http://www.iliadproject.org/pages/Download/Pharo-Squeak

It should state it using a script, like you show in your post.


I am a bit confused... Why is there a "IliadDev" project? As a
developer that considers Iliad for a new project, which stream of
Iliad should I use? Wouldn't it be best to keep the framework in one
place?

Kind regards
Runar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

sebastien audier

Hi Runar, welcome,

We have a repository for new features, experimental parts of code, etc... And sometimes, we make a release.
So, you can use the stable version for deployment, but If you have a fix for a bug, you can submit a patch in the dev branch.

Most of project works like it, I believe.

Kind regards, 


--
Sébastien AUDIER

S.A.R.L Objectfusion
Applications web, consulting, design,
site Internet, Promotion de projets.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

Runar Jordahl
Thanks for all replies!

I guess the load problem for the stable version should be corrected.
As I wrote, loading the stable version using the following script
fails in a fresh 1.4 image:

Gofer new
   squeaksource: 'MetacelloRepository';
   package: 'ConfigurationOfIliad';
   load.
(Smalltalk at: #ConfigurationOfIliad) load.

Is this the correct way to load Iliad stable version?

Kind regards
Runar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

Alex Schenkman
In reply to this post by Bernat Romagosa
Loading version Iliad 0.9.1.2 in Pharo 1.4-14438

Gives following error:
This package depends on the following classes:
  ParseTreeEnvironment
You must resolve these dependencies before you will be able to load these definitions: 
  matcher

Running the tests gives 4 errors. Look at the attached PNG.

How should I load a working version?
Thanks in advance!


Le mardi 22 mai 2012 10:36:58 UTC+2, Bernat Romagosa a écrit :
Hi Runar,

You should load the dev version:


Gofer new
   squeaksource: 'IliadDev';
   package: 'ConfigurationOfIliad';
   load.
((Smalltalk at: #ConfigurationOfIliad) project version: '0.9.1.2') load.


p.s. Maybe we should specify this somewhere?

2012/5/21 Runar Jordahl <[hidden email]>
Using a fresh Pharo 1.4 image and the following load script, I get an
error during load:

Gofer new
   squeaksource: 'MetacelloRepository';
   package: 'ConfigurationOfIliad';
   load.
(Smalltalk at: #ConfigurationOfIliad) load.

I wonder if ConfigurationOfIliad>>load is using a depreciated method,
and should be changed to the following:

ConfigurationOfIliad>>load
       "self load"

       self project lastVersion load

However, even with this change the load stops with a missing dependency.

Kind regards
Runar



--
Bernat Romagosa.

failures.png (303K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ConfigurationOfIliad load fails

Bernat Romagosa
Hi Alex,

The ParseTreeEnvironment warning is already a classic ;)

Don't worry, this is the development version and the one we're all using (0.9.1.2), Iliad will work even despite these 4 errors and the ParseTreeEnvironment warning.

Cheers,

Bernat.

2012/6/4 Alex Schenkman <[hidden email]>
Loading version Iliad 0.9.1.2 in Pharo 1.4-14438

Gives following error:
This package depends on the following classes:
  ParseTreeEnvironment
You must resolve these dependencies before you will be able to load these definitions: 
  matcher

Running the tests gives 4 errors. Look at the attached PNG.

How should I load a working version?
Thanks in advance!


Le mardi 22 mai 2012 10:36:58 UTC+2, Bernat Romagosa a écrit :
Hi Runar,

You should load the dev version:


Gofer new
   squeaksource: 'IliadDev';
   package: 'ConfigurationOfIliad';
   load.
((Smalltalk at: #ConfigurationOfIliad) project version: '0.9.1.2') load.


p.s. Maybe we should specify this somewhere?

2012/5/21 Runar Jordahl <[hidden email]>
Using a fresh Pharo 1.4 image and the following load script, I get an
error during load:

Gofer new
   squeaksource: 'MetacelloRepository';
   package: 'ConfigurationOfIliad';
   load.
(Smalltalk at: #ConfigurationOfIliad) load.

I wonder if ConfigurationOfIliad>>load is using a depreciated method,
and should be changed to the following:

ConfigurationOfIliad>>load
       "self load"

       self project lastVersion load

However, even with this change the load stops with a missing dependency.

Kind regards
Runar



--
Bernat Romagosa.



--
Bernat Romagosa.
Loading...