Corrupted fonts in P7 after loading Glamorous Toolkit

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Corrupted fonts in P7 after loading Glamorous Toolkit

Tim Mackinnon
Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.

Anyone else seen this? Is is it something about loading GT?

This is on OSX

Tim
Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

Tim Mackinnon
It looks like this:


And this:





On 25 Jan 2019, at 15:55, Tim Mackinnon <[hidden email]> wrote:

Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.

Anyone else seen this? Is is it something about loading GT?

This is on OSX

Tim

Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

Tim Mackinnon
Actually - I just remembered that I saved my image right after loading GT (and before playing with it) and so quitting without saving shows that it started out fine. So following some of the examples seems to have corrupted something? (In retrospect I should have saved with a new name - so I’ll have to see if I can repro it if its not something already known). But I recall some discussion around Freetype fonts or something - so wondering if anyone has any thoughts, otherwise I’ll log a bug.

Tim

On 25 Jan 2019, at 15:58, Tim Mackinnon <[hidden email]> wrote:

It looks like this:

<PastedGraphic-2.png>

And this:

<PastedGraphic-1.png>


<PastedGraphic-3.png>

On 25 Jan 2019, at 15:55, Tim Mackinnon <[hidden email]> wrote:

Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.

Anyone else seen this? Is is it something about loading GT?

This is on OSX

Tim


Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

Sean P. DeNigris
Administrator
Tim Mackinnon wrote
> But I recall some discussion around Freetype fonts or something

That was my thought as well. Maybe try reloading Freetype fonts (IIRC you
can uncheck and recheck in settings)



-----
Cheers,
Sean
--
Sent from: http://forum.world.st/Pharo-Smalltalk-Users-f1310670.html

Cheers,
Sean
Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

Sven Van Caekenberghe-2
In reply to this post by Tim Mackinnon
Hi Tim,

I also reported back an earlier problem (title 'Pharo 7 RC - Changing to larger font breaks scrolling in code browsers').

I also saw some weirdness with fonts (I made them bigger).

There is indeed some way to reset things, but I can't remember it myself.

Sven

> On 25 Jan 2019, at 17:01, Tim Mackinnon <[hidden email]> wrote:
>
> Actually - I just remembered that I saved my image right after loading GT (and before playing with it) and so quitting without saving shows that it started out fine. So following some of the examples seems to have corrupted something? (In retrospect I should have saved with a new name - so I’ll have to see if I can repro it if its not something already known). But I recall some discussion around Freetype fonts or something - so wondering if anyone has any thoughts, otherwise I’ll log a bug.
>
> Tim
>
>> On 25 Jan 2019, at 15:58, Tim Mackinnon <[hidden email]> wrote:
>>
>> It looks like this:
>>
>> <PastedGraphic-2.png>
>>
>> And this:
>>
>> <PastedGraphic-1.png>
>>
>>
>> <PastedGraphic-3.png>
>>
>>> On 25 Jan 2019, at 15:55, Tim Mackinnon <[hidden email]> wrote:
>>>
>>> Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.
>>>
>>> Anyone else seen this? Is is it something about loading GT?
>>>
>>> This is on OSX
>>>
>>> Tim
>>
>


Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

HilaireFernandes
In reply to this post by Tim Mackinnon
I did got this effect with GToolkit. I am not sure it is related to
GToolkit as I installed immediately this package, though.

Hilaire

Le 25/01/2019 à 16:55, Tim Mackinnon a écrit :
> Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.
>
> Anyone else seen this? Is is it something about loading GT?
>
> This is on OSX
>
> Tim

--
Dr. Geo
http://drgeo.eu



Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

SergeStinckwich
In reply to this post by Tim Mackinnon
I have recently also some font problems on my new macbook pro with Pharo 6.1.
When I load Roassal and try to run one example, my image crash (with errors related to Cairo). This does not happen with Pharo 7.0

Dunno if this related to my new macbook, Pharo 6.1 VM or my update to last version of Mojave ...

Sent from my iPhone

> On 25 Jan 2019, at 16:55, Tim Mackinnon <[hidden email]> wrote:
>
> Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.
>
> Anyone else seen this? Is is it something about loading GT?
>
> This is on OSX
>
> Tim

Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

EstebanLM
In reply to this post by HilaireFernandes
I don’t think is related to GToolkit, it is an ongoing bug we are having (and we still do not understand why it happens, but we are looking at it).
In the mean time, saving the image will “fix” the problem (because it will reset the font caches).

Esteban


> On 25 Jan 2019, at 17:43, Hilaire <[hidden email]> wrote:
>
> I did got this effect with GToolkit. I am not sure it is related to
> GToolkit as I installed immediately this package, though.
>
> Hilaire
>
> Le 25/01/2019 à 16:55, Tim Mackinnon a écrit :
>> Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.
>>
>> Anyone else seen this? Is is it something about loading GT?
>>
>> This is on OSX
>>
>> Tim
>
> --
> Dr. Geo
> http://drgeo.eu
>
>
>


Reply | Threaded
Open this post in threaded view
|

Re: Corrupted fonts in P7 after loading Glamorous Toolkit

Tim Mackinnon
As an observation that might help with this - I’ve not been able to recreate the corruption after I had re-saved the image and cured the original corruption. I will go back to my original starting image and see if I can corrupt it from there (previously I had been able to).

So I’m not sure why that save and subsequent font cache reset would hold when it didn’t seem to before.

Tim

> On 26 Jan 2019, at 08:27, Esteban Lorenzano <[hidden email]> wrote:
>
> I don’t think is related to GToolkit, it is an ongoing bug we are having (and we still do not understand why it happens, but we are looking at it).
> In the mean time, saving the image will “fix” the problem (because it will reset the font caches).
>
> Esteban
>
>
>> On 25 Jan 2019, at 17:43, Hilaire <[hidden email]> wrote:
>>
>> I did got this effect with GToolkit. I am not sure it is related to
>> GToolkit as I installed immediately this package, though.
>>
>> Hilaire
>>
>> Le 25/01/2019 à 16:55, Tim Mackinnon a écrit :
>>> Hi - I just noticed that when I loaded the Glamorous toolkit and was playing around, when I went to look in the Pharo menus they are all corrupted (the odd character is some type of glyph). Opening a playground and doing some code completion shows that method names have the same random character glyphed.
>>>
>>> Anyone else seen this? Is is it something about loading GT?
>>>
>>> This is on OSX
>>>
>>> Tim
>>
>> --
>> Dr. Geo
>> http://drgeo.eu
>>
>>
>>
>
>