Database encoding issue persists in WV 1.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
jb
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Database encoding issue persists in WV 1.1

jb
Hi,

I've detected the same problem with WebVelocity 1.1. Now it is the
class PostgreSQLConnection where the method

stringEncodingName
        stringEncodingName isNil ifTrue: [stringEncodingName := #utf8].
        ^stringEncodingName

has to be changed.

Best regards
Johannes

On 7 Jul. 2009, 08:30, "masashi.umezawa" <[hidden email]>
wrote:

> Hello all,
>
> I tried Web Velocity for the first time. Thanks for the really nice
> product!
> However, I've encountered an encoding error when I tried to store
> multibyte strings to PostgreSQL.
> I've just made a blog sample according to the walkthrough tutorial.
>
> The error seems to be related to PostgreSQLDriver's default encoding
> settings. So I've changed the code.
>
> PostgreSQLDriver>>stringEncodingName
> stringEncodingName isNil ifTrue: [stringEncodingName := #utf8].
>         ^stringEncodingName
>
> By using #utf8 instead of #default, multibyte strings were stored/
> retrieved correctly.
>
> Is there more elegant way to set the database connection encoding? I
> think it would be better if I can set such settings via Web Velocity's
> database configuration menu. (Or even better it would be set
> automatically?)
>
> Best regards,
> ---
> [:masashi | ^umezawa]

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Database encoding issue persists in WV 1.1

Michael Lucas-Smith-2
Yes there's definitely something going on here. Your patch will work for you, but it needs to determine the encoding of the database you're connected to. There may be issues in the other database drivers too, so we're looking in to this.

Michael


On Oct 23, 2010, at 1:21 PM, joh wrote:

> Hi,
>
> I've detected the same problem with WebVelocity 1.1. Now it is the
> class PostgreSQLConnection where the method
>
> stringEncodingName
> stringEncodingName isNil ifTrue: [stringEncodingName := #utf8].
> ^stringEncodingName
>
> has to be changed.
>
> Best regards
> Johannes
>
> On 7 Jul. 2009, 08:30, "masashi.umezawa" <[hidden email]>
> wrote:
>> Hello all,
>>
>> I tried Web Velocity for the first time. Thanks for the really nice
>> product!
>> However, I've encountered an encoding error when I tried to store
>> multibyte strings to PostgreSQL.
>> I've just made a blog sample according to the walkthrough tutorial.
>>
>> The error seems to be related to PostgreSQLDriver's default encoding
>> settings. So I've changed the code.
>>
>> PostgreSQLDriver>>stringEncodingName
>> stringEncodingName isNil ifTrue: [stringEncodingName := #utf8].
>>        ^stringEncodingName
>>
>> By using #utf8 instead of #default, multibyte strings were stored/
>> retrieved correctly.
>>
>> Is there more elegant way to set the database connection encoding? I
>> think it would be better if I can set such settings via Web Velocity's
>> database configuration menu. (Or even better it would be set
>> automatically?)
>>
>> Best regards,
>> ---
>> [:masashi | ^umezawa]
>
> --
> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> To post to this group, send email to [hidden email].
> To unsubscribe from this group, send email to [hidden email].
> For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
>

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Loading...