Quantcast

Encoding issues with DBXTalk and Glorp

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Encoding issues with DBXTalk and Glorp

Esteban A. Maringolo
I'm trying to search for an object in the database by means of the following GLORP query:

session readOneOf: User where: [:one | one name = 'Martín'].

There is no matching row in the database.

But I get the following error:
DBXRecoverableError: RECOVERABLE OpenDBX: ERROR:  invalid byte sequence for encoding "UTF8": 0xed 0x6e 0x27


On the other hand, if I insert a row manually, when I get the name back (read from the database) I get 'Martín' instead of the original 'Martín'.

Should I define the encoding I want to use somewhere else?

Regards,

Esteban A. Maringolo

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Encoding issues with DBXTalk and Glorp

FDominicus
Bin dabei, habe eigentlich die Sachen soweit zusammen.

Mit freundlichen Grüßen
Friedrich Dominicus
 

--
Q-Software Solutions GmbH; Sitz: Bruchsal; Registergericht: Mannheim
Registriernummer: HRB232138; Geschaeftsfuehrer: Friedrich Dominicus

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Encoding issues with DBXTalk and Glorp

mmimica
In reply to this post by Esteban A. Maringolo
Login new
database: GRSSPostgreSQLPlatform new;
username: 'username';
password: 'password';
connectString: (postgreHost, ':', postgrePort asString, '_', postgreSchema);
encodingStrategy: (DBXStaticEncoding newForEncoding: #utf8)

Note the encodingStrategy: thing at the end!




On 24 September 2013 16:06, Esteban A. Maringolo <[hidden email]> wrote:
I'm trying to search for an object in the database by means of the following GLORP query:

session readOneOf: User where: [:one | one name = 'Martín'].

There is no matching row in the database.

But I get the following error:
DBXRecoverableError: RECOVERABLE OpenDBX: ERROR:  invalid byte sequence for encoding "UTF8": 0xed 0x6e 0x27


On the other hand, if I insert a row manually, when I get the name back (read from the database) I get 'Martín' instead of the original 'Martín'.

Should I define the encoding I want to use somewhere else?

Regards,

Esteban A. Maringolo

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.



--
Milan Mimica
http://sparklet.sf.net

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Encoding issues with DBXTalk and Glorp

Esteban A. Maringolo
2013/9/24 Milan Mimica <[hidden email]>
Login new
database: GRSSPostgreSQLPlatform new;
username: 'username';
password: 'password';
connectString: (postgreHost, ':', postgrePort asString, '_', postgreSchema);
encodingStrategy: (DBXStaticEncoding newForEncoding: #utf8)

Note the encodingStrategy: thing at the end!


Perfect! It did the trick.
I was setting the encoding in the Platform instance, with no effect.

Thank you very much.


 

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Loading...