Error on Windows 10 After loading Ma Client Server on the latest Squeak version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error on Windows 10 After loading Ma Client Server on the latest Squeak version

Hari
Hi Chris et al,

I just loaded Ma Client Server on a new Squeak image in Windows 10 and got an error : 

WindowsOSProcessAccessor does not understand #restoreSigTerm in restartSigTermHandler. 

It is called by "initialize" and "startUp:" in MaServer.

Kind regards,

Hari




_______________________________________________
Magma mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/magma
Reply | Threaded
Open this post in threaded view
|

Re: Error on Windows 10 After loading Ma Client Server on the latest Squeak version

Chris Muller-3
Hi Hari, here is a fileout which guards that error.  I'll be sure to
integrate it.

Thanks!




On Sat, Apr 1, 2017 at 9:04 PM, Hari Balaraman
<[hidden email]> wrote:

> Hi Chris et al,
>
> I just loaded Ma Client Server on a new Squeak image in Windows 10 and got
> an error :
>
> WindowsOSProcessAccessor does not understand #restoreSigTerm in
> restartSigTermHandler.
>
> It is called by "initialize" and "startUp:" in MaServer.
>
> Kind regards,
>
> Hari
>
>
>
>
> _______________________________________________
> Magma mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/magma
>

_______________________________________________
Magma mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/magma

SmalltalkImage-restartSigTermHandler.st (914 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error on Windows 10 After loading Ma Client Server on the latest Squeak version

Hari
I was just about to send you some code I am using to check for windows and avoid making that call, but your code probably goes to the heart of the issue better.
Thanks!
Hari


> Le 3 avr. 2017 à 16:13, Chris Muller <[hidden email]> a écrit :
>
> <SmalltalkImage-restartSigTermHandler.st>

_______________________________________________
Magma mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/magma
Reply | Threaded
Open this post in threaded view
|

Re: Error on Windows 10 After loading Ma Client Server on the latest Squeak version

pahihu
This post has NOT been accepted by the mailing list yet.
In reply to this post by Chris Muller-3
Hi!

Could I suggest that instead of checking Smalltalk platformName,
the following check is used ?

    OSProcess isUnix ifFalse: [ ^self ].

Smalltalk platformName is 'Mac OS' on macOS.

Regards,
pahihu