Freetype ftconfig.h missing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Freetype ftconfig.h missing

Ben Coman
 
I had a problem starting Cygwin (in the end due to a ASLR config change)
and while troubleshooting blew away my existing installation
and reinstalled the latest.

I ran ```installCygwin.bat``` to install all dependencies
cloned  **OpenSmalltalk/opensmalltalk-vm**  repo
remembered to run ```updateSCCSVersions``` (for a change)
then ran ```build.win32x86/pharo.cog.sput/mvm -f```

In the past like that, the build would work out of the box, but today I have an error with Freetype.
The ftconfig.h seems not to be generated

Build log...
tar x -f ../../.thirdparty-cache/freetype-2.9.1.tar.gz -C build/third-party
cp ../third-party/Toolchain-cross-mingw32-cygwin.cmake build/third-party/freetype-2.9.1
test -d build/third-party/freetype-2.9.1/build || mkdir build/third-party/freetype-2.9.1/build
cd build/third-party/freetype-2.9.1/build \
        && cmake ..\
                -DCMAKE_TOOLCHAIN_FILE=../Toolchain-cross-mingw32-cygwin.cmake \
                -DCMAKE_INSTALL_PREFIX=/home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/.thirdparty-cache/windows/i386 \
                -DWITH_PNG=OFF \
                -DBUILD_SHARED_LIBS=ON \
                -DCMAKE_C_FLAGS="-m32 -static-libgcc -static-libstdc++" \
        && make \
        && make install
-- Could NOT find harfbuzz (missing:  HARFBUZZ_INCLUDE_DIRS HARFBUZZ_LIBRARIES)
-- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
-- Could NOT find PNG (missing:  PNG_LIBRARY PNG_PNG_INCLUDE_DIR)
-- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
-- Could NOT find BZip2 (missing:  BZIP2_LIBRARIES BZIP2_INCLUDE_DIR)
-- Configuring done
-- Generating done
-- Build files have been written to: /home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/build.win32x86/pharo.cog.spur/build/third-party/freetype-2.9.1/build
[100%] Built target freetype
Install the project...
-- Install configuration: ""
-- Up-to-date:    ....about 40 header files
-- Up-to-date: /home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/.thirdparty-cache/windows/i386/include/freetype2/ft2build.h
CMake Error at cmake_install.cmake:35 (file):
  file INSTALL cannot find
  "/home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/build.win32x86/pharo.cog.spur/build/third-party/freetype-2.9.1/build/include/freetype/config/ftconfig.h".


I observe this...

$ pushd .../third-party/freetype-2.9.1/

find . -name ftconfig.h
null result

./configure
configure: creating ./config.status
config.status: creating ftoption.h
config.status: creating unix-cc.mk
config.status: creating unix-def.mk
config.status: creating ftconfig.h
config.status: executing libtool commands

find . -name ftconfig.h
./builds/amiga/include/config/ftconfig.h
./builds/unix/ftconfig.h
./builds/vms/ftconfig.h
./include/freetype/config/ftconfig.h

cool, ftconfig.h ends up where expected

$ popd

$ ./mvm -f
same error

$ pushd .../third-party/freetype-2.9.1/

find . -name ftconfig.h
null result


$ git log
commit 476f70605a0352dd7528d251f7403e9233716cdb (HEAD -> Cog, origin/HEAD, origin/Cog)
Date:   Tue Nov 27 15:42:06 2018 -0800

Anyone seeing the same thing?
cheers -ben
Reply | Threaded
Open this post in threaded view
|

Re: Freetype ftconfig.h missing

Alistair Grant
 
Hi Ben,

TL;DR; yes...

On Sat, 1 Dec 2018 at 03:41, Ben Coman <[hidden email]> wrote:

>
>
> I had a problem starting Cygwin (in the end due to a ASLR config change)
> and while troubleshooting blew away my existing installation
> and reinstalled the latest.
>
> I ran ```installCygwin.bat``` to install all dependencies
> cloned  **OpenSmalltalk/opensmalltalk-vm**  repo
> remembered to run ```updateSCCSVersions``` (for a change)
> then ran ```build.win32x86/pharo.cog.sput/mvm -f```
>
> In the past like that, the build would work out of the box, but today I have an error with Freetype.
> The ftconfig.h seems not to be generated
>
> Build log...
> tar x -f ../../.thirdparty-cache/freetype-2.9.1.tar.gz -C build/third-party
> cp ../third-party/Toolchain-cross-mingw32-cygwin.cmake build/third-party/freetype-2.9.1
> test -d build/third-party/freetype-2.9.1/build || mkdir build/third-party/freetype-2.9.1/build
> cd build/third-party/freetype-2.9.1/build \
>         && cmake ..\
>                 -DCMAKE_TOOLCHAIN_FILE=../Toolchain-cross-mingw32-cygwin.cmake \
>                 -DCMAKE_INSTALL_PREFIX=/home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/.thirdparty-cache/windows/i386 \
>                 -DWITH_PNG=OFF \
>                 -DBUILD_SHARED_LIBS=ON \
>                 -DCMAKE_C_FLAGS="-m32 -static-libgcc -static-libstdc++" \
>         && make \
>         && make install
> -- Could NOT find harfbuzz (missing:  HARFBUZZ_INCLUDE_DIRS HARFBUZZ_LIBRARIES)
> -- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
> -- Could NOT find PNG (missing:  PNG_LIBRARY PNG_PNG_INCLUDE_DIR)
> -- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
> -- Could NOT find BZip2 (missing:  BZIP2_LIBRARIES BZIP2_INCLUDE_DIR)
> -- Configuring done
> -- Generating done
> -- Build files have been written to: /home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/build.win32x86/pharo.cog.spur/build/third-party/freetype-2.9.1/build
> [100%] Built target freetype
> Install the project...
> -- Install configuration: ""
> -- Up-to-date:    ....about 40 header files
> -- Up-to-date: /home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/.thirdparty-cache/windows/i386/include/freetype2/ft2build.h
> CMake Error at cmake_install.cmake:35 (file):
>   file INSTALL cannot find
>   "/home/Ben/Repos/OpenSmalltalk/opensmalltalk-vm/build.win32x86/pharo.cog.spur/build/third-party/freetype-2.9.1/build/include/freetype/config/ftconfig.h".
>
> ...
>
> Anyone seeing the same thing?
> cheers -ben

Yep:

CMake Error at cmake_install.cmake:35 (file):
  file INSTALL cannot find
  "/home/alistair/pharo7/pharo-snap/pharo-vm/opensmalltalk-vm/build.win32x86/pharo.cog.spur/build/third-party/freetype-2.9.1/build/include/freetype/config/ftconfig.h".

I'm focusing on other issues (FileAttributesPlugin), so haven't got
back to this (and don't really like Windows, so am happy to
procrastinate :-)).

Cheers,
Alistair