Garage: How to specify backend for OpenDBX?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Garage: How to specify backend for OpenDBX?

Víctor Casado
Hi team!

First of all thanks for your whole work. I've been using DBXTalk a while ago in my work, but lately my image sometimes hangs when tries to do a connection to a server that is not open (but not always, that's what surprises me), and I don't know how to fix it.

That's because I want to try Garage, but I encountered some problems to start with it. When I try to open a connection with my server with the following code:

| connection |
connection := GADriver fromConnectionString: 'opendbx://host:port/database?&user=user&password=password'.

It raises the following error: 'no backend specified for opendbx connection'. Could you tell me what am I doing wrong? How can I specify the MSSQL backend for OpenDBX?

Thanks a lot!

Regards,


--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Garage: How to specify backend for OpenDBX?

Guillermo Polito
Hi! and welcome,

El mar., 4 de ago. de 2015 a la(s) 11:27 a. m., Víctor Casado <[hidden email]> escribió:
Hi team!

First of all thanks for your whole work.

Thanks :)
 
I've been using DBXTalk a while ago in my work, but lately my image sometimes hangs when tries to do a connection to a server that is not open (but not always, that's what surprises me), and I don't know how to fix it.


That happens with the old OpenDBXDriver? Which version of Pharo/opendbx are you using?
 
That's because I want to try Garage, but I encountered some problems to start with it. When I try to open a connection with my server with the following code:

| connection |
connection := GADriver fromConnectionString: 'opendbx://host:port/database?&user=user&password=password'.

It raises the following error: 'no backend specified for opendbx connection'. Could you tell me what am I doing wrong? How can I specify the MSSQL backend for OpenDBX?

Oups, that's something that is not documented. I'll add it to my high priority queue.
Answering you:

When you connect to opendbx, you have to specify which is the backend you want, with the backend key. For example, if you would like to connect to sqlite, you must add to your connection properties the following:

backend=sqlite3

for example,

opendbx://path/to/file?backend=sqlite3
 
Now, connecting to other databases through opendbx is not implemented yet because connecting to mysql or postgres could be achieved by just using the native postgres and mysql drivers that perform better.

So I'd propose you either to use a normal mysql connection

mysql://host:port/database?...

or, if you would like to continue using the opendbx backend, we can work together in adding the two methods for making it available. If you'd like the latter, we can continue in private and have maybe a skype talk.

Cheers,
Guille

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Garage: How to specify backend for OpenDBX?

Víctor Casado
Hi Guillermo!

2015-08-04 16:13 GMT+02:00 Guillermo Polito <[hidden email]>:
Hi! and welcome,

El mar., 4 de ago. de 2015 a la(s) 11:27 a. m., Víctor Casado <[hidden email]> escribió:
Hi team!

First of all thanks for your whole work.

Thanks :)
 
I've been using DBXTalk a while ago in my work, but lately my image sometimes hangs when tries to do a connection to a server that is not open (but not always, that's what surprises me), and I don't know how to fix it.


That happens with the old OpenDBXDriver? Which version of Pharo/opendbx are you using?

Yes, I'm using Pharo 3.0 with the stable version of OpenDBXDriver (34)
 
 
That's because I want to try Garage, but I encountered some problems to start with it. When I try to open a connection with my server with the following code:

| connection |
connection := GADriver fromConnectionString: 'opendbx://host:port/database?&user=user&password=password'.

It raises the following error: 'no backend specified for opendbx connection'. Could you tell me what am I doing wrong? How can I specify the MSSQL backend for OpenDBX?

Oups, that's something that is not documented. I'll add it to my high priority queue.
Answering you:

When you connect to opendbx, you have to specify which is the backend you want, with the backend key. For example, if you would like to connect to sqlite, you must add to your connection properties the following:

backend=sqlite3

for example,

opendbx://path/to/file?backend=sqlite3
 
Now, connecting to other databases through opendbx is not implemented yet because connecting to mysql or postgres could be achieved by just using the native postgres and mysql drivers that perform better.

Correct, I could check because I got an exception with the following message: 

DBXMSSQLBackend(Object)>>doesNotUnderstand: #connectionSettingsFromConnectionString:
 

So I'd propose you either to use a normal mysql connection

mysql://host:port/database?...  

But I can't do this to connect to MSSQL server, or am I wrong?
 
or, if you would like to continue using the opendbx backend, we can work together in adding the two methods for making it available. If you'd like the latter, we can continue in private and have maybe a skype talk.


That would be perfect if it helps you to improve this project :)
 
Cheers,
Guille

Best regards, 

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
Víctor Casado

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...