Iliad on GemStone with Comanche

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Iliad on GemStone with Comanche

Bernat Romagosa
The subject pretty much says it all :)

Any chance to get this config running? I managed to start Iliad on Swazoo, but:

WAGemStoneRunSeasideGems default
        name: 'Swazoo';
        adaptorClass: SwazooGemstoneIliad;
        ports: #(8888).

WAGemStoneRunSeasideGems startGems.

doesn't work, and:

SwazooGemstoneIliad startOn: 8888

does work but block the main thread and you can't do anything else.

Anyway, what we need is to get ut running on Comanche... any pointers on how to proceed?

Thanks!

--
Bernat Romagosa.

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Nicolas Petton

Hi Bernat,

IIRC, you *have* to use Swazoo (there's no comanche port for GemStone
AFAIK). Also, if you run Swazoo directly, it is blocking.

What you have to use is ILGemStoneRunIliadGems from
Iliad-GemStome-Core. It was borrowed from Seaside for GemStone, using it
should be straight-forward.

Nico

Bernat Romagosa <[hidden email]> writes:

> The subject pretty much says it all :)
>
> Any chance to get this config running? I managed to start Iliad on Swazoo,
> but:
>
> *WAGemStoneRunSeasideGems default*
> *        name: 'Swazoo';*
> *        adaptorClass: SwazooGemstoneIliad;*
> *        ports: #(8888).*
> *
> *
> *WAGemStoneRunSeasideGems startGems.*
>
>
> doesn't work, and:
>
> *SwazooGemstoneIliad startOn: 8888*
>
> does work but block the main thread and you can't do anything else.
>
> Anyway, what we need is to get ut running on Comanche... any pointers on
> how to proceed?
>
> Thanks!
>
> --
> Bernat Romagosa.
>
> --
> You received this message because you are subscribed to the Google Groups "Iliad project" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

--
Nicolas Petton
http://nicolas-petton.fr

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Bernat Romagosa
Hi Nico,

I see... but I followed the directions in your blog post and:

WAGemStoneRunSeasideGems default
  name: 'Swazoo';
  adaptorClass: SwazooGemstoneIliad;
  ports: #(8888).

WAGemStoneRunSeasideGems startGems.

This doesn't seem to work... is there something wrong in this code?

Thanks!


2013/1/30 Nicolas Petton <[hidden email]>

Hi Bernat,

IIRC, you *have* to use Swazoo (there's no comanche port for GemStone
AFAIK). Also, if you run Swazoo directly, it is blocking.

What you have to use is ILGemStoneRunIliadGems from
Iliad-GemStome-Core. It was borrowed from Seaside for GemStone, using it
should be straight-forward.

Nico

Bernat Romagosa <[hidden email]> writes:

> The subject pretty much says it all :)
>
> Any chance to get this config running? I managed to start Iliad on Swazoo,
> but:
>
> *WAGemStoneRunSeasideGems default*
> *        name: 'Swazoo';*
> *        adaptorClass: SwazooGemstoneIliad;*
> *        ports: #(8888).*
> *
> *
> *WAGemStoneRunSeasideGems startGems.*
>
>
> doesn't work, and:
>
> *SwazooGemstoneIliad startOn: 8888*
>
> does work but block the main thread and you can't do anything else.
>
> Anyway, what we need is to get ut running on Comanche... any pointers on
> how to proceed?
>
> Thanks!
>
> --
> Bernat Romagosa.
>
> --
> You received this message because you are subscribed to the Google Groups "Iliad project" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

--
Nicolas Petton
http://nicolas-petton.fr



--
Bernat Romagosa.

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Nicolas Petton

Did you try the instructions on the website?
(http://www.iliadproject.org/pages/Download/GemStone-S)

ILGemStoneRunIliadGems default ports: #(1337).
ILGemStoneRunIliadGems startGems

Nico

Bernat Romagosa <[hidden email]> writes:

> Hi Nico,
>
> I see... but I followed the directions in your blog post and:
>
> WAGemStoneRunSeasideGems default
>   name: 'Swazoo';
>   adaptorClass: SwazooGemstoneIliad;
>   ports: #(8888).
>
> WAGemStoneRunSeasideGems startGems.
>
> This doesn't seem to work... is there something wrong in this code?
>
> Thanks!
>
>
> 2013/1/30 Nicolas Petton <[hidden email]>
>
>>
>> Hi Bernat,
>>
>> IIRC, you *have* to use Swazoo (there's no comanche port for GemStone
>> AFAIK). Also, if you run Swazoo directly, it is blocking.
>>
>> What you have to use is ILGemStoneRunIliadGems from
>> Iliad-GemStome-Core. It was borrowed from Seaside for GemStone, using it
>> should be straight-forward.
>>
>> Nico
>>
>> Bernat Romagosa <[hidden email]> writes:
>>
>> > The subject pretty much says it all :)
>> >
>> > Any chance to get this config running? I managed to start Iliad on
>> Swazoo,
>> > but:
>> >
>> > *WAGemStoneRunSeasideGems default*
>> > *        name: 'Swazoo';*
>> > *        adaptorClass: SwazooGemstoneIliad;*
>> > *        ports: #(8888).*
>> > *
>> > *
>> > *WAGemStoneRunSeasideGems startGems.*
>> >
>> >
>> > doesn't work, and:
>> >
>> > *SwazooGemstoneIliad startOn: 8888*
>> >
>> > does work but block the main thread and you can't do anything else.
>> >
>> > Anyway, what we need is to get ut running on Comanche... any pointers on
>> > how to proceed?
>> >
>> > Thanks!
>> >
>> > --
>> > Bernat Romagosa.
>> >
>> > --
>> > You received this message because you are subscribed to the Google
>> Groups "Iliad project" group.
>> > To unsubscribe from this group and stop receiving emails from it, send
>> an email to [hidden email].
>> > For more options, visit https://groups.google.com/groups/opt_out.
>> >
>> >
>>
>> --
>> Nicolas Petton
>> http://nicolas-petton.fr
>>
>
>
>
> --
> Bernat Romagosa.

--
Nicolas Petton
http://nicolas-petton.fr

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Bernat Romagosa
Ouch! No I didn't, I was following these: http://www.nicolas-petton.fr/2011/07/08/iliad-on-gemstone.html

I'll give it a shot tomorrow at work, thanks! :)


2013/1/30 Nicolas Petton <[hidden email]>

Did you try the instructions on the website?
(http://www.iliadproject.org/pages/Download/GemStone-S)

ILGemStoneRunIliadGems default ports: #(1337).
ILGemStoneRunIliadGems startGems

Nico

Bernat Romagosa <[hidden email]> writes:

> Hi Nico,
>
> I see... but I followed the directions in your blog post and:
>
> WAGemStoneRunSeasideGems default
>   name: 'Swazoo';
>   adaptorClass: SwazooGemstoneIliad;
>   ports: #(8888).
>
> WAGemStoneRunSeasideGems startGems.
>
> This doesn't seem to work... is there something wrong in this code?
>
> Thanks!
>
>
> 2013/1/30 Nicolas Petton <[hidden email]>
>
>>
>> Hi Bernat,
>>
>> IIRC, you *have* to use Swazoo (there's no comanche port for GemStone
>> AFAIK). Also, if you run Swazoo directly, it is blocking.
>>
>> What you have to use is ILGemStoneRunIliadGems from
>> Iliad-GemStome-Core. It was borrowed from Seaside for GemStone, using it
>> should be straight-forward.
>>
>> Nico
>>
>> Bernat Romagosa <[hidden email]> writes:
>>
>> > The subject pretty much says it all :)
>> >
>> > Any chance to get this config running? I managed to start Iliad on
>> Swazoo,
>> > but:
>> >
>> > *WAGemStoneRunSeasideGems default*
>> > *        name: 'Swazoo';*
>> > *        adaptorClass: SwazooGemstoneIliad;*
>> > *        ports: #(8888).*
>> > *
>> > *
>> > *WAGemStoneRunSeasideGems startGems.*
>> >
>> >
>> > doesn't work, and:
>> >
>> > *SwazooGemstoneIliad startOn: 8888*
>> >
>> > does work but block the main thread and you can't do anything else.
>> >
>> > Anyway, what we need is to get ut running on Comanche... any pointers on
>> > how to proceed?
>> >
>> > Thanks!
>> >
>> > --
>> > Bernat Romagosa.
>> >
>> > --
>> > You received this message because you are subscribed to the Google
>> Groups "Iliad project" group.
>> > To unsubscribe from this group and stop receiving emails from it, send
>> an email to [hidden email].
>> > For more options, visit https://groups.google.com/groups/opt_out.
>> >
>> >
>>
>> --
>> Nicolas Petton
>> http://nicolas-petton.fr
>>
>
>
>
> --
> Bernat Romagosa.

--
Nicolas Petton
http://nicolas-petton.fr



--
Bernat Romagosa.

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Dale Henrichs
In reply to this post by Bernat Romagosa
Bernat and Nicolas,

In case it helps, there is a port of Zinc to GemStone that could be an alternative to Swazoo ... I don't think that Zinc has been used in production for GemStone, yet ... most of the production apps use FastCGI (I think).

Dale

[1] https://github.com/glassdb/zinc

----- Original Message -----
| From: "Bernat Romagosa" <[hidden email]>
| To: [hidden email]
| Sent: Wednesday, January 30, 2013 4:12:43 AM
| Subject: [Iliad] Iliad on GemStone with Comanche
|
|
| The subject pretty much says it all :)
|
|
| Any chance to get this config running? I managed to start Iliad on
| Swazoo, but:
|
|
|
|
|
| WAGemStoneRunSeasideGems default
|
| name: 'Swazoo';
|
| adaptorClass: SwazooGemstoneIliad;
|
| ports: #(8888).
|
|
|
|
| WAGemStoneRunSeasideGems startGems.
|
|
|
| doesn't work, and:
|
|
|
|
|
| SwazooGemstoneIliad startOn: 8888
|
| does work but block the main thread and you can't do anything else.
|
|
| Anyway, what we need is to get ut running on Comanche... any pointers
| on how to proceed?
|
|
| Thanks!
|
|
| --
| Bernat Romagosa.
|
| --
| You received this message because you are subscribed to the Google
| Groups "Iliad project" group.
| To unsubscribe from this group and stop receiving emails from it,
| send an email to [hidden email].
| For more options, visit https://groups.google.com/groups/opt_out .
|
|
|

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Bernat Romagosa
Thanks Dale!

We kind of need Kom because we ordered an important modification of Komanche to Göran for our app, so switching to another server would mean having to re-implement the modification again in another server. We ordered if from Göran because we didn't know how to do it ourselves, so re-implementing it is not an option...

However, we'll see if we can get it to run on Swazoo first, then begin looking at how hard is it to port Komanche... ;)

Cheers,


2013/1/30 Dale Henrichs <[hidden email]>
Bernat and Nicolas,

In case it helps, there is a port of Zinc to GemStone that could be an alternative to Swazoo ... I don't think that Zinc has been used in production for GemStone, yet ... most of the production apps use FastCGI (I think).

Dale

[1] https://github.com/glassdb/zinc

----- Original Message -----
| From: "Bernat Romagosa" <[hidden email]>
| To: [hidden email]
| Sent: Wednesday, January 30, 2013 4:12:43 AM
| Subject: [Iliad] Iliad on GemStone with Comanche
|
|
| The subject pretty much says it all :)
|
|
| Any chance to get this config running? I managed to start Iliad on
| Swazoo, but:
|
|
|
|
|
| WAGemStoneRunSeasideGems default
|
| name: 'Swazoo';
|
| adaptorClass: SwazooGemstoneIliad;
|
| ports: #(8888).
|
|
|
|
| WAGemStoneRunSeasideGems startGems.
|
|
|
| doesn't work, and:
|
|
|
|
|
| SwazooGemstoneIliad startOn: 8888
|
| does work but block the main thread and you can't do anything else.
|
|
| Anyway, what we need is to get ut running on Comanche... any pointers
| on how to proceed?
|
|
| Thanks!
|
|
| --
| Bernat Romagosa.
|
| --
| You received this message because you are subscribed to the Google
| Groups "Iliad project" group.
| To unsubscribe from this group and stop receiving emails from it,
| send an email to [hidden email].
| For more options, visit https://groups.google.com/groups/opt_out .
|
|
|

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.





--
Bernat Romagosa.

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iliad on GemStone with Comanche

Dale Henrichs
Bernat,

If you find yourself needing to port Komanche, let me know and I'll help with any GemStone-specific bits you need ...

Dale

----- Original Message -----
| From: "Bernat Romagosa" <[hidden email]>
| To: [hidden email]
| Sent: Wednesday, January 30, 2013 9:52:50 AM
| Subject: Re: [Iliad] Iliad on GemStone with Comanche
|
|
| Thanks Dale!
|
|
| We kind of need Kom because we ordered an important modification of
| Komanche to Göran for our app, so switching to another server would
| mean having to re-implement the modification again in another
| server. We ordered if from Göran because we didn't know how to do it
| ourselves, so re-implementing it is not an option...
|
|
| However, we'll see if we can get it to run on Swazoo first, then
| begin looking at how hard is it to port Komanche... ;)
|
|
| Cheers,
|
|
|
|
| 2013/1/30 Dale Henrichs < [hidden email] >
|
|
| Bernat and Nicolas,
|
| In case it helps, there is a port of Zinc to GemStone that could be
| an alternative to Swazoo ... I don't think that Zinc has been used
| in production for GemStone, yet ... most of the production apps use
| FastCGI (I think).
|
| Dale
|
| [1] https://github.com/glassdb/zinc
|
|
|
| ----- Original Message -----
| | From: "Bernat Romagosa" < [hidden email] >
| | To: [hidden email]
| | Sent: Wednesday, January 30, 2013 4:12:43 AM
| | Subject: [Iliad] Iliad on GemStone with Comanche
| |
| |
| | The subject pretty much says it all :)
| |
| |
| | Any chance to get this config running? I managed to start Iliad on
| | Swazoo, but:
| |
| |
| |
| |
| |
| | WAGemStoneRunSeasideGems default
| |
| | name: 'Swazoo';
| |
| | adaptorClass: SwazooGemstoneIliad;
| |
| | ports: #(8888).
| |
| |
| |
| |
| | WAGemStoneRunSeasideGems startGems.
| |
| |
| |
| | doesn't work, and:
| |
| |
| |
| |
| |
| | SwazooGemstoneIliad startOn: 8888
| |
| | does work but block the main thread and you can't do anything else.
| |
| |
| | Anyway, what we need is to get ut running on Comanche... any
| | pointers
| | on how to proceed?
| |
| |
| | Thanks!
| |
| |
| | --
| | Bernat Romagosa.
| |
|
|
| | --
| | You received this message because you are subscribed to the Google
| | Groups "Iliad project" group.
| | To unsubscribe from this group and stop receiving emails from it,
| | send an email to [hidden email] .
| | For more options, visit https://groups.google.com/groups/opt_out .
| |
| |
| |
|
| --
| You received this message because you are subscribed to the Google
| Groups "Iliad project" group.
| To unsubscribe from this group and stop receiving emails from it,
| send an email to [hidden email] .
| For more options, visit https://groups.google.com/groups/opt_out .
|
|
|
|
|
|
| --
| Bernat Romagosa.
|
| --
| You received this message because you are subscribed to the Google
| Groups "Iliad project" group.
| To unsubscribe from this group and stop receiving emails from it,
| send an email to [hidden email].
| For more options, visit https://groups.google.com/groups/opt_out .
|
|
|

--
You received this message because you are subscribed to the Google Groups "Iliad project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.


Loading...