Is bintray the place to go for the latest VM builds?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is bintray the place to go for the latest VM builds?

Phil B
 
I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz from ht
tps://bintray.com/package/files/opensmalltalk/vm/cog and it is missing
the vm-sound-pulse module.  Is this a build issue or am I downloading
from the wrong place?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is bintray the place to go for the latest VM builds?

fniephaus
 
On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]> wrote:

I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz from ht
tps://bintray.com/package/files/opensmalltalk/vm/cog and it is missing
the vm-sound-pulse module.  Is this a build issue or am I downloading
from the wrong place?

Bintray would be the right location, so I'm afraid it's a build issue. But I'm not sure why...does anyone know more about this? 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is bintray the place to go for the latest VM builds?

timrowledge


> On 06-09-2016, at 8:17 AM, Fabio Niephaus <[hidden email]> wrote:
>
> On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]> wrote:
>
> I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz from ht
> tps://bintray.com/package/files/opensmalltalk/vm/cog and it is missing
> the vm-sound-pulse module.  Is this a build issue or am I downloading
> from the wrong place?
>
> Bintray would be the right location, so I'm afraid it's a build issue. But I'm not sure why...does anyone know more about this?

Only that the pulseaudio sound thing hasn’t been included in a while. Somebody with git/svn-fu could probably work out the history.

tim
--
tim Rowledge; [hidden email]; http://www.rowledge.org/tim
Two wrongs are only the beginning.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

Phil B
 
This is still an issue as of the 9/27 build.  This would seem to be a
configuration/build bug as it effectively means that Spur doesn't play
nicely on the desktop w.r.t. sound for many Linux distros.

On Tue, 2016-09-06 at 09:20 -0700, tim Rowledge wrote:

>  
>
> >
> > On 06-09-2016, at 8:17 AM, Fabio Niephaus <[hidden email]>
> > wrote:
> >
> > On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]>
> > wrote:
> >
> > I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz
> > from ht
> > tps://bintray.com/package/files/opensmalltalk/vm/cog and it is
> > missing
> > the vm-sound-pulse module.  Is this a build issue or am I
> > downloading
> > from the wrong place?
> >
> > Bintray would be the right location, so I'm afraid it's a build
> > issue. But I'm not sure why...does anyone know more about this? 
>
> Only that the pulseaudio sound thing hasn’t been included in a while.
> Somebody with git/svn-fu could probably work out the history.
>
> tim
> --
> tim Rowledge; [hidden email]; http://www.rowledge.org/tim
> Two wrongs are only the beginning.
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

fniephaus
 
What needs to be done to fix this? Anyone?


--

On Tue, Sep 27, 2016 at 10:35 PM Phil (list) <[hidden email]> wrote:

This is still an issue as of the 9/27 build.  This would seem to be a
configuration/build bug as it effectively means that Spur doesn't play
nicely on the desktop w.r.t. sound for many Linux distros.

On Tue, 2016-09-06 at 09:20 -0700, tim Rowledge wrote:
>  
>
> >
> > On 06-09-2016, at 8:17 AM, Fabio Niephaus <[hidden email]>
> > wrote:
> >
> > On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]>
> > wrote:
> >
> > I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz
> > from ht
> > tps://bintray.com/package/files/opensmalltalk/vm/cog and it is
> > missing
> > the vm-sound-pulse module.  Is this a build issue or am I
> > downloading
> > from the wrong place?
> >
> > Bintray would be the right location, so I'm afraid it's a build
> > issue. But I'm not sure why...does anyone know more about this? 
>
> Only that the pulseaudio sound thing hasn’t been included in a while.
> Somebody with git/svn-fu could probably work out the history.
>
> tim
> --
> tim Rowledge; [hidden email]; http://www.rowledge.org/tim
> Two wrongs are only the beginning.
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

Eliot Miranda-2
 


On Thu, Oct 13, 2016 at 2:30 AM, Fabio Niephaus <[hidden email]> wrote:
 
What needs to be done to fix this? Anyone?

McStalker.oscogvm$ grep -Hi pulse platforms/unix/vm-sound-*/* platforms/unix/config/*
platforms/unix/vm-sound-pulse/Makefile.inc:PLIBS=-lpulse-simple
platforms/unix/vm-sound-pulse/acinclude.m4:AC_MSG_CHECKING([for PulseAudio])
platforms/unix/vm-sound-pulse/acinclude.m4:AC_TRY_COMPILE([#include <pulse/simple.h>],[(void)pa_simple_new;],[
platforms/unix/vm-sound-pulse/config.cmake:PLUGIN_REQUIRE_LIBRARY (PULSE pulse-simple)
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:/* sqUnixSoundPulseAudio.c -- sound module for Pulse Audio
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/simple.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/error.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/gccmacro.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:  /* PULSE, Simple API parameters */
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:  printf("\nPulseAudio <option>s: <none>\n");
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:SqModuleDefine(sound, pulse);
platforms/unix/config/configure:plugin="vm-sound-pulse"
platforms/unix/config/configure:rm -f vm-sound-pulse.sub vm-sound-pulse.lib
platforms/unix/config/configure:echo "$as_me:$LINENO: checking for PulseAudio" >&5
platforms/unix/config/configure:echo $ECHO_N "checking for PulseAudio... $ECHO_C" >&6
platforms/unix/config/configure:#include <pulse/simple.h>

So... I guess the /usr/include/pulse files must be there and the lib pulse-simple.a or .so must be there.  Maybe someone should update build.linux*/HowToBuild with instructions on how to install pulse development support.


--

On Tue, Sep 27, 2016 at 10:35 PM Phil (list) <[hidden email]> wrote:

This is still an issue as of the 9/27 build.  This would seem to be a
configuration/build bug as it effectively means that Spur doesn't play
nicely on the desktop w.r.t. sound for many Linux distros.

On Tue, 2016-09-06 at 09:20 -0700, tim Rowledge wrote:
>  
>
> >
> > On 06-09-2016, at 8:17 AM, Fabio Niephaus <[hidden email]>
> > wrote:
> >
> > On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]>
> > wrote:
> >
> > I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz
> > from ht
> > tps://bintray.com/package/files/opensmalltalk/vm/cog and it is
> > missing
> > the vm-sound-pulse module.  Is this a build issue or am I
> > downloading
> > from the wrong place?
> >
> > Bintray would be the right location, so I'm afraid it's a build
> > issue. But I'm not sure why...does anyone know more about this? 
>
> Only that the pulseaudio sound thing hasn’t been included in a while.
> Somebody with git/svn-fu could probably work out the history.
>
> tim
> --
> tim Rowledge; [hidden email]; http://www.rowledge.org/tim
> Two wrongs are only the beginning.
>
>




--
_,,,^..^,,,_
best, Eliot
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

Eliot Miranda-2
In reply to this post by fniephaus
 
oops...

On Thu, Oct 13, 2016 at 2:30 AM, Fabio Niephaus <[hidden email]> wrote:
 
What needs to be done to fix this? Anyone?

McStalker.oscogvm$ grep -Hi pulse platforms/unix/vm-sound-*/* platforms/unix/config/*
platforms/unix/vm-sound-pulse/Makefile.inc:PLIBS=-lpulse-simple
platforms/unix/vm-sound-pulse/acinclude.m4:AC_MSG_CHECKING([for PulseAudio])
platforms/unix/vm-sound-pulse/acinclude.m4:AC_TRY_COMPILE([#include <pulse/simple.h>],[(void)pa_simple_new;],[
platforms/unix/vm-sound-pulse/config.cmake:PLUGIN_REQUIRE_LIBRARY (PULSE pulse-simple)
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:/* sqUnixSoundPulseAudio.c -- sound module for Pulse Audio
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/simple.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/error.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:#include <pulse/gccmacro.h>
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:  /* PULSE, Simple API parameters */
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:  printf("\nPulseAudio <option>s: <none>\n");
platforms/unix/vm-sound-pulse/sqUnixSoundPulseAudio.c:SqModuleDefine(sound, pulse);
platforms/unix/config/configure:plugin="vm-sound-pulse"
platforms/unix/config/configure:rm -f vm-sound-pulse.sub vm-sound-pulse.lib
platforms/unix/config/configure:echo "$as_me:$LINENO: checking for PulseAudio" >&5
platforms/unix/config/configure:echo $ECHO_N "checking for PulseAudio... $ECHO_C" >&6
platforms/unix/config/configure:#include <pulse/simple.h>

So... I guess the /usr/include/pulse files must be there and the /usr/lib/libpulse-simple.a or .so must be there.  Maybe someone should update build.linux*/HowToBuild with instructions on how to install pulse development support.

On Tue, Sep 27, 2016 at 10:35 PM Phil (list) <[hidden email]> wrote:

This is still an issue as of the 9/27 build.  This would seem to be a
configuration/build bug as it effectively means that Spur doesn't play
nicely on the desktop w.r.t. sound for many Linux distros.

On Tue, 2016-09-06 at 09:20 -0700, tim Rowledge wrote:
>  
>
> >
> > On 06-09-2016, at 8:17 AM, Fabio Niephaus <[hidden email]>
> > wrote:
> >
> > On Tue, Sep 6, 2016 at 3:06 AM Phil (list) <[hidden email]>
> > wrote:
> >
> > I downloaded cog_linux32x86_squeak.cog.spur_201609052318.tar.gz
> > from ht
> > tps://bintray.com/package/files/opensmalltalk/vm/cog and it is
> > missing
> > the vm-sound-pulse module.  Is this a build issue or am I
> > downloading
> > from the wrong place?
> >
> > Bintray would be the right location, so I'm afraid it's a build
> > issue. But I'm not sure why...does anyone know more about this? 
>
> Only that the pulseaudio sound thing hasn’t been included in a while.
> Somebody with git/svn-fu could probably work out the history.
>
> tim
> --
> tim Rowledge; [hidden email]; http://www.rowledge.org/tim
> Two wrongs are only the beginning.
>
>




--
_,,,^..^,,,_
best, Eliot
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

timrowledge
In reply to this post by Eliot Miranda-2
 

> On 14-10-2016, at 10:23 AM, Eliot Miranda <[hidden email]> wrote:
> [snip]
> So... I guess the /usr/include/pulse files must be there and the lib pulse-simple.a or .so must be there.  Maybe someone should update build.linux*/HowToBuild with instructions on how to install pulse development support.

Just for fun I did an apt-get of libpulse… something or other on one of the Pi’s and tried a compile. It was a bit odd in that the pulseaudio stuff was built and even (kinda) works and yet in the config log etc there is no mention at all of it …

So, the build looks like it is probably ok but the code may have some issues. The symptom I recall is that the first few attempts at making noises works and then it gets poor quality and then stops altogether.

tim
--
tim Rowledge; [hidden email]; http://www.rowledge.org/tim
Strange OpCodes: CAO: Compare Apples to Oranges


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

timrowledge
 
Some more details on -

> On 31-12-2016, at 5:37 PM, tim Rowledge <[hidden email]> wrote:
>
>
>
>> On 14-10-2016, at 10:23 AM, Eliot Miranda <[hidden email]> wrote:
>> [snip]
>> So... I guess the /usr/include/pulse files must be there and the lib pulse-simple.a or .so must be there.  Maybe someone should update build.linux*/HowToBuild with instructions on how to install pulse development support.
>
> Just for fun I did an apt-get of libpulse… something or other on one of the Pi’s and tried a compile. It was a bit odd in that the pulseaudio stuff was built and even (kinda) works and yet in the config log etc there is no mention at all of it …
>
> So, the build looks like it is probably ok but the code may have some issues. The symptom I recall is that the first few attempts at making noises works and then it gets poor quality and then stops altogether.

I can play quite a few sounds with no problem and then after a while (*possibly* related to pressing keys at just the wrong time?) no sound but the system is otherwise OK. Then after a while it locks up the VM completely.

Turning on debugging printfs in the  vm-sound-pulse/SqUnixSoundPulseAudio.c file provides a minimally interesting log that finally reports
DBG: sqUnixSoundMaemo: >sound_Stop() (11, Resource temporarily unavailable)
though one must note that this DBG comes at the beginning of the routine and thus seems to require errno to have been set non-0 just before.
Attempts at asking Lt.Cmdr.Google for suggested pages mostly implied that that error message is rather annoyingly generic, though plenty of people seem to have seen it because of pulse audio problems.

Pointers to actually meaningful references would be appreciated.

tim
--
tim Rowledge; [hidden email]; http://www.rowledge.org/tim
Strange OpCodes: NNI: Neglect Next Instruction


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PulseAudio support not included in recent VM builds

Eliot Miranda-2
 


On Tue, Jan 3, 2017 at 6:02 PM, tim Rowledge <[hidden email]> wrote:

Some more details on -
> On 31-12-2016, at 5:37 PM, tim Rowledge <[hidden email]> wrote:
>
>
>
>> On 14-10-2016, at 10:23 AM, Eliot Miranda <[hidden email]> wrote:
>> [snip]
>> So... I guess the /usr/include/pulse files must be there and the lib pulse-simple.a or .so must be there.  Maybe someone should update build.linux*/HowToBuild with instructions on how to install pulse development support.
>
> Just for fun I did an apt-get of libpulse… something or other on one of the Pi’s and tried a compile. It was a bit odd in that the pulseaudio stuff was built and even (kinda) works and yet in the config log etc there is no mention at all of it …
>
> So, the build looks like it is probably ok but the code may have some issues. The symptom I recall is that the first few attempts at making noises works and then it gets poor quality and then stops altogether.

I can play quite a few sounds with no problem and then after a while (*possibly* related to pressing keys at just the wrong time?) no sound but the system is otherwise OK. Then after a while it locks up the VM completely.

Turning on debugging printfs in the  vm-sound-pulse/SqUnixSoundPulseAudio.c file provides a minimally interesting log that finally reports
DBG: sqUnixSoundMaemo: >sound_Stop() (11, Resource temporarily unavailable)
though one must note that this DBG comes at the beginning of the routine and thus seems to require errno to have been set non-0 just before.
Attempts at asking Lt.Cmdr.Google for suggested pages mostly implied that that error message is rather annoyingly generic, though plenty of people seem to have seen it because of pulse audio problems.

Pointers to actually meaningful references would be appreciated.

man 2 intro
 
tim
--
tim Rowledge; [hidden email]; http://www.rowledge.org/tim
Strange OpCodes: NNI: Neglect Next Instruction

_,,,^..^,,,_
best, Eliot
Loading...