Is repository down for Magma?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is repository down for Magma?

CdAB63
While loading Magma via:

((Smalltalk at: #ConfigurationOfMagma) project latestVersion) load.

I get:

Error: Could Not Resolve: Ma exception handling [Ma exception handling-cmm.33] in /home/casimiro/Desenvolvimento/Pharo/package-cache http:

And in debugger:

linearLoadPackageSpec: packageSpec gofer: gofer

where

packageSpec is:

spec
    name: 'Ma exception handling';
    file: 'Ma exception handling-cmm.33'.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Miguel Cobá
Unfortunately for all us, Chris deleted without notice, the versions
from Magma repository that were used by the Metacello configuration to
install Magma. So Magma isn't installable with Metacello anymore.

Last weekend I started a ground up rewrite for ConfigurationOfMagma with
support only for 1.2 (easier than fix the versions 1.1r43 1.1r44 that
could be installed with the configuration) but after creating
ConfigurationOfMaBase, ConfigurationOfMaClientServer and the new
ConfigurationOfMagma (everything loaded correctly) I got stuck by the
fact that the new Magma 1.2 is Squeak specific at the moment (it uses
WeakOrderedCollection that Chris pushed to Squeak trunk in december 2010
and that is not in Pharo 1.1, nor in Pharo 1.2). So, I could to publish
the new ConfigurationOfMagma to the metacello repository and you'll can
install Magma but it won't run anymore. (I have had time to check the
WeakOrderedCollection issue only, I don't know if after fixing that
other issues will remain because I haven't gone that far).

So, that is the state of affairs with the Magma on Pharo. Of course, you
can use the new ConfigurationOfMagma to load Magma on Squeak and it will
work good I think.

I will upload the new ConfigurationOfMagma right now anyway because the
old ConfigurationOfMagma are broken without hope of fix (at least from
me).

The way I am going to fix this, at least for Pharo 1.1.1 and Pharo 1.2,
is to put the changes that Magma needs in a separate package somewhere
(maybe PharoInbox or PharoTaskForces) and use it as a dependency in
ConfigurationOfMagma. This way it will work correctly. But I will do it
until tomorrow night.

Cheers

El mié, 23-02-2011 a las 11:42 -0300, Casimiro de Almeida Barreto
escribió:

> While loading Magma via:
>
> ((Smalltalk at: #ConfigurationOfMagma) project latestVersion) load.
>
> I get:
>
> Error: Could Not Resolve: Ma exception handling [Ma exception
> handling-cmm.33] in /home/casimiro/Desenvolvimento/Pharo/package-cache
> http:
>
> And in debugger:
>
> linearLoadPackageSpec: packageSpec gofer: gofer
>
> where
>
> packageSpec is:
>
> spec
>     name: 'Ma exception handling';
>     file: 'Ma exception handling-cmm.33'.

--
Miguel Cobá
http://twitter.com/MiguelCobaMtz
http://miguel.leugim.com.mx




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Chris Muller-3
Hi, please copy me or the Magma list if you want me to see things
soonish.  I saw this by luck.

> Unfortunately for all us, Chris deleted without notice, the versions

Incidentally, notice was posted on the Magma mailing list:

  http://lists.squeakfoundation.org/pipermail/magma/2011-February/001728.html

You can find the new actual load-scripts clicking the link provided in
that message.

Also, nothing has been deleted from MagmaTester yet, so all of the old
packages are still there.  However, I want to clean that up pretty
soon too..

> from Magma repository that were used by the Metacello configuration to
> install Magma. So Magma isn't installable with Metacello anymore.
>
> Last weekend I started a ground up rewrite for ConfigurationOfMagma with
> support only for 1.2 (easier than fix the versions 1.1r43 1.1r44 that

Yes, don't worry about those old Magma versions.  I won't be
supporting them anymore either.

> could be installed with the configuration) but after creating
> ConfigurationOfMaBase, ConfigurationOfMaClientServer and the new
> ConfigurationOfMagma (everything loaded correctly) I got stuck by the
> fact that the new Magma 1.2 is Squeak specific at the moment (it uses
> WeakOrderedCollection that Chris pushed to Squeak trunk in december 2010
> and that is not in Pharo 1.1, nor in Pharo 1.2).

Incidentally,

   http://lists.squeakfoundation.org/pipermail/magma/2010-November/001612.html

To incorporate this into Pharo, see the changes in Squeak between:

    Collections-ul.403 and Collections-cmm.404.

The changes are very simple.  Basically, we simply allow the
OrderedCollection's internal 'array' to be specified by its
#arrayType, instead of being hard-coded to an Array.

This allows WeakOrderedCollection to exist by only one single method,
an override of #arrayType on the class-side to specify WeakArray.

I do hope Pharo will incorporate these changes and gain the benefit of
a weak OrderedCollection, not to mention, Magma...!  C'mon Pharo, the
total gain in code-size is just one Class with a single one-line
method, plus one extra one-line method on OC.

> So, I could to publish
> the new ConfigurationOfMagma to the metacello repository and you'll can
> install Magma but it won't run anymore.

True, WeakOrderedCollection is crucial for the new proxy bulk-become
performance improvement.

> (I have had time to check the
> WeakOrderedCollection issue only, I don't know if after fixing that
> other issues will remain because I haven't gone that far).

Me either, we have to get this addressed first.  Would someone in
Pharo help me lobby for this?

> The way I am going to fix this, at least for Pharo 1.1.1 and Pharo 1.2,
> is to put the changes that Magma needs in a separate package somewhere
> (maybe PharoInbox or PharoTaskForces) and use it as a dependency in
> ConfigurationOfMagma. This way it will work correctly. But I will do it
> until tomorrow night.

Ok.  I hope if we can get past WeakOrderedCollection there won't be
any more special changes needed, but we'll have to see.

Thanks Miguel!

 - Chris

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Miguel Cobá
El jue, 24-02-2011 a las 15:40 -0600, Chris Muller escribió:
> Hi, please copy me or the Magma list if you want me to see things
> soonish.  I saw this by luck.

Yes, I forgot to CC. Sorry.

>
> > Unfortunately for all us, Chris deleted without notice, the versions
>
> Incidentally, notice was posted on the Magma mailing list:
>
>   http://lists.squeakfoundation.org/pipermail/magma/2011-February/001728.html

Yes, I saw that but the announce was after the deletion. Thats is why I
said without notice.

>
> You can find the new actual load-scripts clicking the link provided in
> that message.
>
> Also, nothing has been deleted from MagmaTester yet, so all of the old
> packages are still there.  However, I want to clean that up pretty
> soon too..

The configuration relied on the versions on Magma, given that that is
the official repository for released configuration.

>
> > from Magma repository that were used by the Metacello configuration to
> > install Magma. So Magma isn't installable with Metacello anymore.
> >
> > Last weekend I started a ground up rewrite for ConfigurationOfMagma with
> > support only for 1.2 (easier than fix the versions 1.1r43 1.1r44 that
>
> Yes, don't worry about those old Magma versions.  I won't be
> supporting them anymore either.

Ok, good to now! :)

>
> > could be installed with the configuration) but after creating
> > ConfigurationOfMaBase, ConfigurationOfMaClientServer and the new
> > ConfigurationOfMagma (everything loaded correctly) I got stuck by the
> > fact that the new Magma 1.2 is Squeak specific at the moment (it uses
> > WeakOrderedCollection that Chris pushed to Squeak trunk in december 2010
> > and that is not in Pharo 1.1, nor in Pharo 1.2).
>
> Incidentally,
>
>    http://lists.squeakfoundation.org/pipermail/magma/2010-November/001612.html
>
> To incorporate this into Pharo, see the changes in Squeak between:
>
>     Collections-ul.403 and Collections-cmm.404.
>
> The changes are very simple.  Basically, we simply allow the
> OrderedCollection's internal 'array' to be specified by its
> #arrayType, instead of being hard-coded to an Array.
>
> This allows WeakOrderedCollection to exist by only one single method,
> an override of #arrayType on the class-side to specify WeakArray.

Yes, I do now, I found that the changes are in fact small but that was
too late in sunday and I had no more energy after creating the other
configurations and testing that loaded correctly.

>
> I do hope Pharo will incorporate these changes and gain the benefit of
> a weak OrderedCollection, not to mention, Magma...!  C'mon Pharo, the
> total gain in code-size is just one Class with a single one-line
> method, plus one extra one-line method on OC.

Yes, nobody has said that they aren't going to be merged, it is just
that for Pharo 1.2 is frozen right now. So no new code can be added, it
will be added to 1.3 that recently opened to development. That is the
reason that I said that a little package with the changes will be
uploaded to some repository and used as a dependency for Magma on
Pharo1.2. For Pharo1.3 it won't be necessary.

>
> > So, I could to publish
> > the new ConfigurationOfMagma to the metacello repository and you'll can
> > install Magma but it won't run anymore.
>
> True, WeakOrderedCollection is crucial for the new proxy bulk-become
> performance improvement.
>
> > (I have had time to check the
> > WeakOrderedCollection issue only, I don't know if after fixing that
> > other issues will remain because I haven't gone that far).
>
> Me either, we have to get this addressed first.  Would someone in
> Pharo help me lobby for this?
>
> > The way I am going to fix this, at least for Pharo 1.1.1 and Pharo 1.2,
> > is to put the changes that Magma needs in a separate package somewhere
> > (maybe PharoInbox or PharoTaskForces) and use it as a dependency in
> > ConfigurationOfMagma. This way it will work correctly. But I will do it
> > until tomorrow night.
>
> Ok.  I hope if we can get past WeakOrderedCollection there won't be
> any more special changes needed, but we'll have to see.
>
> Thanks Miguel!

Nothing  to thank, I really want Magma on Pharo healthy, just that those
months I have had little time to maintain the configuration and the
weekend that I dedicated to it, it was too late when I discovered the
WeakOrderedCollection issue (especially because I had also to prepare
the fix to Pharo and report it. So I choose to sleep because next day is
workday :)

I hope this weekend I will finally finish the work and report the
enhancement to Pharo to be applied to Pharo1.3.

Cheers
>
>  - Chris
>

--
Miguel Cobá
http://twitter.com/MiguelCobaMtz
http://miguel.leugim.com.mx




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Stéphane Ducasse
In reply to this post by Miguel Cobá
In pharoTaskForces :)

On Feb 23, 2011, at 5:17 PM, Miguel Cobá wrote:

> Unfortunately for all us, Chris deleted without notice, the versions
> from Magma repository that were used by the Metacello configuration to
> install Magma. So Magma isn't installable with Metacello anymore.
>
> Last weekend I started a ground up rewrite for ConfigurationOfMagma with
> support only for 1.2 (easier than fix the versions 1.1r43 1.1r44 that
> could be installed with the configuration) but after creating
> ConfigurationOfMaBase, ConfigurationOfMaClientServer and the new
> ConfigurationOfMagma (everything loaded correctly) I got stuck by the
> fact that the new Magma 1.2 is Squeak specific at the moment (it uses
> WeakOrderedCollection that Chris pushed to Squeak trunk in december 2010
> and that is not in Pharo 1.1, nor in Pharo 1.2). So, I could to publish
> the new ConfigurationOfMagma to the metacello repository and you'll can
> install Magma but it won't run anymore. (I have had time to check the
> WeakOrderedCollection issue only, I don't know if after fixing that
> other issues will remain because I haven't gone that far).
>
> So, that is the state of affairs with the Magma on Pharo. Of course, you
> can use the new ConfigurationOfMagma to load Magma on Squeak and it will
> work good I think.
>
> I will upload the new ConfigurationOfMagma right now anyway because the
> old ConfigurationOfMagma are broken without hope of fix (at least from
> me).
>
> The way I am going to fix this, at least for Pharo 1.1.1 and Pharo 1.2,
> is to put the changes that Magma needs in a separate package somewhere
> (maybe PharoInbox or PharoTaskForces) and use it as a dependency in
> ConfigurationOfMagma. This way it will work correctly. But I will do it
> until tomorrow night.
>
> Cheers
>
> El mié, 23-02-2011 a las 11:42 -0300, Casimiro de Almeida Barreto
> escribió:
>> While loading Magma via:
>>
>> ((Smalltalk at: #ConfigurationOfMagma) project latestVersion) load.
>>
>> I get:
>>
>> Error: Could Not Resolve: Ma exception handling [Ma exception
>> handling-cmm.33] in /home/casimiro/Desenvolvimento/Pharo/package-cache
>> http:
>>
>> And in debugger:
>>
>> linearLoadPackageSpec: packageSpec gofer: gofer
>>
>> where
>>
>> packageSpec is:
>>
>> spec
>>    name: 'Ma exception handling';
>>    file: 'Ma exception handling-cmm.33'.
>
> --
> Miguel Cobá
> http://twitter.com/MiguelCobaMtz
> http://miguel.leugim.com.mx
>
>
>
>


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Stéphane Ducasse
In reply to this post by Miguel Cobá
BTW this is why I would like to have a copy of all the packages when we publish a configuration.
So that the world can explode and the user does not get impacted.

Stef


> Unfortunately for all us, Chris deleted without notice, the versions
> from Magma repository that were used by the Metacello configuration to
> install Magma. So Magma isn't installable with Metacello anymore.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Stéphane Ducasse
In reply to this post by Chris Muller-3
>
> To incorporate this into Pharo, see the changes in Squeak between:
>
>    Collections-ul.403 and Collections-cmm.404.
>
> The changes are very simple.  Basically, we simply allow the
> OrderedCollection's internal 'array' to be specified by its
> #arrayType, instead of being hard-coded to an Array.
>
> This allows WeakOrderedCollection to exist by only one single method,
> an override of #arrayType on the class-side to specify WeakArray.
>
> I do hope Pharo will incorporate these changes and gain the benefit of
> a weak OrderedCollection, not to mention, Magma...!  C'mon Pharo, the
> total gain in code-size is just one Class with a single one-line
> method, plus one extra one-line method on OC.

Chris since november and besides working pharo 1.2 I wrote 4 project proposals, a couple of article, bookchapters,
reviews for PhD, letters of recommandations...... lng list of meetings.....
So this is not that we do not want. This is that if people do not make that happens it is slow.

>> the new ConfigurationOfMagma to the metacello repository and you'll can
>> install Magma but it won't run anymore.
>
> True, WeakOrderedCollection is crucial for the new proxy bulk-become
> performance improvement.

what is it?

>> (I have had time to check the
>> WeakOrderedCollection issue only, I don't know if after fixing that
>> other issues will remain because I haven't gone that far).
>
> Me either, we have to get this addressed first.  Would someone in
> Pharo help me lobby for this?

Pharo does not have to be lobbied.
Just open a bug entry put the code and the tests, make sure that it works well
and discuss pros and cons in the mailing-list.

> Ok.  I hope if we can get past WeakOrderedCollection there won't be
> any more special changes needed, but we'll have to see.

Stef
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is repository down for Magma?

Miguel Cobá
In reply to this post by Stéphane Ducasse
El vie, 25-02-2011 a las 13:40 +0100, Stéphane Ducasse escribió:
> BTW this is why I would like to have a copy of all the packages when we publish a configuration.
> So that the world can explode and the user does not get impacted.

+ 1

>
> Stef
>
>
> > Unfortunately for all us, Chris deleted without notice, the versions
> > from Magma repository that were used by the Metacello configuration to
> > install Magma. So Magma isn't installable with Metacello anymore.
>
>

--
Miguel Cobá
http://twitter.com/MiguelCobaMtz
http://miguel.leugim.com.mx




Loading...