Comment #2 on issue 4550 by
[hidden email]: methodSymbol is a bad
name for selector
http://code.google.com/p/pharo/issues/detail?id=4550There is only one left :)
All the other ones are in code that should get removed. :)
contents: aString notifying: aController
"Accept the string as new source for the current method, and make certain
the annotation pane gets invalidated"
| existingSelector existingClass superResult newSelector |
existingSelector := self selectedMessageName.
existingClass := self selectedClassOrMetaClass.
superResult := super contents: aString notifying: aController.
superResult ifTrue: "succeeded"
[newSelector := existingClass parserClass new parseSelector: aString.
newSelector ~= existingSelector
ifTrue: "Selector changed -- maybe an addition"
[self reformulateList.
self changed: #messageList.
self messageList doWithIndex:
[:aMethodReference :anIndex |
(aMethodReference actualClass == existingClass and:
[aMethodReference selector == newSelector])
_______________________________________________
Pharo-bugtracker mailing list
[hidden email]
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-bugtracker