Issue 7314 in pharo: Improving robsutness of mcz repositories by filtering files not respecting naming convention

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue 7314 in pharo: Improving robsutness of mcz repositories by filtering files not respecting naming convention

pharo
Status: Accepted
Owner: [hidden email]
Labels: Type-Bug

New issue 7314 by [hidden email]: Improving robsutness of mcz  
repositories by filtering files not respecting naming convention
http://code.google.com/p/pharo/issues/detail?id=7314

We should modify readableFileNames to remove any files not following the  
naming pattern:

http://lists.squeakfoundation.org/pipermail/seaside-dev/2011-February/004558.html 
says

  <hyphenated-package-name>.<dotted.branch.tag>-<initials>.<count>.mcz

is it correct?



_______________________________________________
Pharo-bugtracker mailing list
[hidden email]
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-bugtracker
Reply | Threaded
Open this post in threaded view
|

Re: Issue 7314 in pharo: Improving robsutness of mcz repositories by filtering files not respecting naming convention

pharo

Comment #1 on issue 7314 by [hidden email]: Improving robsutness of  
mcz repositories by filtering files not respecting naming convention
http://code.google.com/p/pharo/issues/detail?id=7314

GoferVersionReference>>parseName: aString
        | basicName |
        basicName := aString last isDigit
                ifTrue: [ aString ]
                ifFalse: [ (aString copyUpToLast: $.) copyUpTo: $( ].
        package := basicName copyUpToLast: $-.
        (package includes: $.)
                ifFalse: [ branch := '' ]
                ifTrue: [
                        branch := package copyAfter: $..
                        package := package copyUpTo: $. ].
        author := (basicName copyAfterLast: $-) copyUpToLast: $..
        versionNumber := (basicName copyAfterLast: $-) copyAfterLast: $..
        (versionNumber notEmpty and: [ versionNumber allSatisfy: [ :each | each  
isDigit ] ])
                ifTrue: [ versionNumber := versionNumber asInteger ]
                ifFalse: [ versionNumber := 0 ]


_______________________________________________
Pharo-bugtracker mailing list
[hidden email]
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-bugtracker