Bug in _Inbox: Not Spam
• You are subscribed to this case
It is really a valuable feature to have the timed wait behavior of a condition variable - get the signal within the timeout period or return from the method call. I'd like to see the implementation changed to provide the feature implied by the name, rather than change the name and forget about what is really wanted. My use case comes from communicating with remote servers which may not reply. I'm porting code from other languages that use condition variables to coordinate transferring reply messages from a receiving thread or returning a timeout failure.