Metacello not updating any package from GitHub?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Metacello not updating any package from GitHub?

Christoph Thiede

Hi all,


it took me a few hours to find a bug in my image that was raised by an incompletely installed package. The problem only occurs in one of my images, but as my activities in this image were widely restricted to working with recent Inbox commits, I hoped to find a general reason of the defect.


I can reproduce the following: In my image, an old version of ToolIconsPlus is installed (it's just an example package). When I do


Installer ensureRecentMetacello.

Metacello new

repository: 'github://Salami555/Squeak-ToolIconsPlus:master';

baseline: 'ToolIconsPlus';

get;

load.

ToolIcons>>#iconNamed:


I receive a KeyNotFound error in the last statement. This is very strange as the package actually defines the method. When I try to update any other package, no new classes are installed at all. However, installing a new package does work, only updating an existing package does not. Installing the same example package in another image works as expected.


Do you have any ideas why this does happen or how to fix? I cannot remember having fiddled around the Metacello/Squot implementation in this image.


Running [Installer ensureRecentMetacello] did not help.


Best,

Christoph


_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners