Quantcast

MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Paul DeBruicker
Hi Dale,

The Metacello that is loaded by the ConfigurationOfSeaside3 does not include platform attributes for Squeak 4.6 & 5.0.  


Is there a version that does?


Here is a modified version of the #defaultPlatformAttributes method in the event its not been updated anywhere else:


defaultPlatformAttributes
        | attributes versionString |
        attributes := OrderedCollection with: #squeakCommon with: #squeak.
        Smalltalk
                at: #SystemVersion
                ifPresent: [:cl |
                        versionString := cl current version.
                        (versionString beginsWith: 'Squeak3.10')
                                ifTrue: [attributes add: #'squeak3.10.x'].
                        (versionString beginsWith: 'Squeak4')
                                ifTrue: [attributes add: #'squeak4.x'.
                                        (versionString beginsWith: 'Squeak4.1')
                                                ifTrue: [attributes add: #'squeak4.1.x']
                                                ifFalse: [(versionString beginsWith: 'Squeak4.2')
                                                                ifTrue: [attributes add: #'squeak4.2.x']
                                                                ifFalse: [(versionString beginsWith: 'Squeak4.3')
                                                                        ifTrue: [attributes add: #'squeak4.3.x']
                                                                        ifFalse: [(versionString beginsWith: 'Squeak4.4')
                                                                                ifTrue: [attributes add: #'squeak4.4.x']
                                                                                        ifFalse: [(versionString beginsWith: 'Squeak4.5')
                                                                                                ifTrue: [attributes add: #'squeak4.5.x']
                                                                                                ifFalse: [(versionString beginsWith: 'Squeak4.6')
                                                                                                ifTrue: [attributes add: #'squeak4.6.x']]]]]]].
                        (versionString beginsWith: 'Squeak5') ifTrue:[attributes add: #'squeak5.x']].
        ^ attributes

--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Dale Henrichs-3
I'm not sure that Metacello has been ported (or port completed) for
Squeak 4.6 and 5.0...

Dale

On 08/20/2015 10:14 AM, Paul DeBruicker wrote:

> Hi Dale,
>
> The Metacello that is loaded by the ConfigurationOfSeaside3 does not include platform attributes for Squeak 4.6 & 5.0.
>
>
> Is there a version that does?
>
>
> Here is a modified version of the #defaultPlatformAttributes method in the event its not been updated anywhere else:
>
>
> defaultPlatformAttributes
> | attributes versionString |
> attributes := OrderedCollection with: #squeakCommon with: #squeak.
> Smalltalk
> at: #SystemVersion
> ifPresent: [:cl |
> versionString := cl current version.
> (versionString beginsWith: 'Squeak3.10')
> ifTrue: [attributes add: #'squeak3.10.x'].
> (versionString beginsWith: 'Squeak4')
> ifTrue: [attributes add: #'squeak4.x'.
> (versionString beginsWith: 'Squeak4.1')
> ifTrue: [attributes add: #'squeak4.1.x']
> ifFalse: [(versionString beginsWith: 'Squeak4.2')
> ifTrue: [attributes add: #'squeak4.2.x']
> ifFalse: [(versionString beginsWith: 'Squeak4.3')
> ifTrue: [attributes add: #'squeak4.3.x']
> ifFalse: [(versionString beginsWith: 'Squeak4.4')
> ifTrue: [attributes add: #'squeak4.4.x']
> ifFalse: [(versionString beginsWith: 'Squeak4.5')
> ifTrue: [attributes add: #'squeak4.5.x']
> ifFalse: [(versionString beginsWith: 'Squeak4.6')
> ifTrue: [attributes add: #'squeak4.6.x']]]]]]].
> (versionString beginsWith: 'Squeak5') ifTrue:[attributes add: #'squeak5.x']].
> ^ attributes
>

--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Paul DeBruicker
Dale Henrichs-3 wrote
I'm not sure that Metacello has been ported (or port completed) for
Squeak 4.6 and 5.0...

Dale

OK, well with that change Seaside loads, so its not far off regardless. I'll load the tests and see if anything is breaking.   The Seaside script loads Metacello from  'http://www.squeaksource.com/MetacelloRepository' 
or 'http://seaside.gemstone.com/ss/metacello'.  Is that the best place to grab the latest stable version?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Dale Henrichs-3
Paul,

I think that Metacello should be installed into squeak using the
github-based instructions[1]. Especially for Seaside3 since I'm pretty
sure that the configuration uses some of the advanced features ...

FWIW I think that Tobias Pape is trying to get Metacello pre-installed
in Squeak so that the long involved install is not necessary ....

We can look at this at Camp Smalltalk (PDX) if you want ..

Dale

[1] https://github.com/dalehenrich/metacello-work#squeak

On 08/20/2015 10:41 AM, Paul DeBruicker wrote:

> Dale Henrichs-3 wrote
>> I'm not sure that Metacello has been ported (or port completed) for
>> Squeak 4.6 and 5.0...
>>
>> Dale
>
> OK, well with that change Seaside loads, so its not far off regardless. I'll
> load the tests and see if anything is breaking.   The Seaside script loads
> Metacello from  'http://www.squeaksource.com/MetacelloRepository'
> or 'http://seaside.gemstone.com/ss/metacello'.  Is that the best place to
> grab the latest stable version?
>
>
>
> --
> View this message in context: http://forum.world.st/MetacelloSqueakPlatform-defaultPlatformAttributes-needs-an-update-tp4844596p4844607.html
> Sent from the Metacello mailing list archive at Nabble.com.
>

--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Tobias Pape-3

On 20.08.2015, at 20:54, Dale Henrichs <[hidden email]> wrote:

> Paul,
>
> I think that Metacello should be installed into squeak using the github-based instructions[1]. Especially for Seaside3 since I'm pretty sure that the configuration uses some of the advanced features ...
>

See https://github.com/dalehenrich/metacello-work/pull/357

Best regards
        -Tobias


> FWIW I think that Tobias Pape is trying to get Metacello pre-installed in Squeak so that the long involved install is not necessary ....
>
> We can look at this at Camp Smalltalk (PDX) if you want ..
>
> Dale
>
> [1] https://github.com/dalehenrich/metacello-work#squeak
>
> On 08/20/2015 10:41 AM, Paul DeBruicker wrote:
>> Dale Henrichs-3 wrote
>>> I'm not sure that Metacello has been ported (or port completed) for
>>> Squeak 4.6 and 5.0...
>>>
>>> Dale
>>
>> OK, well with that change Seaside loads, so its not far off regardless. I'll
>> load the tests and see if anything is breaking.   The Seaside script loads
>> Metacello from  'http://www.squeaksource.com/MetacelloRepository'
>> or 'http://seaside.gemstone.com/ss/metacello'.  Is that the best place to
>> grab the latest stable version?
>>
>>
>>
>> --
>> View this message in context: http://forum.world.st/MetacelloSqueakPlatform-defaultPlatformAttributes-needs-an-update-tp4844596p4844607.html
>> Sent from the Metacello mailing list archive at Nabble.com.



--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Dale Henrichs-3


On 08/20/2015 12:03 PM, Tobias Pape wrote:

> On 20.08.2015, at 20:54, Dale Henrichs <[hidden email]> wrote:
>
>> Paul,
>>
>> I think that Metacello should be installed into squeak using the github-based instructions[1]. Especially for Seaside3 since I'm pretty sure that the configuration uses some of the advanced features ...
>>
> See https://github.com/dalehenrich/metacello-work/pull/357
>
> Best regards
> -Tobias
>

But....the .travis.yml file doesn't have entries for Squeak4.6 or
Squeak5.0, so I don't know (via running tests with travis) that
Metacello works on those releases[1] ...

Dale

[1]
https://github.com/dalehenrich/metacello-work/pull/357#issuecomment-128866583

--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Tobias Pape-3

On 20.08.2015, at 21:07, Dale Henrichs <[hidden email]> wrote:

> On 08/20/2015 12:03 PM, Tobias Pape wrote:
>> On 20.08.2015, at 20:54, Dale Henrichs <[hidden email]> wrote:
>>
>>> Paul,
>>>
>>> I think that Metacello should be installed into squeak using the github-based instructions[1]. Especially for Seaside3 since I'm pretty sure that the configuration uses some of the advanced features ...
>>>
>> See https://github.com/dalehenrich/metacello-work/pull/357
>>
>> Best regards
>> -Tobias
>>
>
> But....the .travis.yml file doesn't have entries for Squeak4.6 or Squeak5.0, so I don't know (via running tests with travis) that Metacello works on those releases[1] ...
>

I know, sorry, I was just pointing out that code exists.
At that point in time, the releases did actually not exist yet, so
I deferred that. Hence my inexcusable silence.



> Dale
>
> [1] https://github.com/dalehenrich/metacello-work/pull/357#issuecomment-128866583



--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Dale Henrichs-3


On 08/20/2015 12:33 PM, Tobias Pape wrote:

> On 20.08.2015, at 21:07, Dale Henrichs <[hidden email]> wrote:
>
>> On 08/20/2015 12:03 PM, Tobias Pape wrote:
>>> On 20.08.2015, at 20:54, Dale Henrichs <[hidden email]> wrote:
>>>
>>>> Paul,
>>>>
>>>> I think that Metacello should be installed into squeak using the github-based instructions[1]. Especially for Seaside3 since I'm pretty sure that the configuration uses some of the advanced features ...
>>>>
>>> See https://github.com/dalehenrich/metacello-work/pull/357
>>>
>>> Best regards
>>> -Tobias
>>>
>> But....the .travis.yml file doesn't have entries for Squeak4.6 or Squeak5.0, so I don't know (via running tests with travis) that Metacello works on those releases[1] ...
>>
> I know, sorry, I was just pointing out that code exists.
> At that point in time, the releases did actually not exist yet, so
> I deferred that. Hence my inexcusable silence.
>

I guess the big question at this moment is: "how much work is required
to get Metacello running on Squeak4.6 and Squeak5.0?"

Barring significant changes in the API, Metacello should be expected to
run and pass the majority of tests, right?

Dale

--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MetacelloSqueakPlatform>>#defaultPlatformAttributes needs an update -

Tobias Pape-3

On 20.08.2015, at 21:37, Dale Henrichs <[hidden email]> wrote:

> On 08/20/2015 12:33 PM, Tobias Pape wrote:
>> On 20.08.2015, at 21:07, Dale Henrichs <[hidden email]> wrote:
>>
>>> On 08/20/2015 12:03 PM, Tobias Pape wrote:
>>>> On 20.08.2015, at 20:54, Dale Henrichs <[hidden email]> wrote:
>>>>
>>>>> Paul,
>>>>>
>>>>> I think that Metacello should be installed into squeak using the github-based instructions[1]. Especially for Seaside3 since I'm pretty sure that the configuration uses some of the advanced features ...
>>>>>
>>>> See https://github.com/dalehenrich/metacello-work/pull/357
>>>>
>>>> Best regards
>>>> -Tobias
>>>>
>>> But....the .travis.yml file doesn't have entries for Squeak4.6 or Squeak5.0, so I don't know (via running tests with travis) that Metacello works on those releases[1] ...
>>>
>> I know, sorry, I was just pointing out that code exists.
>> At that point in time, the releases did actually not exist yet, so
>> I deferred that. Hence my inexcusable silence.
>>
>
> I guess the big question at this moment is: "how much work is required to get Metacello running on Squeak4.6 and Squeak5.0?"
>
> Barring significant changes in the API, Metacello should be expected to run and pass the majority of tests, right?

Yes.
I have used it already :)



--
You received this message because you are subscribed to the Google Groups "Metacello" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...