Need help opening image

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Need help opening image

cdavidshaffer
I have an image (from Pharo3.0) which reports version 6505.  I have tried four OSX vms but none of them will open it.  Either I get “This interpreter (vers. X) cannot read image file (vers. 6505)” or I get hit with a long stream of:

[NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to …

which I know is a known bug.  The problem is, I can’t find a VM that doesn’t have this bug but can open my old image format (on OSX).  Any pointers would be appreciated.

Thanks!

David


Reply | Threaded
Open this post in threaded view
|

Re: Need help opening image

Paul DeBruicker
Some old VMs are archived here:


http://files.pharo.org/vm/old/stack/mac/




Also the squeak VM's should open images that old some of which are here:

http://www.squeakvm.org/mac/

and SqueakJS may be able to run it here:


https://squeak.js.org




cdavidshaffer wrote
I have an image (from Pharo3.0) which reports version 6505.  I have tried four OSX vms but none of them will open it.  Either I get “This interpreter (vers. X) cannot read image file (vers. 6505)” or I get hit with a long stream of:

[NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to …

which I know is a known bug.  The problem is, I can’t find a VM that doesn’t have this bug but can open my old image format (on OSX).  Any pointers would be appreciated.

Thanks!

David
Reply | Threaded
Open this post in threaded view
|

Re: Need help opening image

Clément Bera-4
In reply to this post by cdavidshaffer
Hi,

You need a VM with the SqueakV3 memory manager and compiled in the past few months for Mac OS X Sierra support.

All recent Pharo VM are compiled with the Spur memory manager leading to this error “This interpreter (vers. X) cannot read image file (vers. 6505)”.

I would try the latest VM from this repository (latest.zip):

If you get the second error ( [NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to … ), it means the VM is too old and does not support Mac OS X Sierra.

In this case, try instead the VM named: 
cog_macos32x86_squeak.cog.v3_201703051406.tar.gz
present at:

It should work but it is not a Pharo VM hence some features may be disabled (specific VM plugins, etc.). Depending on your use-case it may be enough or not.

Best,


On Sun, Mar 12, 2017 at 4:57 PM, David Shaffer <[hidden email]> wrote:
I have an image (from Pharo3.0) which reports version 6505.  I have tried four OSX vms but none of them will open it.  Either I get “This interpreter (vers. X) cannot read image file (vers. 6505)” or I get hit with a long stream of:

[NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to …

which I know is a known bug.  The problem is, I can’t find a VM that doesn’t have this bug but can open my old image format (on OSX).  Any pointers would be appreciated.

Thanks!

David



Reply | Threaded
Open this post in threaded view
|

Re: Need help opening image

cdavidshaffer

On Mar 12, 2017, at 9:46 PM, Clément Bera <[hidden email]> wrote:

Hi,

You need a VM with the SqueakV3 memory manager and compiled in the past few months for Mac OS X Sierra support.

All recent Pharo VM are compiled with the Spur memory manager leading to this error “This interpreter (vers. X) cannot read image file (vers. 6505)”.

I would try the latest VM from this repository (latest.zip):

If you get the second error ( [NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to … ), it means the VM is too old and does not support Mac OS X Sierra.

In this case, try instead the VM named: 
cog_macos32x86_squeak.cog.v3_201703051406.tar.gz
present at:

It should work but it is not a Pharo VM hence some features may be disabled (specific VM plugins, etc.). Depending on your use-case it may be enough or not.

Thanks guys!  The second image (cog_macos32x86_squeak.cog…) seems to be working great.  The “latest.zip” image gives the NSPathStore2 errors.

David


Reply | Threaded
Open this post in threaded view
|

Re: Need help opening image

EstebanLM
In reply to this post by cdavidshaffer
for Pharo3 (for any image up to 4.0), you need to download this VM: 


so you will have a pharovm (with our plugin configuration, etc.)

cheers, 
Esteban


On 13 Mar 2017, at 00:57, David Shaffer <[hidden email]> wrote:

I have an image (from Pharo3.0) which reports version 6505.  I have tried four OSX vms but none of them will open it.  Either I get “This interpreter (vers. X) cannot read image file (vers. 6505)” or I get hit with a long stream of:

[NSPathStore2 stringByAppendingPathExtension:]: cannot append extension 'bundle/Contents/MacOS/' to …

which I know is a known bug.  The problem is, I can’t find a VM that doesn’t have this bug but can open my old image format (on OSX).  Any pointers would be appreciated.

Thanks!

David