OSX Build broken past 2 months - could not find a valid SDK

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

OSX Build broken past 2 months - could not find a valid SDK

Ben Coman
 

OSX builds have been broken and not built the past 2 months...

since commit "Update minimum SDK for 64-bit Mac to 10.12 (for metal)"...


- #Build the oldest SDK installed (must be MacOSX10.11.sdk because of Metal and later)
+ #Build oldest installed SDK (must be MacOSX10.12.sdk because of Metal and later)

- SDKs:=MacOSX10.11.sdk MacOSX10.12.sdk MacOSX10.13.sdk MacOSX10.14.sdk
+ SDKs:=MacOSX10.12.sdk MacOSX10.13.sdk MacOSX10.14.sdk

The fix is potentially not difficult. Our travis.yml specifies...
     osx_image: xcode7.3

is shown to be OSX 10.11, which was just removed.

It seems we have four options: xcode9.2, xcode9.1, xcode9, xcode8.3.
Can someone with OSX experience please choose one and commit it for Travis to check?
This will facilitate correct results for CI testing of PRs. 

cheers -ben