OpenDBX not loading on pharo 2.0 (Windows 7 - 64 bits) - Retrocompatiblity issue?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

OpenDBX not loading on pharo 2.0 (Windows 7 - 64 bits) - Retrocompatiblity issue?

Jose.Larroque
This post has NOT been accepted by the mailing list yet.
This post was updated on .
Hi guys, sorry if i'm asking something previously asked, but reading the last mails doesn't clarifiy me if OpenDBX can be loaded correctly in Pharo (i'm using Pharo 2.0) or not (i saw some FFI problems related to the load in previous messages).

I am installing it with this code:

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfOpenDBXDriver';
    load.

(((Smalltalk at: #ConfigurationOfOpenDBXDriver)
    perform: #project)
        perform: #version: with: #stable)
            load.

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfGlorpDBX';
    load.

(((Smalltalk at: #ConfigurationOfGlorpDBX)
    perform: #project)
        perform: #version: with: '2.5')
            load


But the last part generates an error related to some dependencies, i believe that this has something to do with the latest changes in FFI, i upload an image with this problem:

Problem loading OpenDBX on Pharo 2.0 - FFI related

I execute this code some time ago an it was working. So, any recomendation? This can't be installed in Pharo 2.0 anymore? (I understand that this problem is related to something with Pharo 3.0, but i can't swich from Pharo 2.0 to 3.0)

Bye!
Jose