Pharo 6 Segmentation fault on Travis OS X

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Pharo 6 Segmentation fault on Travis OS X

Juraj Kubelka-2
 
Hi,

I have noticed that Pharo 6 VM is quite unstable on OS X. I do not face it on my desktop, but my Travis CI builds are mostly broken. See the example here: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L258 

Segmentation fault Thu Apr 20 23:31:54 2017
VM: 201702221539 https://github.com/pharo-project/pharo-vm.git $ Date: Wed Feb 22 16:39:40 2017 +0100 $
C stack backtrace & registers:
eax 0x00000000 ebx 0x044f9014 ecx 0x044f9014 edx 0x00000000
edi 0x044f7a7d esi 0x044f7a7d ebp 0xbffabae8 esp 0xbffabaa0
eip 0x000689e6
0 Pharo 0x000689e6 bytecodePCForstartBcpcin + 195
1 Pharo 0x000961be reportStackState + 706


The same build task is stable on Windows and Linux.

If some of the builds are green, it is because I have restarted the job, typically several times. 

There is also this issue at the beginning of the log: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L84 


62.56sDownloading the latest pharoVM:
pharo-vm/Pharo.app/Contents/MacOS/Pharo
Downloading PharoV60.sources:
Creating starter scripts pharo and pharo-ui
2017-04-20 23:30:25.180 Pharo[2532:5750] 23:30:25.180 ERROR: 312: error -66680
2017-04-20 23:30:25.182 Pharo[2532:5750] 23:30:25.182 ERROR: >aq> 1630: failed (-66680); will stop (5512/0 frames)
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR: 312: error -66680
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR: >aq> 1630: failed (-66680); will stop (33075/0 frames)
Any idea how can it be improved? Or how can I debug it in order to provide more information? 

Thanks!
Juraj


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pharo 6 Segmentation fault on Travis OS X

Eliot Miranda-2
 


On Thu, Apr 20, 2017 at 5:11 PM, Juraj Kubelka <[hidden email]> wrote:
 
Hi,

I have noticed that Pharo 6 VM is quite unstable on OS X. I do not face it on my desktop, but my Travis CI builds are mostly broken. See the example here: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L258 

Segmentation fault Thu Apr 20 23:31:54 2017
VM: 201702221539 https://github.com/pharo-project/pharo-vm.git $ Date: Wed Feb 22 16:39:40 2017 +0100 $
C stack backtrace & registers:
eax 0x00000000 ebx 0x044f9014 ecx 0x044f9014 edx 0x00000000
edi 0x044f7a7d esi 0x044f7a7d ebp 0xbffabae8 esp 0xbffabaa0
eip 0x000689e6
0 Pharo 0x000689e6 bytecodePCForstartBcpcin + 195
1 Pharo 0x000961be reportStackState + 706


The same build task is stable on Windows and Linux.

If some of the builds are green, it is because I have restarted the job, typically several times. 

There is also this issue at the beginning of the log: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L84 


62.56sDownloading the latest pharoVM:
pharo-vm/Pharo.app/Contents/MacOS/Pharo
Downloading PharoV60.sources:
Creating starter scripts pharo and pharo-ui
2017-04-20 23:30:25.180 Pharo[2532:5750] 23:30:25.180 ERROR: 312: error -66680
2017-04-20 23:30:25.182 Pharo[2532:5750] 23:30:25.182 ERROR: >aq> 1630: failed (-66680); will stop (5512/0 frames)
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR: 312: error -66680
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR: >aq> 1630: failed (-66680); will stop (33075/0 frames)
Any idea how can it be improved? Or how can I debug it in order to provide more information? 

Have you tried building your own Pharo VM from the opensmalltalk-vm sources?  Any more or less stable?
 

Thanks!
Juraj






--
_,,,^..^,,,_
best, Eliot
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pharo 6 Segmentation fault on Travis OS X

Ben Coman
In reply to this post by Juraj Kubelka-2
 
On Fri, Apr 21, 2017 at 8:11 AM, Juraj Kubelka <[hidden email]> wrote:

>
> Hi,
>
> I have noticed that Pharo 6 VM is quite unstable on OS X. I do not face it on my desktop, but my Travis CI builds are mostly broken. See the example here: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L258
>
> Segmentation fault Thu Apr 20 23:31:54 2017
> VM: 201702221539 https://github.com/pharo-project/pharo-vm.git $ Date: Wed Feb 22 16:39:40 2017 +0100 $
> Plugins: 201702221539 https://github.com/pharo-project/pharo-vm.git $
> C stack backtrace & registers:
> eax 0x00000000 ebx 0x044f9014 ecx 0x044f9014 edx 0x00000000
> edi 0x044f7a7d esi 0x044f7a7d ebp 0xbffabae8 esp 0xbffabaa0
> eip 0x000689e6
> 0   Pharo                               0x000689e6 bytecodePCForstartBcpcin + 195
> 1   Pharo                               0x000961be reportStackState + 706
>
>
>
> The same build task is stable on Windows and Linux.
>
> If some of the builds are green, it is because I have restarted the job, typically several times.
>
> There is also this issue at the beginning of the log: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L84
>
>
> 62.56sDownloading the latest pharoVM:
> http://files.pharo.org/get-files/60/pharo-mac-stable.zip
> pharo-vm/Pharo.app/Contents/MacOS/Pharo
> Downloading PharoV60.sources:
> http://files.pharo.org/get-files/60/sources.zip
> Creating starter scripts pharo and pharo-ui
> 2017-04-20 23:30:25.180 Pharo[2532:5750] 23:30:25.180 ERROR:    312: error -66680
> 2017-04-20 23:30:25.182 Pharo[2532:5750] 23:30:25.182 ERROR:    >aq> 1630: failed (-66680); will stop (5512/0 frames)
> 2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    312: error -66680
> 2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    >aq> 1630: failed (-66680); will stop (33075/0 frames)
>
> Any idea how can it be improved? Or how can I debug it in order to provide more information?
>
> Thanks!
> Juraj
>
>
>

https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L297-L299
Smalltalk stack dump:
0xbffb7ae8 I SessionManager>snapshot:andQuit: 0x5a26fd0: a(n) SessionManager
0xbffb7b18 I [] in SmalltalkImage>snapshot:andQuit: 0x4fc3410: a(n)
SmalltalkImage

Maybe it is be the Compactor bug,
http://forum.world.st/Crashes-on-snapshot-with-the-new-compactor-td4939959.html#a4942434

introduced I guess per this commit...
    Date:   Sat Feb 18 07:43:47 2017 -0800
    CogVM source as per VMMaker.oscog-eem.2134
    Move the SpurPlanningCompactor to tip.

and fixed
    Date:   Mon Apr 10 19:37:04 2017 +0200
    SpurPlanningCompactor:
    Fix a bug in resetting the free chunk used for the
firstUnusedFieldsSpace after
    non-final pasxses (i.e. on snapshot).  The old code didn't check to see if a
    free chunk was actually found(!!).

where that VM http://files.pharo.org/get-files/60/pharo-mac-stable.zip
falls in between
   VM: 201702221539 [...]  Date: Wed Feb 22 [...]

Try with http://files.pharo.org/get-files/60/pharo-mac-latest.zip

@Esteban, when you're back from vacation, probably good to bump stable prior
doing it again(?) at Pharo 6 release.

cheers -ben
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pharo 6 Segmentation fault on Travis OS X

Juraj Kubelka-2
 
Hi,

you are right, with the get.pharo.org/vmLatest60  it works well. Unfortunately, I cannot set this on Travis. It would be nice to make a new stable release.

Thanks!
Juraj

El 21-04-2017, a las 00:30, Ben Coman <[hidden email]> escribió:


On Fri, Apr 21, 2017 at 8:11 AM, Juraj Kubelka <[hidden email]> wrote:

Hi,

I have noticed that Pharo 6 VM is quite unstable on OS X. I do not face it on my desktop, but my Travis CI builds are mostly broken. See the example here: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L258

Segmentation fault Thu Apr 20 23:31:54 2017
VM: 201702221539 https://github.com/pharo-project/pharo-vm.git $ Date: Wed Feb 22 16:39:40 2017 +0100 $
Plugins: 201702221539 https://github.com/pharo-project/pharo-vm.git $
C stack backtrace & registers:
eax 0x00000000 ebx 0x044f9014 ecx 0x044f9014 edx 0x00000000
edi 0x044f7a7d esi 0x044f7a7d ebp 0xbffabae8 esp 0xbffabaa0
eip 0x000689e6
0   Pharo                               0x000689e6 bytecodePCForstartBcpcin + 195
1   Pharo                               0x000961be reportStackState + 706



The same build task is stable on Windows and Linux.

If some of the builds are green, it is because I have restarted the job, typically several times.

There is also this issue at the beginning of the log: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L84


62.56sDownloading the latest pharoVM:
http://files.pharo.org/get-files/60/pharo-mac-stable.zip
pharo-vm/Pharo.app/Contents/MacOS/Pharo
Downloading PharoV60.sources:
http://files.pharo.org/get-files/60/sources.zip
Creating starter scripts pharo and pharo-ui
2017-04-20 23:30:25.180 Pharo[2532:5750] 23:30:25.180 ERROR:    312: error -66680
2017-04-20 23:30:25.182 Pharo[2532:5750] 23:30:25.182 ERROR:    >aq> 1630: failed (-66680); will stop (5512/0 frames)
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    312: error -66680
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    >aq> 1630: failed (-66680); will stop (33075/0 frames)

Any idea how can it be improved? Or how can I debug it in order to provide more information?

Thanks!
Juraj




https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L297-L299
Smalltalk stack dump:
0xbffb7ae8 I SessionManager>snapshot:andQuit: 0x5a26fd0: a(n) SessionManager
0xbffb7b18 I [] in SmalltalkImage>snapshot:andQuit: 0x4fc3410: a(n)
SmalltalkImage

Maybe it is be the Compactor bug,
http://forum.world.st/Crashes-on-snapshot-with-the-new-compactor-td4939959.html#a4942434

introduced I guess per this commit...
   Date:   Sat Feb 18 07:43:47 2017 -0800
   CogVM source as per VMMaker.oscog-eem.2134
   Move the SpurPlanningCompactor to tip.

and fixed
   Date:   Mon Apr 10 19:37:04 2017 +0200
   SpurPlanningCompactor:
   Fix a bug in resetting the free chunk used for the
firstUnusedFieldsSpace after
   non-final pasxses (i.e. on snapshot).  The old code didn't check to see if a
   free chunk was actually found(!!).

where that VM http://files.pharo.org/get-files/60/pharo-mac-stable.zip
falls in between
  VM: 201702221539 [...]  Date: Wed Feb 22 [...]

Try with http://files.pharo.org/get-files/60/pharo-mac-latest.zip

@Esteban, when you're back from vacation, probably good to bump stable prior
doing it again(?) at Pharo 6 release.

cheers -ben

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pharo 6 Segmentation fault on Travis OS X

Juraj Kubelka-2
In reply to this post by Ben Coman
 
Hi!

I notice the same issue, reported recently, even with the latest Pharo VM: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/226952575#L257 

Segmentation fault Fri Apr 28 20:13:09 2017
VM: 201704281504 https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Fri Apr 28 17:04:48 2017 +0200 $
Plugins: 201704281504 https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
C stack backtrace & registers:
eax 0x00000000 ebx 0x04539374 ecx 0x04539374 edx 0x00000000
edi 0x0452e0b8 esi 0x0452e0b8 ebp 0xbff15ac8 esp 0xbff15a60
eip 0x00104a08
0   Pharo                               0x00104a08 bytecodePCForstartBcpcin + 183
1   Pharo                               0x00138223 reportStackState + 819
2   Pharo                               0x001385c7 sigsegv + 167

Any idea how I could help to fix it or provide more information?

> Eliot: Have you tried building your own Pharo VM from the opensmalltalk-vm sources?  Any more or less stable?

No I have not tried to build my own vm. Should I? Currently I use the latest VM, as the stable VM for Pharo 6.0 is unstable. 

Thanks!
Juraj

On Apr 21, 2017, at 00:30, Ben Coman <[hidden email]> wrote:


On Fri, Apr 21, 2017 at 8:11 AM, Juraj Kubelka <[hidden email]> wrote:

Hi,

I have noticed that Pharo 6 VM is quite unstable on OS X. I do not face it on my desktop, but my Travis CI builds are mostly broken. See the example here: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L258

Segmentation fault Thu Apr 20 23:31:54 2017
VM: 201702221539 https://github.com/pharo-project/pharo-vm.git $ Date: Wed Feb 22 16:39:40 2017 +0100 $
Plugins: 201702221539 https://github.com/pharo-project/pharo-vm.git $
C stack backtrace & registers:
eax 0x00000000 ebx 0x044f9014 ecx 0x044f9014 edx 0x00000000
edi 0x044f7a7d esi 0x044f7a7d ebp 0xbffabae8 esp 0xbffabaa0
eip 0x000689e6
0   Pharo                               0x000689e6 bytecodePCForstartBcpcin + 195
1   Pharo                               0x000961be reportStackState + 706



The same build task is stable on Windows and Linux.

If some of the builds are green, it is because I have restarted the job, typically several times.

There is also this issue at the beginning of the log: https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L84


62.56sDownloading the latest pharoVM:
http://files.pharo.org/get-files/60/pharo-mac-stable.zip
pharo-vm/Pharo.app/Contents/MacOS/Pharo
Downloading PharoV60.sources:
http://files.pharo.org/get-files/60/sources.zip
Creating starter scripts pharo and pharo-ui
2017-04-20 23:30:25.180 Pharo[2532:5750] 23:30:25.180 ERROR:    312: error -66680
2017-04-20 23:30:25.182 Pharo[2532:5750] 23:30:25.182 ERROR:    >aq> 1630: failed (-66680); will stop (5512/0 frames)
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    312: error -66680
2017-04-20 23:30:25.184 Pharo[2532:5750] 23:30:25.184 ERROR:    >aq> 1630: failed (-66680); will stop (33075/0 frames)

Any idea how can it be improved? Or how can I debug it in order to provide more information?

Thanks!
Juraj




https://travis-ci.org/JurajKubelka/PharoSprint/jobs/224161107#L297-L299
Smalltalk stack dump:
0xbffb7ae8 I SessionManager>snapshot:andQuit: 0x5a26fd0: a(n) SessionManager
0xbffb7b18 I [] in SmalltalkImage>snapshot:andQuit: 0x4fc3410: a(n)
SmalltalkImage

Maybe it is be the Compactor bug,
http://forum.world.st/Crashes-on-snapshot-with-the-new-compactor-td4939959.html#a4942434

introduced I guess per this commit...
   Date:   Sat Feb 18 07:43:47 2017 -0800
   CogVM source as per VMMaker.oscog-eem.2134
   Move the SpurPlanningCompactor to tip.

and fixed
   Date:   Mon Apr 10 19:37:04 2017 +0200
   SpurPlanningCompactor:
   Fix a bug in resetting the free chunk used for the
firstUnusedFieldsSpace after
   non-final pasxses (i.e. on snapshot).  The old code didn't check to see if a
   free chunk was actually found(!!).

where that VM http://files.pharo.org/get-files/60/pharo-mac-stable.zip
falls in between
  VM: 201702221539 [...]  Date: Wed Feb 22 [...]

Try with http://files.pharo.org/get-files/60/pharo-mac-latest.zip

@Esteban, when you're back from vacation, probably good to bump stable prior
doing it again(?) at Pharo 6 release.

cheers -ben

Loading...