Pier CMS status for Pharo 4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Pier CMS status for Pharo 4.0

dtrussardi@tiscali.it
Ciao,

        i have a Pharo4.0 Latest update: #40625

        where i install, from Configuration Browser, the stable version of :

                Pier3 (JohnCBorden.52)

                Pier3Addons (StephanEggermont.95)


        Now when i open the relative web application:

                pier and piersetup

        i found some problematic and  errors.



        Can anyone help me to understand the status of these applications?

        How i can load them into Pharo 4.0 ?

        Thanks for considerations,

                Dario
_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

John Borden
Pier3Addons version 95 uses the stable version of Pillar, which has removed embedded links from PRReference, version 99 and newer of Pier3Addons is hard-coded to Pillar 1.1.2, which still has the embedded present.  Try using the newer version of Pier3Addon configuration.
Thanks,
John

> On Dec 2, 2015, at 5:16 AM, [hidden email] wrote:
>
> Ciao,
>
> i have a Pharo4.0 Latest update: #40625
>
> where i install, from Configuration Browser, the stable version of :
>
> Pier3 (JohnCBorden.52)
>
> Pier3Addons (StephanEggermont.95)
>
>
> Now when i open the relative web application:
>
> pier and piersetup
>
> i found some problematic and  errors.
>
>
>
> Can anyone help me to understand the status of these applications?
>
> How i can load them into Pharo 4.0 ?
>
> Thanks for considerations,
>
> Dario
> _______________________________________________
> Magritte, Pier and Related Tools ...
> https://www.list.inf.unibe.ch/listinfo/smallwiki

_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

dtrussardi@tiscali.it
Ciao,
       
        thanks,

> Pier3Addons version 95 uses the stable version of Pillar, which has removed embedded links from PRReference, version 99 and newer of Pier3Addons is hard-coded to Pillar 1.1.2, which still has the embedded present.  Try using the newer version of Pier3Addon configuration.
       
        but into  MetaRepoForPharo40

        i found only the ConfigurationOfPier3AddOns-StephanEggermont.95.

        Where i found the newer version of Pier3Addon configurations ?

        Or you intend to load  the last version:   version311: spec

                from ConfigurationOfPier3AddOns-StephanEggermont.95.?


P.S.  When into a new Pharo 4.0 image i load the Pier3 (JohnCBorden.52) stable version

        the system erase the error:

                Character(Object)>>doesNotUnderstand: #greaseInteger
                WAUrlEncoder class>>encode:on:
                WAUrlEncoder class>>initializeTable
                WAUrlEncoder class>>initialize
                MCMethodDefinition>>postloadOver:
                [ :each | each postloadOver: (self obsoletionFor: each) ] in  

        What i need to load before ?......

        Thanks,
       
                Dario

       

> Thanks,
> John
>
>> On Dec 2, 2015, at 5:16 AM, [hidden email] wrote:
>>
>> Ciao,
>>
>> i have a Pharo4.0 Latest update: #40625
>>
>> where i install, from Configuration Browser, the stable version of :
>>
>> Pier3 (JohnCBorden.52)
>>
>> Pier3Addons (StephanEggermont.95)
>>
>>
>> Now when i open the relative web application:
>>
>> pier and piersetup
>>
>> i found some problematic and  errors.
>>
>>
>>
>> Can anyone help me to understand the status of these applications?
>>
>> How i can load them into Pharo 4.0 ?
>>
>> Thanks for considerations,
>>
>> Dario
>> _______________________________________________
>> Magritte, Pier and Related Tools ...
>> https://www.list.inf.unibe.ch/listinfo/smallwiki
>
> _______________________________________________
> Magritte, Pier and Related Tools ...
> https://www.list.inf.unibe.ch/listinfo/smallwiki

_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

Stephan Eggermont
Hi Dario,

The way we are dealing with metarepos is somewhat problematic.
The creation of a new repo for each new pharo version is wrong. The result
is that the latest version of configurations is often not in all metarepos.

Stephan

_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

dtrussardi@tiscali.it
Ciao,


> Hi Dario,
>
> The way we are dealing with metarepos is somewhat problematic.
> The creation of a new repo for each new pharo version is wrong. The result
> is that the latest version of configurations is often not in all metarepos.
>

        OK.....  from: http://www.smalltalkhub.com/mc/Pier/Pier3Addons/main

        i load ( ConfigurationOfPier3AddOns project version: #'stable' )

        without error!!!   ( But i need to load #'development'  version ?)

        But for example any Magritte package was uploaded,

        and the ZnZincServerAdaptor too......

        What is the right package sequence to load and which the relative version ?


        Thanks for any considerations,
       
                Dario



_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

dtrussardi@tiscali.it
Ciao,

Ciao,


Hi Dario,

The way we are dealing with metarepos is somewhat problematic.
The creation of a new repo for each new pharo version is wrong. The result
is that the latest version of configurations is often not in all metarepos.


OK.....  from: http://www.smalltalkhub.com/mc/Pier/Pier3Addons/main

i load ( ConfigurationOfPier3AddOns project version: #'stable' )

without error!!!   ( But i need to load #'development'  version ?)

But for example any Magritte package was uploaded,

and the ZnZincServerAdaptor too......

What is the right package sequence to load and which the relative version ?

Into Pharo 4.0 i load:

( ConfigurationOfSeaside3 project version: #'release3.1' ) load. ( ConfigurationOfMagritte3 project version: #'stable' ) load. ( ConfigurationOfMagritte3AddOns project version: #'release3.1' ) load.

with this exception :

This package depends on the following classes:
  SAXParserDriver
  XMLWellFormedParserTokenizer
You must resolve these dependencies before you will be able to load these definitions: 
  SAXPositionParserDriver
  decodesCharacters
  handleEndCDataPosition:
  handleEndCommentPosition:
  handleEndDeclaration:
  handleEndDoctypeDeclarationPosition:
  handleEndEntityReferencePosition:
  handleEndPIPosition:
  handleEndQuotedStringValuePosition:
  handleEndTagPosition:
  handleEndXMLDeclarationPosition:
  handleStartCDataPosition:
  handleStartCommentPosition:
  handleStartDeclaration:
  handleStartDoctypeDeclarationPosition:
  handleStartEntityReferencePosition:
  handleStartPIPosition:
  handleStartQuotedStringValuePosition:
  handleStartTagPosition:
  handleStartXMLDeclarationPosition:
  isValidating
  tokenizerClass
  XMLPositionWellFormedParserTokenizer
  currentPosition
  nextAttributeValue
  nextCDataSection
  nextCharacterReferenceOnWriteStream
  nextComment
  nextDoctypeDeclaration
  nextEndDoctypeDeclaration
  nextEntityValue
  nextGeneralEntityReferenceOnWriteStream
  nextPIWithTarget:
  nextParameterEntityReference
  nextParameterEntityReferenceInDeclaration
  nextParameterEntityReferenceOnWriteStream
  nextSubsetDeclaration
  nextTag
  nextXMLDeclaration
  setDriver:stream:readLimit:
( ConfigurationOfPier3 project version: #'release3.1' ) load. ( ConfigurationOfPier3AddOns project version: #'release3.1' ) load
with this exception:

A) XML-Parser have unsaved change in the image

B)  PRAdminSetup initialize
| piersetup |
piersetup := (WAAdmin register: self asApplicationAt: 'piersetup')
preferenceAt: #useCookies put: false;     ****** useCookies  is not configured *******


NOW when i open the:  pier   and the: pier-setup    applications  the system report some errors

and is not  operating.

Some Considerations?

Thanks,

Dario


_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

dtrussardi@tiscali.it
Ciao,

        at the end these are my conclusions:

        A) into Pharo 4.0 i load:

                ( ConfigurationOfSeaside3 project version: #'release3.1' )

                ( ConfigurationOfMagritte3 project version: #'release3.5' )

                ( ConfigurationOfPier3 project version: #'release3.0' )

        With these the pier web applications   work fine.

       


        B) I don't load:

                ( ConfigurationOfMagritte3AddOns project version: #'release3.1' )

                        what it implemented ?  ( i don't remember )

                ( ConfigurationOfPier3AddOns project version: #'release3.X' )

                        if i right understand it's not  port - supported  into the new ' Pier release' .

                        Someone is working on it  ?

        Thanks,

                Dario
       
_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pier CMS status for Pharo 4.0

John Borden
Hi Dario - Below is the script I’ve used to test the configuration:

#!/usr/bin/env ksh

export VERSION=release3.1
# export JOB_NAME=`dirname $PWD`
export JOB_NAME=$PWD/pier_addons


./pharo Pharo.image save $JOB_NAME --delete-old
./pharo $JOB_NAME.image --version > version.txt

# not all add ons have tests yet. We list here the projects that do not get loaded with tests.
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-Blog'
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-EditorEnh'
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-Shout'
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-TagCloud'
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-Google'
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Pier-Setup'
# Load the tests, and the add ons with tests
./pharo $JOB_NAME.image config $REPO ConfigurationOfPier3AddOns --install=$VERSION --group='Tests'

./pharo $JOB_NAME.image test --junit-xml-output "Pier.*"


To run it, create a new directory, update the 3.1 to 3.0 if you want the stable version.  Change 50 to 40 for Pharo version 4, and run it.  Thanks to Stephan Eggermont for this.  Let me know if you have trouble with this.

Thanks,
John

On Dec 3, 2015, at 9:03 AM, [hidden email] wrote:

Ciao,

at the end these are my conclusions:

A) into Pharo 4.0 i load:

( ConfigurationOfSeaside3 project version: #'release3.1' )

( ConfigurationOfMagritte3 project version: #'release3.5' )

( ConfigurationOfPier3 project version: #'release3.0' )

With these the pier web applications   work fine.




B) I don't load:

( ConfigurationOfMagritte3AddOns project version: #'release3.1' )

what it implemented ?  ( i don't remember )

( ConfigurationOfPier3AddOns project version: #'release3.X' )

if i right understand it's not  port - supported  into the new ' Pier release' .

Someone is working on it  ?

Thanks,

Dario

_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki


_______________________________________________
Magritte, Pier and Related Tools ...
https://www.list.inf.unibe.ch/listinfo/smallwiki
Loading...