Pier questions

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Pier questions

Nicolas MELIN

I finally got the time to try using Pier. The main goal is not to  
have a rock stable wiki (I would have used SmallWiki1 for that), but  
to test Pier features. Don't get me wrong, I'm not complaining, just  
trying to help in what is, I hope, a constructive way.

I installed Pier from scratch, to have the latest versions. (I  
followed instructions given on http://smallwiki.unibe.ch/smallwiki/ 
pier/installationofpier/). As I needed the authentication features, I  
installed the Pier-Security too.

The versions I used are:
- Pier-Model-lr.37
- Pier-Tests-lr.22
- Pier-Seaside-lr.34
- Pier-Security-lr.16

At the moment, I have 2 kernels running. I noted a few problems :

- Pier-Security: I added users, groups without problem. Then I  
disabled the View Command for "Other" users.
The problem is, disabling view doesn't hide contents. ie: "Other"  
users can still view the first page of the wiki (even if the links  
are grayed), the tree contents, and worst, if they type the address  
directly, they can view all the pages of the wiki. (this problem was  
already reported by Cédrick Béler, and I fixed it quick&dirty by  
modifying PRContentsWidget and PRTreeWidget to only display content  
when context isValid)

Another thing, even after fixing the first problem, when I click on  
Login, the context becomes valid, and the tree contents are displayed.

- PRFilePersistency: I subclassed PRFilePersistency to have each  
kernel logging in it's own log file.
        - When PRFilePersistency is instanced, it doesn't actually create  
the log file. So when using the Log or Changes commands before saving  
anything, I get a FileDoesNotExistException.

        - When I delete a page, the object remains in the log. When I use  
Changes or Log Commands, Pier is confused because it tries to display  
informations about deleted pages, thus resulting in an  
UndefinedObject error. If I manually delete the log, the problem is  

- mutex: I got a strange problem. Suddenly, one of the 2 kernels  
stopped accepting logins. The page just froze when I tried to login.  
I found that something went wrong with a process in this kernel's  
mutex. I tried to play with the blocked process, sending resume and  
terminate messages, but I probably shouldn't have, because the image  
locked, and the VM segfaulted, so I couldn't investigate it more  
deeply ;-)

- Do you have a bug tracker for Pier ?


Smallwiki mailing list
[hidden email]