Problems with PunQLite

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problems with PunQLite

Peter Kenny

Hello

 

I have decided to have another try with PunQLite, having failed to get it working before. For the record, I am using Windows 10 Home with all recent updates applied.

 

I tried the following:

 

  1. Download latest image of Moose 6.1 (Pharo 6.0 Latest update: #60507).
  2. Search Catalog Browser for PunQLite, which is flagged as OK for Pharo 6.0, and select ‘Install stable version’.
  3. Check that the file unqlite.dll has been installed in the same folder as the image.
  4. Run tests in PqDatabaseTests. 30 tests run, all red.
  5. Try to run some tests manually. Enter ‘PqDatabase openOnMemory’ and ‘doIt’. Result: ‘Error: External module not found’.

 

Looking at the Monticello Browser, I see that my image has ConfigurationOfPunQLite(TorstenBergmann.29) and PunQLite-Core(TorstenBergmann.28). This is the version chosen as stable by the Catalog Browser. Have I in fact got the right version? Do I have to do something with the .dll to make it visible to the .ffi call?

 

Any suggestions gratefully received.

 

Peter Kenny

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with PunQLite

Peter Kenny

Hello

 

Just an update on a further test. Going through old e-mails, I saw Esteban Lorenzano’s recommendation to use a different repository to install PunQLite. I used his snippet:

Metacello new 
    repository: '<a href="github://pharo-nosql/PunQLite/repository'">github://pharo-nosql/PunQLite/repository';
    baseline: 'PunQLite';
    load.

to install it in a clean Moose 6.1 image. The results were the same; all tests red, manual test gave error: ‘External module not found’. I suspect it is all a matter of getting the unqlite.dll module where it can be found, but I don’t know where this should be.

 

Thanks for any help

 

Peter Kenny

 

From: Pharo-users [mailto:[hidden email]] On Behalf Of PBKResearch
Sent: 11 July 2017 18:27
To: [hidden email]
Subject: [Pharo-users] Problems with PunQLite

 

Hello

 

I have decided to have another try with PunQLite, having failed to get it working before. For the record, I am using Windows 10 Home with all recent updates applied.

 

I tried the following:

 

  1. Download latest image of Moose 6.1 (Pharo 6.0 Latest update: #60507).
  2. Search Catalog Browser for PunQLite, which is flagged as OK for Pharo 6.0, and select ‘Install stable version’.
  3. Check that the file unqlite.dll has been installed in the same folder as the image.
  4. Run tests in PqDatabaseTests. 30 tests run, all red.
  5. Try to run some tests manually. Enter ‘PqDatabase openOnMemory’ and ‘doIt’. Result: ‘Error: External module not found’.

 

Looking at the Monticello Browser, I see that my image has ConfigurationOfPunQLite(TorstenBergmann.29) and PunQLite-Core(TorstenBergmann.28). This is the version chosen as stable by the Catalog Browser. Have I in fact got the right version? Do I have to do something with the .dll to make it visible to the .ffi call?

 

Any suggestions gratefully received.

 

Peter Kenny

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with PunQLite

EstebanLM
Hi, 

while the installer should download and install the dll, I have seen that in some cases it does not downloads it correctly.
can you try to download the library from here: 


and putting it in same dir as your image? (which is where should be the downloaded dll, so you need to replace it).

cheers!
Esteban

On 12 Jul 2017, at 14:10, PBKResearch <[hidden email]> wrote:

Hello
 
Just an update on a further test. Going through old e-mails, I saw Esteban Lorenzano’s recommendation to use a different repository to install PunQLite. I used his snippet:
Metacello new 
    repository: '<a href="github://pharo-nosql/PunQLite/repository'" style="color: rgb(149, 79, 114); text-decoration: underline;" class="">github://pharo-nosql/PunQLite/repository';
    baseline: 'PunQLite';
    load.
to install it in a clean Moose 6.1 image. The results were the same; all tests red, manual test gave error: ‘External module not found’. I suspect it is all a matter of getting the unqlite.dll module where it can be found, but I don’t know where this should be.
 
Thanks for any help
 
Peter Kenny
 
From: Pharo-users [[hidden email]] On Behalf Of PBKResearch
Sent: 11 July 2017 18:27
To: [hidden email]
Subject: [Pharo-users] Problems with PunQLite
 
Hello
 
I have decided to have another try with PunQLite, having failed to get it working before. For the record, I am using Windows 10 Home with all recent updates applied.
 
I tried the following:
 
  1. Download latest image of Moose 6.1 (Pharo 6.0 Latest update: #60507). 
  2. Search Catalog Browser for PunQLite, which is flagged as OK for Pharo 6.0, and select ‘Install stable version’.
  3. Check that the file unqlite.dll has been installed in the same folder as the image.
  4. Run tests in PqDatabaseTests. 30 tests run, all red.
  5. Try to run some tests manually. Enter ‘PqDatabase openOnMemory’ and ‘doIt’. Result: ‘Error: External module not found’.
 
Looking at the Monticello Browser, I see that my image has ConfigurationOfPunQLite(TorstenBergmann.29) and PunQLite-Core(TorstenBergmann.28). This is the version chosen as stable by the Catalog Browser. Have I in fact got the right version? Do I have to do something with the .dll to make it visible to the .ffi call?
 
Any suggestions gratefully received.
 
Peter Kenny

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with PunQLite

Peter Kenny

Hi Esteban

 

Thanks. That has fixed the immediate problem – the tests in PqDatabaseTests are now all green. The effect is weird, because the downloaded .dll just overwrote the old one, so they are in the same place, but now it works.

 

I am still getting some PqFetch errors in testing, but I can’t yet give a clear characterisation of the problem. I shall come back when I have some more results.

 

Peter

 

From: Pharo-users [mailto:[hidden email]] On Behalf Of Esteban Lorenzano
Sent: 12 July 2017 13:24
To: Any question about pharo is welcome <[hidden email]>
Subject: Re: [Pharo-users] Problems with PunQLite

 

Hi, 

 

while the installer should download and install the dll, I have seen that in some cases it does not downloads it correctly.

can you try to download the library from here: 

 

 

and putting it in same dir as your image? (which is where should be the downloaded dll, so you need to replace it).

 

cheers!

Esteban

 

On 12 Jul 2017, at 14:10, PBKResearch <[hidden email]> wrote:

 

Hello

 

Just an update on a further test. Going through old e-mails, I saw Esteban Lorenzano’s recommendation to use a different repository to install PunQLite. I used his snippet:

Metacello new 
    repository: '<a href="github://pharo-nosql/PunQLite/repository'">github://pharo-nosql/PunQLite/repository';
    baseline: 'PunQLite';
    load.

to install it in a clean Moose 6.1 image. The results were the same; all tests red, manual test gave error: ‘External module not found’. I suspect it is all a matter of getting the unqlite.dll module where it can be found, but I don’t know where this should be.

 

Thanks for any help

 

Peter Kenny

 

From: Pharo-users [[hidden email]] On Behalf Of PBKResearch
Sent: 11 July 2017 18:27
To: [hidden email]
Subject: [Pharo-users] Problems with PunQLite

 

Hello

 

I have decided to have another try with PunQLite, having failed to get it working before. For the record, I am using Windows 10 Home with all recent updates applied.

 

I tried the following:

 

  1. Download latest image of Moose 6.1 (Pharo 6.0 Latest update: #60507). 
  2. Search Catalog Browser for PunQLite, which is flagged as OK for Pharo 6.0, and select ‘Install stable version’.
  3. Check that the file unqlite.dll has been installed in the same folder as the image.
  4. Run tests in PqDatabaseTests. 30 tests run, all red.
  5. Try to run some tests manually. Enter ‘PqDatabase openOnMemory’ and ‘doIt’. Result: ‘Error: External module not found’.

 

Looking at the Monticello Browser, I see that my image has ConfigurationOfPunQLite(TorstenBergmann.29) and PunQLite-Core(TorstenBergmann.28). This is the version chosen as stable by the Catalog Browser. Have I in fact got the right version? Do I have to do something with the .dll to make it visible to the .ffi call?

 

Any suggestions gratefully received.

 

Peter Kenny

 

Loading...