Re: [Pharo-project] How to load Phoseydon and Neptuno?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [Pharo-project] How to load Phoseydon and Neptuno?

Guillermo Polito
Hi!

which Pharo version are you using? I was able to download Phoseydon in Pharo 1.4 by doing

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfDBXTools';
    load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Phoseydon'

as it is in the webpage...
What problem did you find?

BTW, I would move this thread to [hidden email] or the pharo-users mailing lists.

Cheers,
Guille

On Wed, Dec 12, 2012 at 11:07 PM, Stan Shepherd <[hidden email]> wrote:
Hi all, is there a working snippet to load these two? I've tried combinations
from previous threads without success so far.
Thanks,    ...Stan



--
View this message in context: http://forum.world.st/How-to-load-Phoseydon-and-Neptuno-tp4659102.html
Sent from the Pharo Smalltalk mailing list archive at Nabble.com.


Reply | Threaded
Open this post in threaded view
|

Walkback loading Neptuno (was Re: [Pharo-project] How to load Phoseydon and Neptuno?)

Stan Shepherd
This post has NOT been accepted by the mailing list yet.
Thanks Guille,
That works for Phoseydon. But

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfDBXBrowser';
    load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Neptuno'

throws an error- 'announcer is already defined in MorphTreeModel'

...Stan

(p.s. http://dbxtalk.smallworks.com.ar/pier/Support on http://dbxtalk.smallworks.com.ar/news/Neptuno-First-Stable-Version-Release/ is a broken link)
Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Stan Shepherd
In reply to this post by Guillermo Polito
Thanks Guille,
That works for Phoseydon. But

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfDBXBrowser';
    load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Neptuno'

throws an error- 'announcer is already defined in MorphTreeModel'

...Stan

(p.s. http://dbxtalk.smallworks.com.ar/pier/Support on
http://dbxtalk.smallworks.com.ar/news/Neptuno-First-Stable-Version-Release/
is a broken link)




On Dec 13, 9:49 am, Guillermo Polito <[hidden email]>
wrote:

> Hi!
>
> which Pharo version are you using? I was able to download Phoseydon in
> Pharo 1.4 by doing
>
> Gofer it
>     squeaksource: 'MetacelloRepository';
>     package: 'ConfigurationOfDBXTools';
>     load.
>
> (((Smalltalk at: #ConfigurationOfDBXTools)
>     perform: #project)
>         perform: #version: with: #stable)
>             load: 'Phoseydon'
>
> as it is in the webpage...
> What problem did you find?
>
> BTW, I would move this thread to [hidden email] or the
> pharo-users mailing lists.
>
> Cheers,
> Guille
>
> On Wed, Dec 12, 2012 at 11:07 PM, Stan Shepherd
> <[hidden email]>wrote:
>
>
>
>
>
>
>
> > Hi all, is there a working snippet to load these two? I've tried
> > combinations
> > from previous threads without success so far.
> > Thanks,    ...Stan
>
> > --
> > View this message in context:
> >http://forum.world.st/How-to-load-Phoseydon-and-Neptuno-tp4659102.html
> > Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Guillermo Polito


On Sat, Dec 15, 2012 at 1:08 PM, stan shepherd <[hidden email]> wrote:
Thanks Guille,
That works for Phoseydon. But

Gofer it
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfDBXBrowser';
    load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Neptuno'

throws an error- 'announcer is already defined in MorphTreeModel'

Yes, that's a dependency problem with a framework we depend on... I'll try to fix it asap. Tx for telling :) 

...Stan

(p.s. http://dbxtalk.smallworks.com.ar/pier/Support on
http://dbxtalk.smallworks.com.ar/news/Neptuno-First-Stable-Version-Release/
is a broken link)

fixed :P

Guille 




On Dec 13, 9:49 am, Guillermo Polito <[hidden email]>
wrote:
> Hi!
>
> which Pharo version are you using? I was able to download Phoseydon in
> Pharo 1.4 by doing
>
> Gofer it
>     squeaksource: 'MetacelloRepository';
>     package: 'ConfigurationOfDBXTools';
>     load.
>
> (((Smalltalk at: #ConfigurationOfDBXTools)
>     perform: #project)
>         perform: #version: with: #stable)
>             load: 'Phoseydon'
>
> as it is in the webpage...
> What problem did you find?
>
> BTW, I would move this thread to [hidden email] or the
> pharo-users mailing lists.
>
> Cheers,
> Guille
>
> On Wed, Dec 12, 2012 at 11:07 PM, Stan Shepherd
> <[hidden email]>wrote:
>
>
>
>
>
>
>
> > Hi all, is there a working snippet to load these two? I've tried
> > combinations
> > from previous threads without success so far.
> > Thanks,    ...Stan
>
> > --
> > View this message in context:
> >http://forum.world.st/How-to-load-Phoseydon-and-Neptuno-tp4659102.html
> > Sent from the Pharo Smalltalk mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Bernat Romagosa
Has this been fixed?

I've tried to install Neptuno in a fresh Pharo 1.4 image and got the exact same error.

Thanks!

Bernat.
Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Guillermo Polito
Oups, perdón.

I'd fixed it long time ago, updated the ConfigurationOfDBXBrowser, but not the ConfigurationOfDBXTools.

I just updated it, you can try again!

BTW, I just warn you, this browser still needs lots of love...


On Wed, May 29, 2013 at 12:12 PM, Bernat Romagosa <[hidden email]> wrote:
Has this been fixed?

I've tried to install Neptuno in a fresh Pharo 1.4 image and got the exact
same error.

Thanks!

Bernat.



--
View this message in context: http://forum.world.st/Re-Pharo-project-How-to-load-Phoseydon-and-Neptuno-tp4659171p4690598.html
Sent from the DBXTalk mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.



--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Guillermo Polito
ok, and you should fetch the configurations from the new repo in smalltalkhub:

Gofer it
package: 'ConfigurationOfDBXTools';
load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Neptuno'


On Fri, May 31, 2013 at 11:51 PM, Guillermo Polito <[hidden email]> wrote:
Oups, perdón.

I'd fixed it long time ago, updated the ConfigurationOfDBXBrowser, but not the ConfigurationOfDBXTools.

I just updated it, you can try again!

BTW, I just warn you, this browser still needs lots of love...


On Wed, May 29, 2013 at 12:12 PM, Bernat Romagosa <[hidden email]> wrote:
Has this been fixed?

I've tried to install Neptuno in a fresh Pharo 1.4 image and got the exact
same error.

Thanks!

Bernat.



--
View this message in context: http://forum.world.st/Re-Pharo-project-How-to-load-Phoseydon-and-Neptuno-tp4659171p4690598.html
Sent from the DBXTalk mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.




--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: How to load Phoseydon and Neptuno?

Bernat Romagosa
This post has NOT been accepted by the mailing list yet.
Thanks Guille! It's working now :)


2013/5/31 Guillermo Polito [via Smalltalk] <[hidden email]>
ok, and you should fetch the configurations from the new repo in smalltalkhub:

Gofer it
package: 'ConfigurationOfDBXTools';
load.

(((Smalltalk at: #ConfigurationOfDBXTools)
    perform: #project)
        perform: #version: with: #stable)
            load: 'Neptuno'


On Fri, May 31, 2013 at 11:51 PM, Guillermo Polito <[hidden email]> wrote:
Oups, perdón.

I'd fixed it long time ago, updated the ConfigurationOfDBXBrowser, but not the ConfigurationOfDBXTools.

I just updated it, you can try again!

BTW, I just warn you, this browser still needs lots of love...


On Wed, May 29, 2013 at 12:12 PM, Bernat Romagosa <[hidden email]> wrote:
Has this been fixed?

I've tried to install Neptuno in a fresh Pharo 1.4 image and got the exact
same error.

Thanks!

Bernat.



--
View this message in context: http://forum.world.st/Re-Pharo-project-How-to-load-Phoseydon-and-Neptuno-tp4659171p4690598.html
Sent from the DBXTalk mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.




--
You received this message because you are subscribed to the Google Groups "DBXTalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 



If you reply to this email, your message will be added to the discussion below:
http://forum.world.st/Re-Pharo-project-How-to-load-Phoseydon-and-Neptuno-tp4659171p4691130.html
To unsubscribe from Re: [Pharo-project] How to load Phoseydon and Neptuno?, click here.
NAML



--
Bernat Romagosa.