> #canUnderstand: is a message send to a class, and tells you whether
> all of its instances respond to a particular message. #respondsTo: is
> a message sent to an instance, and tells you whether that instance
> will respond to a particular message.
>
> The names are unfortunately cryptic, but that is what they mean.
IMHO canUnderstand: is simply the wrong name for something on the class
side, especially given that the error message on the instance side is
#doesNotUnderstand:.
Trying to change this would break lots of code, but maybe we could have
#instancesRespondTo: on the class side, and deprecate #canUnderstand:?
Steve
_______________________________________________
vwnc mailing list
[hidden email]
http://lists.cs.uiuc.edu/mailman/listinfo/vwnc