Re: [aida] failure in parsing HTTPRequestLine

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Re: [aida] failure in parsing HTTPRequestLine

Janko Mivšek
Hi Andreas,

Now I know what is a problem and it is patched (I cannot say solved:) in
  latest Swazoo 2.1.

Namely POSTs are somehow not parsed completelly and it seems a byte or
so sometimes stay unparsed. But parsed content is correct anyway. That's
why I didn't go deeper (besides I didn't have time). Quick solution is
simply to close connection after a post and that's in Swazoo 2.1 in
method HTTPConnection produceResponseFor: .

Because POSTs are relatively rare comparing to GETs I think such quick
problem solution won't affect Swazoo performance in general.

I hope this help a bit

Andreas Petermann wrote:

>>>> because of getting arbitrary 502 errors, i found out that the reason
>> for that problem is an error in parsing the HTTPRequestLine. When it is not
>> possible to find a corresponding HTTPRequest class is the leading character
>> of the method a <lf>. I simple solved this problem by an additional
>> #trimBlanks.
>>>> Is this is a bug in Swazoo or my Firefox?
>>> I didn't have first request line parsing errors for ages so I'm really
>>> interested what is happening in your case. Can you spy a network and
>>> record, what is actually flowing on the wire? With Ethereal or similar
>>> spy/network monitor. That way we will find a cause most efficiently.
> Hi Janko,
> i have spied out the network traffic with the result, that there is no failure. The requests are all ok. It seems, that POST requests are parsed two times. I get one correct POST request and then i get the same one again, but this time only a part of the post data. And on trying to get the request type occurs the error. I am not sure why this happens, perhaps why the post data seems not to be parsed?
> regards
> Andreas

Janko Mivšek
Smalltalk Web Application Server