Roassal2 in Pharo 6.1 (Win) 137 tests fails

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Roassal2 in Pharo 6.1 (Win) 137 tests fails

hernanmd
In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
spec in a baseline:

            spec
                project: 'Roassal2'
                with: [
                    spec
                        className: #ConfigurationOfRoassal2;
                        versionString: #stable;
                        repository:
'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].

But many Trachel tests fails because of "External module not found"
error (Screenshots attached).
May be Roassal2 is broken on Windows?

I tried loading Roassal2 from the Catalog browser and the same 137 tests fails.

Any idea what could be missing?

Cheers,

Hernán

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev

Test Runner.png (172K) Download Attachment
Error - External module not found.png (163K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Roassal2 in Pharo 6.1 (Win) 137 tests fails

Peter Uhnák
May be Roassal2 is broken on Windows?

Sometimes Pharo on Windows decides that it will not load external library.

Try to restart your PC and see if it persists.

Peter

On Fri, Jul 6, 2018 at 5:38 PM, Hernán Morales Durand <[hidden email]> wrote:
In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
spec in a baseline:

            spec
                project: 'Roassal2'
                with: [
                    spec
                        className: #ConfigurationOfRoassal2;
                        versionString: #stable;
                        repository:
'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].

But many Trachel tests fails because of "External module not found"
error (Screenshots attached).
May be Roassal2 is broken on Windows?

I tried loading Roassal2 from the Catalog browser and the same 137 tests fails.

Any idea what could be missing?

Cheers,

Hernán

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev



_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: [Pharo-users] Roassal2 in Pharo 6.1 (Win) 137 tests fails

abergel
In reply to this post by hernanmd
Dear Hernan,

Likely that you use a VM that does not have the Cairo library. Can you try updating your VM?

Cheers
Alexandre 

http://bergel.eu

Le 6 juil. 2018 à 18:38, Hernán Morales Durand <[hidden email]> a écrit :

In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
spec in a baseline:

           spec
               project: 'Roassal2'
               with: [
                   spec
                       className: #ConfigurationOfRoassal2;
                       versionString: #stable;
                       repository:
'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].

But many Trachel tests fails because of "External module not found"
error (Screenshots attached).
May be Roassal2 is broken on Windows?

I tried loading Roassal2 from the Catalog browser and the same 137 tests fails.

Any idea what could be missing?

Cheers,

Hernán
<Test Runner.png>
<Error - External module not found.png>

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: [Pharo-users] Roassal2 in Pharo 6.1 (Win) 137 tests fails

hernanmd
Hi Alex,

I used the VM which is provided by the zeroconf, i.e.:

wget -O- https://get.pharo.org | bash

This VM is Cog Spur VM 5.0 (release) from May 9 2018.
gcc 6.4.0

Could happen that loading a library on Windows sometimes fails?
It would be nice to have the path or additional information on the
loading error.

Cheers,

Hernán


2018-07-06 13:55 GMT-03:00 Alexandre Bergel <[hidden email]>:

> Dear Hernan,
>
> Likely that you use a VM that does not have the Cairo library. Can you try
> updating your VM?
>
> Cheers
> Alexandre
>
> http://bergel.eu
>
> Le 6 juil. 2018 à 18:38, Hernán Morales Durand <[hidden email]> a
> écrit :
>
> In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
> spec in a baseline:
>
>            spec
>                project: 'Roassal2'
>                with: [
>                    spec
>                        className: #ConfigurationOfRoassal2;
>                        versionString: #stable;
>                        repository:
> 'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].
>
> But many Trachel tests fails because of "External module not found"
> error (Screenshots attached).
> May be Roassal2 is broken on Windows?
>
> I tried loading Roassal2 from the Catalog browser and the same 137 tests
> fails.
>
> Any idea what could be missing?
>
> Cheers,
>
> Hernán
>
> <Test Runner.png>
>
> <Error - External module not found.png>
>
>
> _______________________________________________
> Moose-dev mailing list
> [hidden email]
> https://www.list.inf.unibe.ch/listinfo/moose-dev
>
_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: Roassal2 in Pharo 6.1 (Win) 137 tests fails

hernanmd
In reply to this post by Peter Uhnák
Hi Peter,

I don't know why but restarted the PC and it worked! On a new image
and Roassal2 installation.
Thank you,

Cheers,

Hernán

2018-07-06 12:52 GMT-03:00 Peter Uhnák <[hidden email]>:

>>  May be Roassal2 is broken on Windows?
>
> Sometimes Pharo on Windows decides that it will not load external library.
>
> Try to restart your PC and see if it persists.
>
> Peter
>
> On Fri, Jul 6, 2018 at 5:38 PM, Hernán Morales Durand
> <[hidden email]> wrote:
>>
>> In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
>> spec in a baseline:
>>
>>             spec
>>                 project: 'Roassal2'
>>                 with: [
>>                     spec
>>                         className: #ConfigurationOfRoassal2;
>>                         versionString: #stable;
>>                         repository:
>> 'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].
>>
>> But many Trachel tests fails because of "External module not found"
>> error (Screenshots attached).
>> May be Roassal2 is broken on Windows?
>>
>> I tried loading Roassal2 from the Catalog browser and the same 137 tests
>> fails.
>>
>> Any idea what could be missing?
>>
>> Cheers,
>>
>> Hernán
>>
>> _______________________________________________
>> Moose-dev mailing list
>> [hidden email]
>> https://www.list.inf.unibe.ch/listinfo/moose-dev
>>
>
>
> _______________________________________________
> Moose-dev mailing list
> [hidden email]
> https://www.list.inf.unibe.ch/listinfo/moose-dev
>
_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: Roassal2 in Pharo 6.1 (Win) 137 tests fails

Bouremel Abd El Hakim
Hi, the problem is with the VM. You must use an older one.

Le sam. 7 juil. 2018 à 05:01, Hernán Morales Durand <[hidden email]> a écrit :
Hi Peter,

I don't know why but restarted the PC and it worked! On a new image
and Roassal2 installation.
Thank you,

Cheers,

Hernán

2018-07-06 12:52 GMT-03:00 Peter Uhnák <[hidden email]>:
>>  May be Roassal2 is broken on Windows?
>
> Sometimes Pharo on Windows decides that it will not load external library.
>
> Try to restart your PC and see if it persists.
>
> Peter
>
> On Fri, Jul 6, 2018 at 5:38 PM, Hernán Morales Durand
> <[hidden email]> wrote:
>>
>> In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
>> spec in a baseline:
>>
>>             spec
>>                 project: 'Roassal2'
>>                 with: [
>>                     spec
>>                         className: #ConfigurationOfRoassal2;
>>                         versionString: #stable;
>>                         repository:
>> 'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].
>>
>> But many Trachel tests fails because of "External module not found"
>> error (Screenshots attached).
>> May be Roassal2 is broken on Windows?
>>
>> I tried loading Roassal2 from the Catalog browser and the same 137 tests
>> fails.
>>
>> Any idea what could be missing?
>>
>> Cheers,
>>
>> Hernán
>>
>> _______________________________________________
>> Moose-dev mailing list
>> [hidden email]
>> https://www.list.inf.unibe.ch/listinfo/moose-dev
>>
>
>
> _______________________________________________
> Moose-dev mailing list
> [hidden email]
> https://www.list.inf.unibe.ch/listinfo/moose-dev
>
_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: Roassal2 in Pharo 6.1 (Win) 137 tests fails

Peter Uhnák
Hi, the problem is with the VM. You must use an older one.
 
It is randomly broken in all VMs that I have ever used (on Windows).

I don't know why but restarted the PC and it worked!

If you happen to see your fonts all wonky and weird, then FT also failed to load and restart should fix it.

Peter 

On Sat, Jul 7, 2018 at 9:55 AM, Bouremel Abd El Hakim <[hidden email]> wrote:


Le sam. 7 juil. 2018 à 05:01, Hernán Morales Durand <[hidden email]> a écrit :
Hi Peter,

I don't know why but restarted the PC and it worked! On a new image
and Roassal2 installation.
Thank you,

Cheers,

Hernán

2018-07-06 12:52 GMT-03:00 Peter Uhnák <[hidden email]>:
>>  May be Roassal2 is broken on Windows?
>
> Sometimes Pharo on Windows decides that it will not load external library.
>
> Try to restart your PC and see if it persists.
>
> Peter
>
> On Fri, Jul 6, 2018 at 5:38 PM, Hernán Morales Durand
> <[hidden email]> wrote:
>>
>> In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
>> spec in a baseline:
>>
>>             spec
>>                 project: 'Roassal2'
>>                 with: [
>>                     spec
>>                         className: #ConfigurationOfRoassal2;
>>                         versionString: #stable;
>>                         repository:
>> 'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].
>>
>> But many Trachel tests fails because of "External module not found"
>> error (Screenshots attached).
>> May be Roassal2 is broken on Windows?
>>
>> I tried loading Roassal2 from the Catalog browser and the same 137 tests
>> fails.
>>
>> Any idea what could be missing?
>>
>> Cheers,
>>
>> Hernán
>>
>> _______________________________________________
>> Moose-dev mailing list
>> [hidden email]
>> https://www.list.inf.unibe.ch/listinfo/moose-dev
>>
>
>
> _______________________________________________
> Moose-dev mailing list
> [hidden email]
> https://www.list.inf.unibe.ch/listinfo/moose-dev
>
_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev



_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev
Reply | Threaded
Open this post in threaded view
|

Re: [Pharo-users] Re: Roassal2 in Pharo 6.1 (Win) 137 tests fails

abergel
In reply to this post by hernanmd
Wow!!!!

Glad to hear everything works now...

Alexandre

> On Jul 7, 2018, at 7:01 AM, Hernán Morales Durand <[hidden email]> wrote:
>
> Hi Peter,
>
> I don't know why but restarted the PC and it worked! On a new image
> and Roassal2 installation.
> Thank you,
>
> Cheers,
>
> Hernán
>
> 2018-07-06 12:52 GMT-03:00 Peter Uhnák <[hidden email]>:
>>> May be Roassal2 is broken on Windows?
>>
>> Sometimes Pharo on Windows decides that it will not load external library.
>>
>> Try to restart your PC and see if it persists.
>>
>> Peter
>>
>> On Fri, Jul 6, 2018 at 5:38 PM, Hernán Morales Durand
>> <[hidden email]> wrote:
>>>
>>> In a clean Pharo 6.1 (Windows 8) I loaded Roassal2 with the following
>>> spec in a baseline:
>>>
>>>            spec
>>>                project: 'Roassal2'
>>>                with: [
>>>                    spec
>>>                        className: #ConfigurationOfRoassal2;
>>>                        versionString: #stable;
>>>                        repository:
>>> 'http://www.smalltalkhub.com/mc/ObjectProfile/Roassal2' ].
>>>
>>> But many Trachel tests fails because of "External module not found"
>>> error (Screenshots attached).
>>> May be Roassal2 is broken on Windows?
>>>
>>> I tried loading Roassal2 from the Catalog browser and the same 137 tests
>>> fails.
>>>
>>> Any idea what could be missing?
>>>
>>> Cheers,
>>>
>>> Hernán
>>>
>>> _______________________________________________
>>> Moose-dev mailing list
>>> [hidden email]
>>> https://www.list.inf.unibe.ch/listinfo/moose-dev
>>>
>>
>>
>> _______________________________________________
>> Moose-dev mailing list
>> [hidden email]
>> https://www.list.inf.unibe.ch/listinfo/moose-dev
>>
>

_______________________________________________
Moose-dev mailing list
[hidden email]
https://www.list.inf.unibe.ch/listinfo/moose-dev