Quantcast

Seaside 3.0 sous Pharo 3.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Seaside 3.0 sous Pharo 3.0

Rene Mages (ramix)
Bonjour,

En suivant les directives de cette page :
       http://www.seaside.st/download/pharo#16819391
et notamment :
      Starting the Zinc Web Server
      Open the ’Seaside Control Panel’ in the ’Tools’ submenu of the
’World’ menu
je ne vois pas de panneau de controle de Seaside dans le sous-menu Tools :
   http://www.ffii.fr/ramix/pharo/SeasideControlPanel.png
Mon laptop est sous Ubuntu 13.04 (en 32 bits) et Apache 2.0 tourne en local.

--
Amicalement.
Rene Mages ( GnuPG_key 1024D/2CC455D9 )
http://renemages.wordpress.com/smalltalk/pharo

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes Smalltalk-fr.
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse [hidden email].
Pour plus d'options, visitez le site https://groups.google.com/groups/opt_out .
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Seaside 3.0 sous Pharo 3.0

sebastien audier
Bonjour Rene, 

Je n'ai pas testé sur Pharo 3.0, mais on rencontre aussi ce genre de chose dans Pharo 2.0.
A priori, tu peux toujours exécuter la commande suivante dans un workspace:

ZnZincServerAdaptor startOn: 8080

Cordialement, 



Le 6 février 2014 10:42, Rene Mages (ramix) <[hidden email]> a écrit :
Bonjour,

En suivant les directives de cette page :
       http://www.seaside.st/download/pharo#16819391
et notamment :
      Starting the Zinc Web Server
      Open the ’Seaside Control Panel’ in the ’Tools’ submenu of the
’World’ menu
je ne vois pas de panneau de controle de Seaside dans le sous-menu Tools :
   http://www.ffii.fr/ramix/pharo/SeasideControlPanel.png
Mon laptop est sous Ubuntu 13.04 (en 32 bits) et Apache 2.0 tourne en local.

--
Amicalement.
Rene Mages ( GnuPG_key 1024D/2CC455D9 )
http://renemages.wordpress.com/smalltalk/pharo

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes Smalltalk-fr.
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse [hidden email].
Pour plus d'options, visitez le site https://groups.google.com/groups/opt_out .



--
Sébastien AUDIER

S.A.R.L Objectfusion,
Applications web, consulting,
Smalltalk developpement

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes Smalltalk-fr.
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse [hidden email].
Pour plus d'options, visitez le site https://groups.google.com/groups/opt_out .
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Seaside 3.0 sous Pharo 3.0

Rene Mages (ramix)
Le 6 février 2014 11:45, Sebastien Audier <[hidden email]> a écrit :
> Bonjour Rene,
>
> Je n'ai pas testé sur Pharo 3.0, mais on rencontre aussi ce genre de chose
> dans Pharo 2.0.
> A priori, tu peux toujours exécuter la commande suivante dans un workspace:
>
> ZnZincServerAdaptor startOn: 8080

Merci beaucoup Sébastien.
Après avoir re_vérifier qu'apache répond bien sur le port 8080 :
       http://localhost:8080/
j'ai évalué dans un workspace :
     ZnZincServerAdaptor startOn: 8080
           mais toujours rien à l'horizon ...
J'ai vérifié que le package Zinc est bien présent dans mon image :
    http://www.ffii.fr/ramix/pharo/ZnZincServerAdaptor.png

Dans qq minutes je vais poster sur la liste dédiée à seaside :
   http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside
et bien entendu je reposterai sur smalltalk-fr@ dès que je comprendrai
la raison de mon problème.

--
Amicalement.
Rene Mages ( GnuPG_key 1024D/2CC455D9 )
http://renemages.wordpress.com/smalltalk/seaside

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes Smalltalk-fr.
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse [hidden email].
Pour plus d'options, visitez le site https://groups.google.com/groups/opt_out .
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Seaside 3.0 sous Pharo 3.0

Rene Mages (ramix)
Le 6 février 2014 14:56, Rene Mages (ramix) <[hidden email]> a écrit :

> Le 6 février 2014 11:45, Sebastien Audier <[hidden email]> a écrit :
>> Bonjour Rene,
>>
>> Je n'ai pas testé sur Pharo 3.0, mais on rencontre aussi ce genre de chose
>> dans Pharo 2.0.
>> A priori, tu peux toujours exécuter la commande suivante dans un workspace:
>>
>> ZnZincServerAdaptor startOn: 8080
>
> Merci beaucoup Sébastien.
> Après avoir re_vérifier qu'apache répond bien sur le port 8080 :
>        http://localhost:8080/
> j'ai évalué dans un workspace :
>      ZnZincServerAdaptor startOn: 8080
>            mais toujours rien à l'horizon ...
> J'ai vérifié que le package Zinc est bien présent dans mon image :
>     http://www.ffii.fr/ramix/pharo/ZnZincServerAdaptor.png
>
> Dans qq minutes je vais poster sur la liste dédiée à seaside :
>    http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside
> et bien entendu je reposterai sur smalltalk-fr@ dès que je comprendrai
> la raison de mon problème.

Grâce à l'aide de Sven van Caekenberghe (en Carbon Copy) :

http://lists.squeakfoundation.org/pipermail/seaside/2014-February/030544.html

j'ai enfin compris l'origine de mon problème :
le port 8080 d'apache étant déjà utilisé la solution consiste à
utiliser un autre port pour Seaside:

http://localhost:9090/

Tout fonctionne parfaitement désormais.
--
Amicalement.
Rene Mages ( GnuPG_key 1024D/2CC455D9 )
http://renemages.wordpress.com/smalltalk/pharo

--
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes Smalltalk-fr.
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse [hidden email].
Pour plus d'options, visitez le site https://groups.google.com/groups/opt_out .
Loading...