SqueakSSL Error when updating my image

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

SqueakSSL Error when updating my image

Christoph Thiede

Hi all,

maybe someone is interested in this error I received when updating my image this week in the debug console:

LoadLibrary(SqueakSSL) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.


)

LoadLibrary(SqueakSSL.dll) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.


)


Translated to English: SqueakSSL complains about an access violation twice. And by the way, at some point, there happens an interesting encoding error.


Everything else seems to work, I just wanted to mention this warning. Is this an error in the plugin?


Best,

Christoph



Reply | Threaded
Open this post in threaded view
|

Re: SqueakSSL Error when updating my image

marcel.taeumel
Hi Christoph,

under Windows 10, I have this issue frequently after a Windows Update. 2-3 reboots are required until the OpenSmalltalk VM is able to load modules again. I suspect it is related to some cache invalidation in the operating system and the VM not loading modules as it is supposed to do. :-) Just a rough guess.

Today, I had this too, after a Windows Update. Not just SqueakSSL, but also SqueakFFIPrims. 

Just reboot. And then reboot again. :-D

Best,
Marcel

Am 12.06.2020 15:35:12 schrieb Thiede, Christoph <[hidden email]>:

Hi all,

maybe someone is interested in this error I received when updating my image this week in the debug console:

LoadLibrary(SqueakSSL) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.


)

LoadLibrary(SqueakSSL.dll) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.


)


Translated to English: SqueakSSL complains about an access violation twice. And by the way, at some point, there happens an interesting encoding error.


Everything else seems to work, I just wanted to mention this warning. Is this an error in the plugin?


Best,

Christoph



Reply | Threaded
Open this post in threaded view
|

Re: SqueakSSL Error when updating my image

Tobias Pape
In reply to this post by Christoph Thiede

> On 12.06.2020, at 15:35, Thiede, Christoph <[hidden email]> wrote:
>
> Hi all,
>
> maybe someone is interested in this error I received when updating my image this week in the debug console:
>
> LoadLibrary(SqueakSSL) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>
> )
> LoadLibrary(SqueakSSL.dll) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>
> )
>
> Translated to English: SqueakSSL complains about an access violation twice. And by the way, at some point, there happens an interesting encoding error.
>
> Everything else seems to work, I just wanted to mention this warning. Is this an error in the plugin?

Rather in the way libs are loaded.
I don't know, This does not seem to be SqueakSSL specific, as it happens before the dll has been completely loaded (LoadLibrary):

This is from the respective file:

**************************************
  lstrcpy(libName,prefix);
  lstrcat(libName,baseName);
  lstrcat(libName,postfix);
  h = LoadLibrary(libName);
  if (h == NULL
#ifdef NDEBUG /* in production ignore errors for non-existent modules */
   && GetLastError() != ERROR_MOD_NOT_FOUND
#endif
      )
    vprintLastError(TEXT("LoadLibrary(%s)"), libName);
  return h;
**************************************


But maybe it is the dll itself that does strange things during DllMain or so. I don't see why tho…

Best regards
        -Tobias

Reply | Threaded
Open this post in threaded view
|

Re: SqueakSSL Error when updating my image

timrowledge
Any chance this relates to the failures (as in, complete failure, test broken) of the ssl socket stuff? Be nice to solve that one sometime.

> On 2020-07-06, at 3:02 AM, Tobias Pape <[hidden email]> wrote:
>
>
>> On 12.06.2020, at 15:35, Thiede, Christoph <[hidden email]> wrote:
>>
>> Hi all,
>>
>> maybe someone is interested in this error I received when updating my image this week in the debug console:
>>
>> LoadLibrary(SqueakSSL) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>>
>> )
>> LoadLibrary(SqueakSSL.dll) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>>
>> )
>>
>> Translated to English: SqueakSSL complains about an access violation twice. And by the way, at some point, there happens an interesting encoding error.
>>
>> Everything else seems to work, I just wanted to mention this warning. Is this an error in the plugin?
>
> Rather in the way libs are loaded.
> I don't know, This does not seem to be SqueakSSL specific, as it happens before the dll has been completely loaded (LoadLibrary):
>
> This is from the respective file:
>
> **************************************
>  lstrcpy(libName,prefix);
>  lstrcat(libName,baseName);
>  lstrcat(libName,postfix);
>  h = LoadLibrary(libName);
>  if (h == NULL
> #ifdef NDEBUG /* in production ignore errors for non-existent modules */
>   && GetLastError() != ERROR_MOD_NOT_FOUND
> #endif
>      )
>    vprintLastError(TEXT("LoadLibrary(%s)"), libName);
>  return h;
> **************************************
>
>
> But maybe it is the dll itself that does strange things during DllMain or so. I don't see why tho…
>
> Best regards
> -Tobias
>
>


tim
--
tim Rowledge; [hidden email]; http://www.rowledge.org/tim
Useful random insult:- "Body by Fisher -- brains by Mattel."



Reply | Threaded
Open this post in threaded view
|

Re: SqueakSSL Error when updating my image

Tobias Pape

> On 06.07.2020, at 18:57, tim Rowledge <[hidden email]> wrote:
>
> Any chance this relates to the failures (as in, complete failure, test broken) of the ssl socket stuff? Be nice to solve that one sometime.
>

i don't think so…

>> On 2020-07-06, at 3:02 AM, Tobias Pape <[hidden email]> wrote:
>>
>>
>>> On 12.06.2020, at 15:35, Thiede, Christoph <[hidden email]> wrote:
>>>
>>> Hi all,
>>>
>>> maybe someone is interested in this error I received when updating my image this week in the debug console:
>>>
>>> LoadLibrary(SqueakSSL) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>>>
>>> )
>>> LoadLibrary(SqueakSSL.dll) (998: Unzuläÿssiger Zugriff auf einen Speicherbereich.
>>>
>>> )
>>>
>>> Translated to English: SqueakSSL complains about an access violation twice. And by the way, at some point, there happens an interesting encoding error.
>>>
>>> Everything else seems to work, I just wanted to mention this warning. Is this an error in the plugin?
>>
>> Rather in the way libs are loaded.
>> I don't know, This does not seem to be SqueakSSL specific, as it happens before the dll has been completely loaded (LoadLibrary):
>>
>> This is from the respective file:
>>
>> **************************************
>> lstrcpy(libName,prefix);
>> lstrcat(libName,baseName);
>> lstrcat(libName,postfix);
>> h = LoadLibrary(libName);
>> if (h == NULL
>> #ifdef NDEBUG /* in production ignore errors for non-existent modules */
>>  && GetLastError() != ERROR_MOD_NOT_FOUND
>> #endif
>>     )
>>   vprintLastError(TEXT("LoadLibrary(%s)"), libName);
>> return h;
>> **************************************
>>
>>
>> But maybe it is the dll itself that does strange things during DllMain or so. I don't see why tho…
>>
>> Best regards
>> -Tobias
>>
>>
>
>
> tim