Strange SSL error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Strange SSL error

Chris Muller-4
An application I've been running for a couple of years has started
failing when trying to use WebClient.  I see a lot of instances of
this error in the console:

4149581508:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol:../../ssl/s23_clnt.c:531

Is this a SqueakSSL issue?  I have two versions of the SqueakSSL
plugin, one is < 100K the other is > 8.9MB from April, 2015, which I
think is Levente's statically-linked one.

The app needs to access various API's and scrape various web sites.
Any ideas on this error and what should I be running these days for
SqueakSSL?

thanks

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strange SSL error

Levente Uzonyi
Hi Chris,

This is probably an issue with SAN certificates. The sites you're trying
to access probably have changed to SAN certificates or changed the order
of the domain names listed in them.
If this is the case, then you might want to check your code with the
solution I posted here[1]. Note that it has been scraped in favor of
plugin-side certificate verification, but that hasn't been implemented
yet.

Levente

[1] http://forum.world.st/SqueakSSL-SAN-certificates-td4828767.html

On Mon, 26 Dec 2016, Chris Muller wrote:

> An application I've been running for a couple of years has started
> failing when trying to use WebClient.  I see a lot of instances of
> this error in the console:
>
> 4149581508:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
> protocol:../../ssl/s23_clnt.c:531
>
> Is this a SqueakSSL issue?  I have two versions of the SqueakSSL
> plugin, one is < 100K the other is > 8.9MB from April, 2015, which I
> think is Levente's statically-linked one.
>
> The app needs to access various API's and scrape various web sites.
> Any ideas on this error and what should I be running these days for
> SqueakSSL?
>
> thanks

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strange SSL error

Phil B
I've been seeing this and other SSL errors more frequently as well recently.  Keep in mind that a lot of people enabling SSL via services like Let's Encrypt have probably never done it before so there very well may be configuration issues such as http://askubuntu.com/questions/649000/openssl-curl-error-ssl23-get-server-hellotlsv1-alert-internal-error (note that this is an old issue but who knows what combination of OS/SSL are running on some of these servers)

On Dec 27, 2016 11:07 AM, "Levente Uzonyi" <[hidden email]> wrote:
Hi Chris,

This is probably an issue with SAN certificates. The sites you're trying to access probably have changed to SAN certificates or changed the order of the domain names listed in them.
If this is the case, then you might want to check your code with the solution I posted here[1]. Note that it has been scraped in favor of plugin-side certificate verification, but that hasn't been implemented yet.

Levente

[1] http://forum.world.st/SqueakSSL-SAN-certificates-td4828767.html

On Mon, 26 Dec 2016, Chris Muller wrote:

An application I've been running for a couple of years has started
failing when trying to use WebClient.  I see a lot of instances of
this error in the console:

<a href="tel:4149581508" value="+14149581508" target="_blank">4149581508:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol:../../ssl/s23_clnt.c:531

Is this a SqueakSSL issue?  I have two versions of the SqueakSSL
plugin, one is < 100K the other is > 8.9MB from April, 2015, which I
think is Levente's statically-linked one.

The app needs to access various API's and scrape various web sites.
Any ideas on this error and what should I be running these days for
SqueakSSL?

thanks



Loading...