Suggestion: rename some methods for consistency

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Suggestion: rename some methods for consistency

DougEdmunds
The vast majority of example methods follow a consistent naming pattern where
the word 'example' starts the method name. There's a handful that don't.

The advantage of this approach is that all the examples appear together in
the browser list of methods.

I suggest that these methods be renamed:

  BorderedMorph class >> gradientExample
    --> exampleGradient
  SimpleHierarchicalListMorph class >> submorphsExample
    --> exampleSubmorphs
  PluggableMenuSpec class >> withOneSingleItemExample
    --> exampleWithOneSingleItem
  PluggableMenuSpec class >> withSubMenuExample
    --> exampleWithSubMenu
  PluggableMenuSpec class >> withTwoSimpleItemsExample
    --> exampleWithTwoSimpleItems
  DigitalSignatureAlgorith >> writeExamplesToDisk
    --> exampleWriteToDisk
  UITheme class >> textEntryWithCompletionDialog
    --> exampletextEntryWithCompletionDialog
  UITheme class >> closeExampleDialogs
    --> exampleCloseDialogs
 
 (I've excluded test and testcase examples from this list).