I think this came about from the MutliByteFileStream work, where there are a lot of #basic.. calls. The idea there is to bypass the MultiByte work, and use the more basic version of the calls. In that class it translates into a super call of the normal call (so, #basicUpTo: calls super upTo:).
I suspect the phrase #basicUpTo: is in refers to the basic for of upTo: and not the complex form of upTo:.
In either case, this fix was to just fix a lurking bug, not addressing the naming of the calls already there.