Trouble with checking out from Github

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Trouble with checking out from Github

Hi, I have three computers and two of these, one Linux and one Mac works
excellent with Iceberg.

But I have a difficult child, one laptop where I can not checkout code from
a private github repo. It keeps running into stacktrace, nomatter which
strategy I select.

Problems does not seem to be connected to versions. I have tried different
versions of Pharo images, from 8-stable to 9-bleeding edge.

I have ticked the ssh-setting in Pharo for using custom keys and verified
that these exists and has right permissions.

Checkout from ssh in shell works fine.

I have tried these strategies.

1) Using the add-key trick which is referred as a solution on this, like in
ssh-add ~/.ssh/id_rsa

This always results in stacktrace in Pharo.

2) Checking out as as github-repo with ssh, same problem

3) Checking out as a git-repo, same problem

4) Generated new ssh-keys and tried to setup these as the default keys

Same stack trace problem in Pharo.

5) Checking out over https

This does not work either. The ssh-checkout box appears in Pharo even though
I select this specifically. Checking out over https-does not seem to be
working at all?

Version on ssh on my laptop is:

ssh: OpenSSH_8.1p1, LibreSSL 2.7.3
mac: Catalina 10.15.6

Interesting enough I have the same versions on my working mac. Only
difference is that the default ssh-key is with a passphrase on the
non-working computer (entering this in the ssh does not help, creating a new
ssh-keypair without a passphrase does not make a difference either).

ssh_config is also equal on the two computers.

Has anybody solved a case like this or has any clues? This beats me :)

And when Iceberg is up and running I must say it is really a valuable and
nice tool, thx!


Sent from: