Quantcast

Ubuntu 16.04 LTS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Ubuntu 16.04 LTS

GLASS mailing list
Hi guys,

Thanks for the details in your answer about DevKit Dale! I thought that was for the development parts only, didn’t knew that devKit could be used for installing the server too.

The current target for an ubuntu install is 16.04 LTS 64bits

I was taking a look at OS pre-requisites here

and all aims to 32bits, I am missing something?

BTW I’ve saw also this doc on how to install gemstone in 64bits, updated to Ubuntu 12.04 which isn’t supported anymore (or it ends its LTS in a couple of months).

One thing I’ve noticed is its size, it’s really long and feels like many things can go wrong and lots of devops costs would sunk into that.

Paul, is your ansible scripts solving that problem? I mean, the ansible script you mention uses this as blueprints/plan on what to do? If so, is there anything I can do to help you to get it out? 

thanks!



_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list


On 1/14/17 6:16 AM, Sebastian Sastre via Glass wrote:

> Hi guys,
>
> Thanks for the details in your answer about DevKit Dale! I thought
> that was for the development parts only, didn’t knew that devKit could
> be used for installing the server too.
>
> The current target for an ubuntu install is 16.04 LTS 64bits
>
> I was taking a look at OS pre-requisites here
> https://github.com/sebastianconcept/gsDevKitHome/blob/master/docs/osPrereqs/osPrereqs.md#gsdevkit-operating-system-prerequisites
>
> and all aims to 32bits, I am missing something?
GsDevKit_home uses some code written in pharo for standard operations
that I chose not to implement in bash:) Things like parsing .ston files
and file manipulation creation algos... and of course pharo requires 32
bit libraries.
>
> BTW I’ve saw also this doc on how to install gemstone in 64bits,
> updated to Ubuntu 12.04 which isn’t supported anymore (or it ends its
> LTS in a couple of months).
> https://downloads.gemtalksystems.com/docs/GemStone64/3.3.x/GS64-InstallGuide-Linux-3.3/GS64-InstallGuide-Linux-3.3.htm?https://downloads.gemtalksystems.com/docs/GemStone64/3.3.x/GS64-InstallGuide-Linux-3.3/1-Installation.htm
Yes, that is a bit misleading. 3.3.1 claims support for 12.04 and 14.04
and I believe that GemStone3.x runs on 16.04 as well. Personally I've
been doing development on 14.04 for quite a while. Typically the
"supported" designation lags a bit behind, as it is representative of
the operating systems that we run the full QA suite against and our
development cycle is not necessarily in synch with Ubunutu's cycle.

Also our big commercial customers typically jump on the latest versions
of the various operating systems so there is not the commercial demand
for moving our QA environment to the latest operating system versions.

I have no reason to believe that there are issues with running on or
doing development on 16.04, but for production purposes, it is best to
follow our supported platform guidelines.
> One thing I’ve noticed is its size, it’s really long and feels like
> many things can go wrong and lots of devops costs would sunk into that.
GsDevKit_home is aimed at an creating an initial install ... a number of
the pieces that get built from scratch during the initial install can be
reused for subsequent installations for sandboxes and production machines,
> Paul, is your ansible scripts solving that problem? I mean, the
> ansible script you mention uses this as blueprints/plan on what to do?
> If so, is there anything I can do to help you to get it out?
I think that for production, the standard GsDevKit_home directory
structure is not quite adequate ... for best performance you will want
to make sure that your tranlogs and extent directories on separate
filesystems as well as make allowances for monitoring gem processes,
restarting the stone on system startup, etc. and those types of
customizations are best described by something like ansible ...

Dale
_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list
In reply to this post by GLASS mailing list

I've copied the 14.04 prerequisites (in the installation scripts) and copied them as 16.04 and so far I've never seen any problems on our various machines.


Marten



_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list



On 1/15/17 12:45 PM, Marten Feldtmann via Glass wrote:

I've copied the 14.04 prerequisites (in the installation scripts) and copied them as 16.04 and so far I've never seen any problems on our various machines.


That's good to know and it confirms the change that was made for PR#150[1] back in November.

Thanks,

Dale

[1]https://github.com/GsDevKit/GsDevKit_home/pull/150

Marten




_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list
Great!

Thanks for the quick response and merge!

Question, I see many requisites like:

sudo dpkg --add-architecture i386

I wonder if GemStone installation via DevKit is 32 bits or is it 64?

Thanks!


On Jan 15, 2017, at 6:49 PM, Dale Henrichs via Glass <[hidden email]> wrote:



On 1/15/17 12:45 PM, Marten Feldtmann via Glass wrote:

I've copied the 14.04 prerequisites (in the installation scripts) and copied them as 16.04 and so far I've never seen any problems on our various machines.


That's good to know and it confirms the change that was made for PR#150[1] back in November.

Thanks,

Dale

[1]https://github.com/GsDevKit/GsDevKit_home/pull/150

Marten




_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list



On 1/15/17 12:55 PM, Sebastian Sastre wrote:
Great!

Thanks for the quick response and merge!

Question, I see many requisites like:
sudo dpkg --add-architecture i386
I wonder if GemStone installation via DevKit is 32 bits or is it 64?
GemStone is 64-bit, but Pharo3.0 is used in some places in GsDevKit_home and Pharo requires the 32-bit libraries ... when all of the bugs are shaken out of the Pharo64 bit vm/implementation, especially the UFFI cod and I (or someone else) has the time to port the $GS_HOME/shared/repos/todeClient code to 64 bit Pharo then the 32 bit libraries will no longer be required ...

Dale

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 LTS

GLASS mailing list
That makes sense. 

Cool!!



On Jan 15, 2017, at 8:46 PM, Dale Henrichs <[hidden email]> wrote:



On 1/15/17 12:55 PM, Sebastian Sastre wrote:
Great!

Thanks for the quick response and merge!

Question, I see many requisites like:
sudo dpkg --add-architecture i386
I wonder if GemStone installation via DevKit is 32 bits or is it 64?
GemStone is 64-bit, but Pharo3.0 is used in some places in GsDevKit_home and Pharo requires the 32-bit libraries ... when all of the bugs are shaken out of the Pharo64 bit vm/implementation, especially the UFFI cod and I (or someone else) has the time to port the $GS_HOME/shared/repos/todeClient code to 64 bit Pharo then the 32 bit libraries will no longer be required ...

Dale


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Loading...