Quantcast

VA Smalltalk V 8.6.3 - Error loading z.ST. Server Smalltalk (SST) - HTTP

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

VA Smalltalk V 8.6.3 - Error loading z.ST. Server Smalltalk (SST) - HTTP

Klaus Breker-2
Hello,

trying to load the Config Map >>z.ST. Server Smaalltalk (SST) - HTTP<< in Version 8.6.3 the load fails in #SciSocketManager -> #initializeLastError -> #Platformfunction -> #call
with the error message: 'Primitive failed calling ''SOCKETS'':WSAGetLastError from PlatformFunction>>#call due to OS error126'. Is there a dll missing or what ever?
Windows is version 7 running in a virtual desktop environment.

Stack trace added in file scirerror.txt

Kind regards

Klaus



--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.

scierror.txt (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: VA Smalltalk V 8.6.3 - Error loading z.ST. Server Smalltalk (SST) - HTTP

Seth Berman
Hello Klaus,

The defaults for SOCKETS in the [Platform Name Mappings] section of the abt.ini file looks like the following in 8.6.3.
SOCKET_PRIMS=
SOCKETS=ws2_32

Is this what yours looks like?

-- Seth

On Friday, December 16, 2016 at 6:24:07 AM UTC-5, Klaus Breker wrote:
Hello,

trying to load the Config Map >>z.ST. Server Smaalltalk (SST) - HTTP<< in Version 8.6.3 the load fails in #SciSocketManager -> #initializeLastError -> #Platformfunction -> #call
with the error message: 'Primitive failed calling ''SOCKETS'':WSAGetLastError from PlatformFunction>>#call due to OS error126'. Is there a dll missing or what ever?
Windows is version 7 running in a virtual desktop environment.

Stack trace added in file scirerror.txt

Kind regards

Klaus



--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: VA Smalltalk V 8.6.3 - Error loading z.ST. Server Smalltalk (SST) - HTTP

Klaus Breker-2
Hello Seth,

thank you for your hint. In the abt.ini SOCKETS=ws2_32 was missing.

It is loading without any error :-)

Klaus

Am Freitag, 16. Dezember 2016 15:10:51 UTC+1 schrieb Seth Berman:
Hello Klaus,

The defaults for SOCKETS in the [Platform Name Mappings] section of the abt.ini file looks like the following in 8.6.3.
SOCKET_PRIMS=
SOCKETS=ws2_32

Is this what yours looks like?

-- Seth

On Friday, December 16, 2016 at 6:24:07 AM UTC-5, Klaus Breker wrote:
Hello,

trying to load the Config Map >>z.ST. Server Smaalltalk (SST) - HTTP<< in Version 8.6.3 the load fails in #SciSocketManager -> #initializeLastError -> #Platformfunction -> #call
with the error message: 'Primitive failed calling ''SOCKETS'':WSAGetLastError from PlatformFunction>>#call due to OS error126'. Is there a dll missing or what ever?
Windows is version 7 running in a virtual desktop environment.

Stack trace added in file scirerror.txt

Kind regards

Klaus



--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: VA Smalltalk V 8.6.3 - Error loading z.ST. Server Smalltalk (SST) - HTTP

Seth Berman
Hello Klaus,

My pleasure and I'm glad to hear.

-- Seth

On Monday, December 19, 2016 at 6:23:57 AM UTC-5, Klaus Breker wrote:
Hello Seth,

thank you for your hint. In the abt.ini SOCKETS=ws2_32 was missing.

It is loading without any error :-)

Klaus

Am Freitag, 16. Dezember 2016 15:10:51 UTC+1 schrieb Seth Berman:
Hello Klaus,

The defaults for SOCKETS in the [Platform Name Mappings] section of the abt.ini file looks like the following in 8.6.3.
SOCKET_PRIMS=
SOCKETS=ws2_32

Is this what yours looks like?

-- Seth

On Friday, December 16, 2016 at 6:24:07 AM UTC-5, Klaus Breker wrote:
Hello,

trying to load the Config Map >>z.ST. Server Smaalltalk (SST) - HTTP<< in Version 8.6.3 the load fails in #SciSocketManager -> #initializeLastError -> #Platformfunction -> #call
with the error message: 'Primitive failed calling ''SOCKETS'':WSAGetLastError from PlatformFunction>>#call due to OS error126'. Is there a dll missing or what ever?
Windows is version 7 running in a virtual desktop environment.

Stack trace added in file scirerror.txt

Kind regards

Klaus



--
You received this message because you are subscribed to the Google Groups "VA Smalltalk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/va-smalltalk.
For more options, visit https://groups.google.com/d/optout.
Loading...