Quantcast

WebVelocity 1.1 Beta

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

WebVelocity 1.1 Beta

jarober
We are making the first beta of WebVelocity 1.1 available.  Please note that the license for this beta is the same as the one for the "Lite" download - you can use this for development and testing, but commercial deployment requires a license from Cincom - not to mention the fact that we would advise against commercial deployment with a beta product, even if you have a WebVelocity license.  You may want to maintain your existing WebVelocity 1.1 installation; this release is not completely compatible with 1.0.

The details:

Released 1.1.248. This is our first beta for WV1.1.


Here is a list of issue fixed in this release:

60155<CI>(Web Velocity) WV: Unloading an application that has live glorp sessions leaves around garbage that breaks trackers
60153<CI>(Web Velocity) WV: SQLite integration issues
60442<HI>(Web Velocity) WV: incorrect order of arguments in attributeCallback
60439<HI>(Web Velocity) Changing WebVelocity settings doesn't work
60471<MI>(Web Velocity) The SQLite3 seaside configuration has extra parameters
60441<MI>(Web Velocity) WV: Process>>putUnderDebug returns inconsistent values
59486<MI>(Web Velocity) WV build consumes 95% CPU on startup due to malformed configuration files


These are issues we are currently working on or will be in the near future:

60167<HR>(Web Velocity) WV: The workflow for setting up your database connection is awkward.
60478<HO>(Web Velocity) WV: Recreating tables of a sqlite3 database fails
60476<HO>(Web Velocity) WV: Test that you can create, update, delete active record objects from the console
60477<MO>(Web Velocity) WV: Sometimes a debugger takes over a development page and clicking on a link brings you back to the debugger
60460<MO>(Web Velocity) WV: Ensure that changing server settings will have effect on SeasideServer.
58988<MO>(Seaside) [WV] Document porting applications from 1.0 to 1.1
58983<MO>(Seaside) [WV] Document headless deployment
58982<MO>(Seaside) [WV] Document deployment to Amazon Cloud Computing (EC2)
58981<MO>(Seaside) [WV] Document Amazon RDS Support
56803<MO>(Seaside) [WV] Document a Debugging example in one of the walk-throughs



WebVelocity Team

Please, send comments to
[hidden email]

James Robertson
Cincom Smalltalk Product Evangelist
Talk Small and Carry a Big Class Library




--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Randal L. Schwartz
>>>>> "James" == James Robertson <[hidden email]> writes:

James> We are making the first beta of WebVelocity 1.1 available.

Doesn't even launch for me. :(

Is this dependent on Snow Leopard, by any chance?

--
Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
<[hidden email]> <URL:http://www.stonehenge.com/merlyn/>
Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
See http://methodsandmessages.vox.com/ for Smalltalk and Seaside discussion

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Randal L. Schwartz
>>>>> "Randal" == Randal L Schwartz <[hidden email]> writes:

Randal> Doesn't even launch for me. :(

Ahh, there's a webvelocity process running, but it never fires up my
browser.  Isn't it supposed to automatically launch my browser?

--
Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
<[hidden email]> <URL:http://www.stonehenge.com/merlyn/>
Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
See http://methodsandmessages.vox.com/ for Smalltalk and Seaside discussion

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Randal L. Schwartz
>>>>> "Randal" == Randal L Schwartz <[hidden email]> writes:

Randal> Ahh, there's a webvelocity process running, but it never fires up my
Randal> browser.  Isn't it supposed to automatically launch my browser?

OK, it tried to connect to the hostname that is the reverse of 127.0.0.1
(which was an adblocker entry in my hosts file) port 7777.  That's
not gonna work very well.  It should literally just try 127.0.0.1.

But after sorting that out, it wants a username and password, for
the realm "WebVelocity Development".

Where is that in the instructions here?

--
Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
<[hidden email]> <URL:http://www.stonehenge.com/merlyn/>
Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
See http://methodsandmessages.vox.com/ for Smalltalk and Seaside discussion

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Michael Lucas-Smith-2
On 6/5/10 11:28 AM, Randal L. Schwartz wrote:
"Randal" == Randal L Schwartz [hidden email] writes:
            
Randal> Ahh, there's a webvelocity process running, but it never fires up my
Randal> browser.  Isn't it supposed to automatically launch my browser?

OK, it tried to connect to the hostname that is the reverse of 127.0.0.1
(which was an adblocker entry in my hosts file) port 7777.  That's
not gonna work very well.  It should literally just try 127.0.0.1.

But after sorting that out, it wants a username and password, for
the realm "WebVelocity Development".

Where is that in the instructions here?

  
Good point! the username is 'admin' and the password is 'password' unless you go in to the settings and configure it for something different.

Michael

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Geert Claes
Administrator

Thanks, I struggled with that one too :)


Michael Lucas-Smith-2 wrote:

>
>
>> But after sorting that out, it wants a username and password, for the
>> realm "WebVelocity Development".
>>
>> Where is that in the instructions here?
>>
>    
> Good point! the username is '*admin*' and the password is '*password*'
> unless you go in to the settings and configure it for something different.
>
--
View this message in context: http://forum.world.st/WebVelocity-1-1-Beta-tp2244398p2251885.html
Sent from the WebVelocity mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WebVelocity 1.1 Beta

Geert Claes
Administrator
In reply to this post by Michael Lucas-Smith-2
Thanks, I struggled with that one too :)

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Loading...