installation of packages on 6.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

installation of packages on 6.1

Baveco, Hans

Trying to install Territorial the installation got stuck on the installation of Roassal2 1.35, with error “LGitObjectNotInitialized”

 

Transcript says:

 

“Project: Roassal2 1.35

I got an error while cloning: There was an authentication error while trying to execute the operation: error authenticating: failed connecting agent.

This happens usually because you didn't provide a valid set of credentials.

You may fix this problem in different ways:

 

1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in your command line.

2. adding your keys in settings (open settings browser search for "Use custom SSH keys" and

add your public and private keys).

3. using HTTPS instead SSH (Just use an url in the form HTTPS://etc.git). I will try to clone the HTTPS variant.”

 

I have encountered this several times before, for different packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540])) and have no idea how to deal with this.

 

Any suggestions?

 

Hans


PharoDebug.log (20K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

hernanmd
Hi Hans,

How did you tried?
Using the following expression I got a different error:

Gofer it
  smalltalkhubUser: ’hernan’ project: ’Territorial’;
  configuration;
  loadBleedingEdge.


LGit_GIT_ERROR: Failed to connect to github.com: Invalid argument.


2018-04-05 13:02 GMT-03:00 Baveco, Hans <[hidden email]>:

> Trying to install Territorial the installation got stuck on the installation
> of Roassal2 1.35, with error “LGitObjectNotInitialized”
>
>
>
> Transcript says:
>
>
>
> “Project: Roassal2 1.35
>
> I got an error while cloning: There was an authentication error while trying
> to execute the operation: error authenticating: failed connecting agent.
>
> This happens usually because you didn't provide a valid set of credentials.
>
> You may fix this problem in different ways:
>
>
>
> 1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in your
> command line.
>
> 2. adding your keys in settings (open settings browser search for "Use
> custom SSH keys" and
>
> add your public and private keys).
>
> 3. using HTTPS instead SSH (Just use an url in the form HTTPS://etc.git). I
> will try to clone the HTTPS variant.”
>
>
>
> I have encountered this several times before, for different packages (on
> windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540])) and have no
> idea how to deal with this.
>
>
>
> Any suggestions?
>
>
>
> Hans

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Baveco, Hans

I used:

Metacello new
                smalltalkhubUser: 'hernan' project: 'Territorial';
                configuration: 'Territorial';
                version: #'bleedingEdge';
                load

I don't think the problem is related to Territorial; same thing happened when trying to load Roassal2 directly or some other packages
Hans

-----Original Message-----
From: Hernán Morales Durand <[hidden email]>
Sent: donderdag 5 april 2018 20:58
To: Any question about pharo is welcome <[hidden email]>
Subject: Re: [Pharo-users] installation of packages on 6.1

Hi Hans,

How did you tried?
Using the following expression I got a different error:

Gofer it
  smalltalkhubUser: ’hernan’ project: ’Territorial’;
  configuration;
  loadBleedingEdge.


LGit_GIT_ERROR: Failed to connect to github.com: Invalid argument.


2018-04-05 13:02 GMT-03:00 Baveco, Hans <[hidden email]>:

> Trying to install Territorial the installation got stuck on the
> installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>
>
>
> Transcript says:
>
>
>
> “Project: Roassal2 1.35
>
> I got an error while cloning: There was an authentication error while
> trying to execute the operation: error authenticating: failed connecting agent.
>
> This happens usually because you didn't provide a valid set of credentials.
>
> You may fix this problem in different ways:
>
>
>
> 1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in
> your command line.
>
> 2. adding your keys in settings (open settings browser search for "Use
> custom SSH keys" and
>
> add your public and private keys).
>
> 3. using HTTPS instead SSH (Just use an url in the form
> HTTPS://etc.git). I will try to clone the HTTPS variant.”
>
>
>
> I have encountered this several times before, for different packages
> (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540]))
> and have no idea how to deal with this.
>
>
>
> Any suggestions?
>
>
>
> Hans


Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Stephane Ducasse-3
In reply to this post by Baveco, Hans
Hi hans

did you succeed to download any other github stored projects?

Stef

On Thu, Apr 5, 2018 at 6:02 PM, Baveco, Hans <[hidden email]> wrote:

> Trying to install Territorial the installation got stuck on the installation
> of Roassal2 1.35, with error “LGitObjectNotInitialized”
>
>
>
> Transcript says:
>
>
>
> “Project: Roassal2 1.35
>
> I got an error while cloning: There was an authentication error while trying
> to execute the operation: error authenticating: failed connecting agent.
>
> This happens usually because you didn't provide a valid set of credentials.
>
> You may fix this problem in different ways:
>
>
>
> 1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in your
> command line.
>
> 2. adding your keys in settings (open settings browser search for "Use
> custom SSH keys" and
>
> add your public and private keys).
>
> 3. using HTTPS instead SSH (Just use an url in the form HTTPS://etc.git). I
> will try to clone the HTTPS variant.”
>
>
>
> I have encountered this several times before, for different packages (on
> windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540])) and have no
> idea how to deal with this.
>
>
>
> Any suggestions?
>
>
>
> Hans

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Baveco, Hans
Hi Stef,

No, for example loading GToolkit with

Metacello new
   baseline: 'GToolkit';
   repository: 'github://feenkcom/gtoolkit/src';
   load.

Immediately results in an "LGit_GIT_ERROR: failed to get server certificate: The handle is in the wrong state for the requested operation"

Hans



-----Original Message-----
From: Stephane Ducasse <[hidden email]>
Sent: zaterdag 7 april 2018 17:29
To: Any question about pharo is welcome <[hidden email]>
Subject: Re: [Pharo-users] installation of packages on 6.1

Hi hans

did you succeed to download any other github stored projects?

Stef

On Thu, Apr 5, 2018 at 6:02 PM, Baveco, Hans <[hidden email]> wrote:

> Trying to install Territorial the installation got stuck on the
> installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>
>
>
> Transcript says:
>
>
>
> “Project: Roassal2 1.35
>
> I got an error while cloning: There was an authentication error while
> trying to execute the operation: error authenticating: failed connecting agent.
>
> This happens usually because you didn't provide a valid set of credentials.
>
> You may fix this problem in different ways:
>
>
>
> 1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in
> your command line.
>
> 2. adding your keys in settings (open settings browser search for "Use
> custom SSH keys" and
>
> add your public and private keys).
>
> 3. using HTTPS instead SSH (Just use an url in the form
> HTTPS://etc.git). I will try to clone the HTTPS variant.”
>
>
>
> I have encountered this several times before, for different packages
> (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540]))
> and have no idea how to deal with this.
>
>
>
> Any suggestions?
>
>
>
> Hans


Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Ben Coman
In reply to this post by Baveco, Hans


On 6 April 2018 at 00:02, Baveco, Hans <[hidden email]> wrote:

Trying to install Territorial the installation got stuck on the installation of Roassal2 1.35, with error “LGitObjectNotInitialized”

 

Transcript says:

 

“Project: Roassal2 1.35

I got an error while cloning: There was an authentication error while trying to execute the operation: error authenticating: failed connecting agent.

This happens usually because you didn't provide a valid set of credentials.

You may fix this problem in different ways:

 

1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in your command line.

2. adding your keys in settings (open settings browser search for "Use custom SSH keys" and

add your public and private keys).

3. using HTTPS instead SSH (Just use an url in the form HTTPS://etc.git). I will try to clone the HTTPS variant.”

 

I have encountered this several times before, for different packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540])) and have no idea how to deal with this.

 

Any suggestions?

 

Hans


On Windows you need to use option 2.  World Menu > Settings > etc...

cheers -ben
Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Baveco, Hans

Thanks Ben!

I created a github account, installed git and git bash, created SSH keys, added keys to my github account, and changed the settings in Pharo to use these keys, and finally was able to install the packages I wanted to try. (roassal2 still not installing though).

Question remains, is this really the only way to get these packages that live on github into the image? I had no plans to work with git/github, but was now forced to spent quite some time on it....

 

Cheers,

Hans

 

 

 

From: Ben Coman <[hidden email]>
Sent: maandag 9 april 2018 22:54
To: Any question about pharo is welcome <[hidden email]>
Subject: Re: [Pharo-users] installation of packages on 6.1

 

 

 

On 6 April 2018 at 00:02, Baveco, Hans <[hidden email]> wrote:

Trying to install Territorial the installation got stuck on the installation of Roassal2 1.35, with error “LGitObjectNotInitialized”

 

Transcript says:

 

“Project: Roassal2 1.35

I got an error while cloning: There was an authentication error while trying to execute the operation: error authenticating: failed connecting agent.

This happens usually because you didn't provide a valid set of credentials.

You may fix this problem in different ways:

 

1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa in your command line.

2. adding your keys in settings (open settings browser search for "Use custom SSH keys" and

add your public and private keys).

3. using HTTPS instead SSH (Just use an url in the form HTTPS://etc.git). I will try to clone the HTTPS variant.”

 

I have encountered this several times before, for different packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update: #60540])) and have no idea how to deal with this.

 

Any suggestions?

 

Hans

 

On Windows you need to use option 2.  World Menu > Settings > etc...

 

cheers -ben

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Herby Vojčík
No, it is possible to install them without github account.

You need to set protocol to https:

  Iceberg enableMetacelloIntegration: true; remoteTypeSelector: #httpsUrl.

Herby

Baveco, Hans wrote:

> Thanks Ben!
>
> I created a github account, installed git and git bash, created SSH
> keys, added keys to my github account, and changed the settings in
> Pharo to use these keys, and finally was able to install the packages
> I wanted to try. (roassal2 still not installing though).
>
> Question remains, is this really the only way to get these packages
> that live on github into the image? I had no plans to work with
> git/github, but was now forced to spent quite some time on it....
>
> Cheers,
>
> Hans
>
> *From:*Ben Coman <[hidden email]>
> *Sent:* maandag 9 april 2018 22:54
> *To:* Any question about pharo is welcome <[hidden email]>
> *Subject:* Re: [Pharo-users] installation of packages on 6.1
>
> On 6 April 2018 at 00:02, Baveco, Hans <hans.baveco@
wur.nl

> <mailto:[hidden email]>> wrote:
>
>     Trying to install Territorial the installation got stuck on the
>     installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>
>     Transcript says:
>
>     “Project: Roassal2 1.35
>
>     I got an error while cloning: There was an authentication error
>     while trying to execute the operation: error authenticating:
>     failed connecting agent.
>
>     This happens usually because you didn't provide a valid set of
>     credentials.
>
>     You may fix this problem in different ways:
>
>     1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa
>     in your command line.
>
>     2. adding your keys in settings (open settings browser search for
>     "Use custom SSH keys" and
>
>     add your public and private keys).
>
>     3. using HTTPS instead SSH (Just use an url in the form
>     HTTPS://etc.git). I will try to clone the HTTPS variant.”
>
>     I have encountered this several t
imes before, for different

>     packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update:
>     #60540])) and have no idea how to deal with this.
>
>     Any suggestions?
>
>     Hans
>
> On Windows you need to use option 2. World Menu > Settings > etc...
>
> cheers -ben
>

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Stephane Ducasse-3
Hans

just a meta remark (I personally find the API of git quite terrible -
In addition I do not really like the github UI it feels like these
ugly google noUIDesigned "UI")
now you should consider that more and more people find git cool and
powerful. And as a matter of fact it is.
So you should consider that understanding and learning git is a way to
look less obsolete in the future. And it has nothing to do with Pharo.
Except that Pharo is becoming less foreign for mamy people thank to this.
I worked super well with git and iceberg on projects managing my dev
in a branch before it is ready to be incorporated.
So solid branches was what was really missing to monticello and before
you use it you may have problems to really assess them
but once you work with them you get the power they bring and the comfort.
Guille is working on a nice explanation of Git and central concept of
branch and you may want to read (at least I will read it because
Guille
understand it super super well).

Stef


On Wed, Apr 11, 2018 at 11:23 AM, Herbert Vojčík <[hidden email]> wrote:

> No, it is possible to install them without github account.
>
> You need to set protocol to https:
>
>  Iceberg enableMetacelloIntegration: true; remoteTypeSelector: #httpsUrl.
>
> Herby
>
> Baveco, Hans wrote:
>>
>> Thanks Ben!
>>
>> I created a github account, installed git and git bash, created SSH keys,
>> added keys to my github account, and changed the settings in Pharo to use
>> these keys, and finally was able to install the packages I wanted to try.
>> (roassal2 still not installing though).
>>
>> Question remains, is this really the only way to get these packages that
>> live on github into the image? I had no plans to work with git/github, but
>> was now forced to spent quite some time on it....
>>
>> Cheers,
>>
>> Hans
>>
>> *From:*Ben Coman <[hidden email]>
>> *Sent:* maandag 9 april 2018 22:54
>> *To:* Any question about pharo is welcome <[hidden email]>
>> *Subject:* Re: [Pharo-users] installation of packages on 6.1
>>
>> On 6 April 2018 at 00:02, Baveco, Hans <hans.baveco@
>
> wur.nl
>>
>> <mailto:[hidden email]>> wrote:
>>
>>     Trying to install Territorial the installation got stuck on the
>>     installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>>
>>     Transcript says:
>>
>>     “Project: Roassal2 1.35
>>
>>     I got an error while cloning: There was an authentication error
>>     while trying to execute the operation: error authenticating:
>>     failed connecting agent.
>>
>>     This happens usually because you didn't provide a valid set of
>>     credentials.
>>
>>     You may fix this problem in different ways:
>>
>>     1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa
>>     in your command line.
>>
>>     2. adding your keys in settings (open settings browser search for
>>     "Use custom SSH keys" and
>>
>>     add your public and private keys).
>>
>>     3. using HTTPS instead SSH (Just use an url in the form
>>     HTTPS://etc.git). I will try to clone the HTTPS variant.”
>>
>>     I have encountered this several t
>
> imes before, for different
>>
>>     packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update:
>>     #60540])) and have no idea how to deal with this.
>>
>>     Any suggestions?
>>
>>     Hans
>>
>> On Windows you need to use option 2. World Menu > Settings > etc...
>>
>> cheers -ben
>>
>

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Offray Vladimir Luna Cárdenas-2
In reply to this post by Herby Vojčík
Hi Baveco,

You don't need all this overcomplex Git paraphernalia to install a
package. I had a really unpleasant morning one day because of that and
mention it on the list and was corrected for the Bloc package.
Unfortunately the default documentation for some package still thinks in
the painful "Git way" (TM) of getting a package.

Despite that, I think that proper branching and creating a bridge with
file system versioning is needed. I hope to be able to help/hold until
Iceberg Fossil integration works without going the Git Way for my own
package but providing the advantages of file based DVCS.

Cheers,

Offray


On 11/04/18 04:23, Herbert Vojčík wrote:

> No, it is possible to install them without github account.
>
> You need to set protocol to https:
>
>  Iceberg enableMetacelloIntegration: true; remoteTypeSelector: #httpsUrl.
>
> Herby
>
> Baveco, Hans wrote:
>> Thanks Ben!
>>
>> I created a github account, installed git and git bash, created SSH
>> keys, added keys to my github account, and changed the settings in
>> Pharo to use these keys, and finally was able to install the packages
>> I wanted to try. (roassal2 still not installing though).
>>
>> Question remains, is this really the only way to get these packages
>> that live on github into the image? I had no plans to work with
>> git/github, but was now forced to spent quite some time on it....
>>
>> Cheers,
>>
>> Hans
>>
>> *From:*Ben Coman <[hidden email]>
>> *Sent:* maandag 9 april 2018 22:54
>> *To:* Any question about pharo is welcome <[hidden email]>
>> *Subject:* Re: [Pharo-users] installation of packages on 6.1
>>
>> On 6 April 2018 at 00:02, Baveco, Hans <hans.baveco@
> wur.nl
>> <mailto:[hidden email]>> wrote:
>>
>>     Trying to install Territorial the installation got stuck on the
>>     installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>>
>>     Transcript says:
>>
>>     “Project: Roassal2 1.35
>>
>>     I got an error while cloning: There was an authentication error
>>     while trying to execute the operation: error authenticating:
>>     failed connecting agent.
>>
>>     This happens usually because you didn't provide a valid set of
>>     credentials.
>>
>>     You may fix this problem in different ways:
>>
>>     1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa
>>     in your command line.
>>
>>     2. adding your keys in settings (open settings browser search for
>>     "Use custom SSH keys" and
>>
>>     add your public and private keys).
>>
>>     3. using HTTPS instead SSH (Just use an url in the form
>>     HTTPS://etc.git). I will try to clone the HTTPS variant.”
>>
>>     I have encountered this several t
> imes before, for different
>>     packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update:
>>     #60540])) and have no idea how to deal with this.
>>
>>     Any suggestions?
>>
>>     Hans
>>
>> On Windows you need to use option 2. World Menu > Settings > etc...
>>
>> cheers -ben
>>
>
>


Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Herby Vojčík
In reply to this post by Herby Vojčík
To make things merrier, when you set procotol to https, you don't need anything of the cruft from before: no ssh keys, no setting up an account, setting git username etc. You get read-only access to all public github:// and bitbucket:// repos with no additional setup.

The con is the “read-only” - you cannot (easily) develop / contribute to them. But if your only concern is to be able to load dependencies, setting protocol to https is easiest way to go.

Herby

On April 11, 2018 11:23:24 AM GMT+02:00, "Herbert Vojčík" <[hidden email]> wrote:

>No, it is possible to install them without github account.
>
>You need to set protocol to https:
>
>Iceberg enableMetacelloIntegration: true; remoteTypeSelector:
>#httpsUrl.
>
>Herby
>
>Baveco, Hans wrote:
>> Thanks Ben!
>>
>> I created a github account, installed git and git bash, created SSH
>> keys, added keys to my github account, and changed the settings in
>> Pharo to use these keys, and finally was able to install the packages
>
>> I wanted to try. (roassal2 still not installing though).
>>
>> Question remains, is this really the only way to get these packages
>> that live on github into the image? I had no plans to work with
>> git/github, but was now forced to spent quite some time on it....
>>
>> Cheers,
>>
>> Hans
>>
>> *From:*Ben Coman <[hidden email]>
>> *Sent:* maandag 9 april 2018 22:54
>> *To:* Any question about pharo is welcome
><[hidden email]>
>> *Subject:* Re: [Pharo-users] installation of packages on 6.1
>>
>> On 6 April 2018 at 00:02, Baveco, Hans <hans.baveco@
>wur.nl
>> <mailto:[hidden email]>> wrote:
>>
>>     Trying to install Territorial the installation got stuck on the
>>     installation of Roassal2 1.35, with error
>“LGitObjectNotInitialized”
>>
>>     Transcript says:
>>
>>     “Project: Roassal2 1.35
>>
>>     I got an error while cloning: There was an authentication error
>>     while trying to execute the operation: error authenticating:
>>     failed connecting agent.
>>
>>     This happens usually because you didn't provide a valid set of
>>     credentials.
>>
>>     You may fix this problem in different ways:
>>
>>     1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa
>>     in your command line.
>>
>>     2. adding your keys in settings (open settings browser search for
>>     "Use custom SSH keys" and
>>
>>     add your public and private keys).
>>
>>     3. using HTTPS instead SSH (Just use an url in the form
>>     HTTPS://etc.git). I will try to clone the HTTPS variant.”
>>
>>     I have encountered this several t
>imes before, for different
>>     packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest
>update:
>>     #60540])) and have no idea how to deal with this.
>>
>>     Any suggestions?
>>
>>     Hans
>>
>> On Windows you need to use option 2. World Menu > Settings > etc...
>>
>> cheers -ben
>>

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Peter Uhnák
The con is the “read-only”

They are _not_ read-only. If you want to push, they will use http auth for authentication. (Obviously you need an account for pushing, but that's given.)

Peter
Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Herby Vojčík
Yes, sorry, of course technically you can use https access to push as well, I just didn't use it for that purpose for long as I always use ssh for that and so only use of https was to read public repos without need for authorization.


On April 11, 2018 11:21:29 PM GMT+02:00, "Peter Uhnák" <[hidden email]> wrote:

>>
>> The con is the “read-only”
>>
>
>They are _not_ read-only. If you want to push, they will use http auth
>for
>authentication. (Obviously you need an account for pushing, but that's
>given.)
>
>Peter

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Herby Vojčík
But it's not easy, as you need username and password and that can be different for each URL. So ssh (with one key) is easier for write-access, IMO. Https is much easier for read(-only) access.

On April 11, 2018 11:25:55 PM GMT+02:00, [hidden email] wrote:

>Yes, sorry, of course technically you can use https access to push as
>well, I just didn't use it for that purpose for long as I always use
>ssh for that and so only use of https was to read public repos without
>need for authorization.
>
>
>On April 11, 2018 11:21:29 PM GMT+02:00, "Peter Uhnák"
><[hidden email]> wrote:
>>>
>>> The con is the “read-only”
>>>
>>
>>They are _not_ read-only. If you want to push, they will use http auth
>>for
>>authentication. (Obviously you need an account for pushing, but that's
>>given.)
>>
>>Peter

Reply | Threaded
Open this post in threaded view
|

Re: installation of packages on 6.1

Baveco, Hans
In reply to this post by Stephane Ducasse-3
Thanks for this explanation Stef,

Now looking forward to Guilles work - sounds like it will be a very helpful resource when starting to use Git!
Hans


-----Original Message-----
From: Stephane Ducasse <[hidden email]>
Sent: woensdag 11 april 2018 22:01
To: Any question about pharo is welcome <[hidden email]>
Subject: Re: [Pharo-users] installation of packages on 6.1

Hans

just a meta remark (I personally find the API of git quite terrible - In addition I do not really like the github UI it feels like these ugly google noUIDesigned "UI") now you should consider that more and more people find git cool and powerful. And as a matter of fact it is.
So you should consider that understanding and learning git is a way to look less obsolete in the future. And it has nothing to do with Pharo.
Except that Pharo is becoming less foreign for mamy people thank to this.
I worked super well with git and iceberg on projects managing my dev in a branch before it is ready to be incorporated.
So solid branches was what was really missing to monticello and before you use it you may have problems to really assess them but once you work with them you get the power they bring and the comfort.
Guille is working on a nice explanation of Git and central concept of branch and you may want to read (at least I will read it because Guille understand it super super well).

Stef


On Wed, Apr 11, 2018 at 11:23 AM, Herbert Vojčík <[hidden email]> wrote:

> No, it is possible to install them without github account.
>
> You need to set protocol to https:
>
>  Iceberg enableMetacelloIntegration: true; remoteTypeSelector: #httpsUrl.
>
> Herby
>
> Baveco, Hans wrote:
>>
>> Thanks Ben!
>>
>> I created a github account, installed git and git bash, created SSH
>> keys, added keys to my github account, and changed the settings in
>> Pharo to use these keys, and finally was able to install the packages I wanted to try.
>> (roassal2 still not installing though).
>>
>> Question remains, is this really the only way to get these packages
>> that live on github into the image? I had no plans to work with
>> git/github, but was now forced to spent quite some time on it....
>>
>> Cheers,
>>
>> Hans
>>
>> *From:*Ben Coman <[hidden email]>
>> *Sent:* maandag 9 april 2018 22:54
>> *To:* Any question about pharo is welcome
>> <[hidden email]>
>> *Subject:* Re: [Pharo-users] installation of packages on 6.1
>>
>> On 6 April 2018 at 00:02, Baveco, Hans <hans.baveco@
>
> wur.nl
>>
>> <mailto:[hidden email]>> wrote:
>>
>>     Trying to install Territorial the installation got stuck on the
>>     installation of Roassal2 1.35, with error “LGitObjectNotInitialized”
>>
>>     Transcript says:
>>
>>     “Project: Roassal2 1.35
>>
>>     I got an error while cloning: There was an authentication error
>>     while trying to execute the operation: error authenticating:
>>     failed connecting agent.
>>
>>     This happens usually because you didn't provide a valid set of
>>     credentials.
>>
>>     You may fix this problem in different ways:
>>
>>     1. adding your keys to ssh-agent, executing ssh-add ~/.ssh/id_rsa
>>     in your command line.
>>
>>     2. adding your keys in settings (open settings browser search for
>>     "Use custom SSH keys" and
>>
>>     add your public and private keys).
>>
>>     3. using HTTPS instead SSH (Just use an url in the form
>>     HTTPS://etc.git). I will try to clone the HTTPS variant.”
>>
>>     I have encountered this several t
>
> imes before, for different
>>
>>     packages (on windows 7, pharo 6.1 (Image: Pharo6.0 [Latest update:
>>     #60540])) and have no idea how to deal with this.
>>
>>     Any suggestions?
>>
>>     Hans
>>
>> On Windows you need to use option 2. World Menu > Settings > etc...
>>
>> cheers -ben
>>
>