Quantcast

pharo script doesn't work on paths that contain whitespaces

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

pharo script doesn't work on paths that contain whitespaces

Tomohiro Oda-2
Hello,

I found my Jenkins jobs with scripts like below fails to start headless pharo process these couple of nights.
---
wget --quiet -O - get.pharo.org/50+vm | bash
./pharo Pharo.image save Pharo5.0 --delete-old
---

The problem is in the last line of the downloaded pharo script;

LD_LIBRARY_PATH=$DIR/pharo-vm:$LD_LIBRARY_PATH $DIR/pharo-vm/pharo --nodisplay  "$@"

should be quoted lilke
LD_LIBRARY_PATH="$DIR/pharo-vm:$LD_LIBRARY_PATH" "$DIR/pharo-vm/pharo" --nodisplay  "$@"

It seems the script for Pharo6 also has the same issue.

Best Regards,
---
tomo

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: pharo script doesn't work on paths that contain whitespaces

Ben Coman
Thanks for the report Tomo.
cheers -ben

On Fri, Mar 17, 2017 at 10:22 AM, Tomohiro Oda <[hidden email]> wrote:
Hello,

I found my Jenkins jobs with scripts like below fails to start headless pharo process these couple of nights.
---
wget --quiet -O - get.pharo.org/50+vm | bash
./pharo Pharo.image save Pharo5.0 --delete-old
---

The problem is in the last line of the downloaded pharo script;

LD_LIBRARY_PATH=$DIR/pharo-vm:$LD_LIBRARY_PATH $DIR/pharo-vm/pharo --nodisplay  "$@"

should be quoted lilke
LD_LIBRARY_PATH="$DIR/pharo-vm:$LD_LIBRARY_PATH" "$DIR/pharo-vm/pharo" --nodisplay  "$@"

It seems the script for Pharo6 also has the same issue.

Best Regards,
---
tomo


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: pharo script doesn't work on paths that contain whitespaces

EstebanLM
ouch! 
I’m sorry :)
anyway I’m reverting that change because I’m transmitting that configuration to general script (by using osvm script). 

Esteban

On 17 Mar 2017, at 04:35, Ben Coman <[hidden email]> wrote:

Thanks for the report Tomo.
cheers -ben

On Fri, Mar 17, 2017 at 10:22 AM, Tomohiro Oda <[hidden email]> wrote:
Hello,

I found my Jenkins jobs with scripts like below fails to start headless pharo process these couple of nights.
---
wget --quiet -O - get.pharo.org/50+vm | bash
./pharo Pharo.image save Pharo5.0 --delete-old
---

The problem is in the last line of the downloaded pharo script;

LD_LIBRARY_PATH=$DIR/pharo-vm:$LD_LIBRARY_PATH $DIR/pharo-vm/pharo --nodisplay  "$@"

should be quoted lilke
LD_LIBRARY_PATH="$DIR/pharo-vm:$LD_LIBRARY_PATH" "$DIR/pharo-vm/pharo" --nodisplay  "$@"

It seems the script for Pharo6 also has the same issue.

Best Regards,
---
tomo



Loading...