Quantcast

"Transcript enableLoggingToGemLogFileForSession" not working anymore?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

"Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list
In reply to this post by GLASS mailing list

...oh and logging to the gem log file is enabled by default ...

also, if you use `startTopaz xxx -r` (remote login) the transcript output shows up in the gem log file ... be aware that gem log files are automatically deleted upon successful logout (log file is not deleted if there is an error exit) ... there are ways to arrange to keep all gem log files if needed ...

Dale

On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list
In reply to this post by GLASS mailing list


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass




--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...

Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list


On Fri, Feb 3, 2017 at 2:54 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...


OK, good spot. It was not that, but related. It seems that in the .topaz ini of the stone I was trying I had the 

topaz> set gemnetid !tcp@xxx#netldi:debrisDemo_333_ldi#task!gemnetobject

On another stone in which I DO NOT set above magic line, the same scripts receives a linked session (it honors -l).

So the problem is that if I define the above line in .topazini then the -l argument is completly ignored in `startTopaz`. This looks wrong to me. Of course, if I remove that line from .topazini it does work correctly.

Thoughts?


 
Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--



--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list

Looks like a feature of topaz. According to the help text for login:

   If the gemnetid is set to anything other than '' (null) or
         gcilinkobj, Topaz starts an RPC session instead of a linked one.

In general I don't think it really matters whether you are running linked or rpc, however, it is a bit surprising that the behavior of GsFile>>gciLogServer: is different ..

Other than that can you think of any other issue?

I'm not in the office today, but I'll see if I can find out if this is expected behavior ...

Dale

On 2/3/17 10:36 AM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 2:54 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...


OK, good spot. It was not that, but related. It seems that in the .topaz ini of the stone I was trying I had the 

topaz> set gemnetid !tcp@xxx#netldi:debrisDemo_333_ldi#task!gemnetobject

On another stone in which I DO NOT set above magic line, the same scripts receives a linked session (it honors -l).

So the problem is that if I define the above line in .topazini then the -l argument is completly ignored in `startTopaz`. This looks wrong to me. Of course, if I remove that line from .topazini it does work correctly.

Thoughts?


 
Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--
--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list


On Fri, Feb 3, 2017 at 8:44 PM, Dale Henrichs <[hidden email]> wrote:

Looks like a feature of topaz.


Probably there is a reason. But I don't like that behavior at all. I mean, I wanted to keep my netldi info in .topazini just in case I needed RPC in some case. But now I must remove that line because else the -l is ignored and so my logs disappear. 

I would prefer to let .topazini have whatever info and honor -l argument. 
 

According to the help text for login:

   If the gemnetid is set to anything other than '' (null) or
         gcilinkobj, Topaz starts an RPC session instead of a linked one.

In general I don't think it really matters whether you are running linked or rpc, however, it is a bit surprising that the behavior of GsFile>>gciLogServer: is different ..

Other than that can you think of any other issue?


I am not sure I understand your question. Now, for example, this issue [1] means that now all -l are ignored and so all logs are lost? 





 

I'm not in the office today, but I'll see if I can find out if this is expected behavior ...

Dale


On 2/3/17 10:36 AM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 2:54 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...


OK, good spot. It was not that, but related. It seems that in the .topaz ini of the stone I was trying I had the 

topaz> set gemnetid !tcp@xxx#netldi:debrisDemo_333_ldi#task!gemnetobject

On another stone in which I DO NOT set above magic line, the same scripts receives a linked session (it honors -l).

So the problem is that if I define the above line in .topazini then the -l argument is completly ignored in `startTopaz`. This looks wrong to me. Of course, if I remove that line from .topazini it does work correctly.

Thoughts?


 
Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--
--



--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list

Mariano,

I've submitted an internal feature request"46671  "add `-L` option to topaz to force a linked login" that when used will do a linked login whether or not there is a gemnetid in the .topazini file ... should be available in 3.4  ... until putting a gemnetid is not a good idea .... I'll have to fiddle with GsDevKit_home ... I think that I will change it to add the gemnetid, but leave it commented out ...

Dale


On 02/06/2017 06:22 PM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 8:44 PM, Dale Henrichs <[hidden email]> wrote:

Looks like a feature of topaz.


Probably there is a reason. But I don't like that behavior at all. I mean, I wanted to keep my netldi info in .topazini just in case I needed RPC in some case. But now I must remove that line because else the -l is ignored and so my logs disappear. 

I would prefer to let .topazini have whatever info and honor -l argument. 
 

According to the help text for login:

   If the gemnetid is set to anything other than '' (null) or
         gcilinkobj, Topaz starts an RPC session instead of a linked one.

In general I don't think it really matters whether you are running linked or rpc, however, it is a bit surprising that the behavior of GsFile>>gciLogServer: is different ..

Other than that can you think of any other issue?


I am not sure I understand your question. Now, for example, this issue [1] means that now all -l are ignored and so all logs are lost? 





 

I'm not in the office today, but I'll see if I can find out if this is expected behavior ...

Dale


On 2/3/17 10:36 AM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 2:54 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...


OK, good spot. It was not that, but related. It seems that in the .topaz ini of the stone I was trying I had the 

topaz> set gemnetid !tcp@xxx#netldi:debrisDemo_333_ldi#task!gemnetobject

On another stone in which I DO NOT set above magic line, the same scripts receives a linked session (it honors -l).

So the problem is that if I define the above line in .topazini then the -l argument is completly ignored in `startTopaz`. This looks wrong to me. Of course, if I remove that line from .topazini it does work correctly.

Thoughts?


 
Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--
--
--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Transcript enableLoggingToGemLogFileForSession" not working anymore?

GLASS mailing list


On Tue, Feb 7, 2017 at 1:13 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

I've submitted an internal feature request"46671  "add `-L` option to topaz to force a linked login" that when used will do a linked login whether or not there is a gemnetid in the .topazini file ... should be available in 3.4  ...


Cool, thanks!
 

until putting a gemnetid is not a good idea .... I'll have to fiddle with GsDevKit_home ... I think that I will change it to add the gemnetid, but leave it commented out ...


Yes, I think that makes sense...and while commenting that, you could also refer to 46671 as part of the comment and mentioning we may be able to uncomment this in 3.4.

 

Dale


On 02/06/2017 06:22 PM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 8:44 PM, Dale Henrichs <[hidden email]> wrote:

Looks like a feature of topaz.


Probably there is a reason. But I don't like that behavior at all. I mean, I wanted to keep my netldi info in .topazini just in case I needed RPC in some case. But now I must remove that line because else the -l is ignored and so my logs disappear. 

I would prefer to let .topazini have whatever info and honor -l argument. 
 

According to the help text for login:

   If the gemnetid is set to anything other than '' (null) or
         gcilinkobj, Topaz starts an RPC session instead of a linked one.

In general I don't think it really matters whether you are running linked or rpc, however, it is a bit surprising that the behavior of GsFile>>gciLogServer: is different ..

Other than that can you think of any other issue?


I am not sure I understand your question. Now, for example, this issue [1] means that now all -l are ignored and so all logs are lost? 





 

I'm not in the office today, but I'll see if I can find out if this is expected behavior ...

Dale


On 2/3/17 10:36 AM, Mariano Martinez Peck wrote:


On Fri, Feb 3, 2017 at 2:54 PM, Dale Henrichs <[hidden email]> wrote:

Mariano,

It works for me... output below ... When I look at tyour output, I see that you are doing an rpc login:

topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16

so you probably left the `-l` off of the command line .. in the rpc case the logfile is created and then deleted on successful logout ...


OK, good spot. It was not that, but related. It seems that in the .topaz ini of the stone I was trying I had the 

topaz> set gemnetid !tcp@xxx#netldi:debrisDemo_333_ldi#task!gemnetobject

On another stone in which I DO NOT set above magic line, the same scripts receives a linked session (it honors -l).

So the problem is that if I define the above line in .topazini then the -l argument is completly ignored in `startTopaz`. This looks wrong to me. Of course, if I remove that line from .topazini it does work correctly.

Thoughts?


 
Dale

----my topaz output ----

topaz> login
[Info]: LNK client/gem GCI levels = 33002/33002
--- 02/03/2017 09:49:51.862 PST Login
[Info]: libssl-3.3.3-64.so: loaded
[Info]: User ID: DataCurator
[Info]: Repository: gs_333
[Info]: Session ID: 4
[Info]: GCI Client Host: <Linked>
[Info]: Page server PID: -1
[Info]: libicudata.54.1.so: loaded
[Info]: libicuuc.54.1.so: loaded
[Info]: libicui18n.54.1.so: loaded
[Info]: Gave this process preference for OOM killer: wrote to /proc/24074/oom_score_adj value 250
[02/03/2017 09:49:51.880 PST]
  gci login: currSession 1  linked session
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 1> run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%
--transcript--'wtf'
TranscriptProxy
Logging out session 1.
--- 02/03/2017 09:49:51.894 PST Logging out
Error on or near line 64 :: startTopaz gs_333 -l :: startTopaz gs_333 -l
foos:bin>


On 2/2/17 10:32 AM, Mariano Martinez Peck wrote:


On Thu, Feb 2, 2017 at 1:25 PM, Dale Henrichs via Glass <[hidden email]> wrote:

Mariano,

When you run topaz the log file is written to stdout. In order to get a "log file" for a topaz session, you either capture stdout/stderr via output redirection or you can use the topaz `output` to route stdout/stderr to another file ... note that you have to supply the full path when using the `output` command.

I would recommend using output redirection when you want to create a log for topaz, because output redirection picks up the startup banner which includes a lot of useful information about the session...


OK, I understand that. But then, why below script:


#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF



Does not print 'wtf' in stdout ?  See the output:



topaz> login
[Info]: libssl-3.3.3-64.so: loaded
[02/02/2017 13:31:55.942 EST]
  gci login: currSession 2  rpc gem processId 13381 socket 6
successful login
 fileformat is now utf8
sourcestringclass is now Unicode16
topaz 2> run

Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.


%
TranscriptProxy
topaz 2>
topaz 2> commit
Successful commit
topaz 2> logout
topaz> exit
...finished :: startTopaz debrisDemo_333 -l
[quuve@quuveserver1 upgrade]$



 

Dale


On 2/2/17 5:49 AM, Mariano Martinez Peck via Glass wrote:
Hi Dale,

Remember some time ago we added #enableLoggingToGemLogFileForSession and related methods? 

I am trying this simple script on a 3.3.3 stone:

#!/bin/bash

$GS_HOME/bin/startTopaz $1 -l <<EOF

login
run
Transcript enableLoggingToGemLogFileForSession.
Transcript show: 'wtf'.
%

commit
logout
exit

EOF


And then on my stone logs directory:

[xx@xx logs]$ grep "wtf" *.log
[xx@xx logs]$


The string does gets written in the ObjectLog. But I want to gem file!

Thanks in advance, 



--


_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
_______________________________________________ Glass mailing list [hidden email] http://lists.gemtalksystems.com/mailman/listinfo/glass
--
--
--



--

_______________________________________________
Glass mailing list
[hidden email]
http://lists.gemtalksystems.com/mailman/listinfo/glass
Loading...