squeak: could not find any display driver

Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

squeak: could not find any display driver

stes

O.S. : Solaris 11.4 (for amd64 / x64 intel)

I'm trying the (old? 32bit) vm for Solaris from : http://squeakvm.org/unix/

The following works fine on Solaris 11.4 (installation as ordinary user, not
root) :

# Squeak-4.10.2.2614-solaris2.11_i386.sh -prefix=$HOME/squeak/
Installing Squeak-4.10.2.2614 for solaris2.11_i386

Then when trying to start the VM I get on this Solaris instance (which is a
virtual instance running on a virtualisation software KVM / ovirtengine
using VNC) :

# bin/squeak.sh unix-4.10.2.image
CHECKING cogvm
which: no cogvm in (/usr/bin:/bin)
CHECKING squeakvm
*squeak: could not find any display driver*
Abort (core dumped)

When I set the X DISPLAY to a remote X server it works, I mean :
bin/squeak.sh unix-4.10.2.image  in that case does not issue a "could not
find any display driver" and on the remote X server I can use the Squeak
4.10 environment (running on Solaris 11.4)

How can I see which display driver it is missing or trying to use ??




--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
tty
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

tty
Hi stes,

In my experience, the "Could not find the Display Driver" is displayed when
the problem is something entirely different. I recently wrangled with that
issue trying to get a 32 bit vm/image running on a 64 bit machine with 32
bit libs.

I do not recall what the fix was, just want to convey that the error message
may be misleading.

cheers.



--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

stes

I agree, the message is somewhat misleading the "Could not find the Display
Driver".

Because when setting DISPLAY to a X display and starting sqeak, it starts up
and seems to work
(I can browse the Smalltalk objects and so on...)

So the old unixvm is a possibility on Solaris 11.4 but it only gives a
Squeak 4.10.

Incidentially, maybe a beginner's question, but why is that squeakvm has a
4.10 image and changes file,
while squeak.org for the 4. series it stops on http://files.squeak.org/  at
4.6alpha  ... there is no 4.10 there.



--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
tty
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

tty
Hi stes.

I do not know why the 4.10 is missing, I would direct that question to squeak-dev as they maintain that sort of infrastructure.

What may be of help is that within the past 6 months somebody ported to BSD and it is on the message boards.
That thread may be of help to you.

I will say this...once you grok how to build the VM's it becomes routine. The porting work you are doing is much appreciated.

cheers,

tty


---- On Wed, 25 Mar 2020 05:06:46 -0400 stes <[hidden email]> wrote ----


I agree, the message is somewhat misleading the "Could not find the Display
Driver".

Because when setting DISPLAY to a X display and starting sqeak, it starts up
and seems to work
(I can browse the Smalltalk objects and so on...)

So the old unixvm is a possibility on Solaris 11.4 but it only gives a
Squeak 4.10.

Incidentially, maybe a beginner's question, but why is that squeakvm has a
4.10 image and changes file,
while squeak.org for the 4. series it stops on http://files.squeak.org/ at
4.6alpha ... there is no 4.10 there.



--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners



_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

stes

OK I'll check in squeak-dev  why files.squeak.org  has files up to 4.6alpha
and not 4.10 (which is on the squeakvm.org site).

I'm not saying I'm doing or will do any porting, I am just checking what is
available ...

The fact that the old unixvm from squeakvm.org  works  (on Solaris 11.4)  is
great, and is in fact sufficient for me.

It would be nice to have a 64bit VM of course, but currently the old 32bit
VM is sufficient for me.



--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

stes

For some reason, the "could not find any display driver" is not happening
with a recent V5 64 bit squeak VM.

I've created a package

# pkg list squeak5
NAME (PUBLISHER)                                  VERSION                  
IFO
runtime/squeak5 (squeak)                          5.0.0                    
i--

and when running squeak5 it launches just fine (using a 64 bit
Squeak5.3-19431-64bit.image).



--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners
Reply | Threaded
Open this post in threaded view
|

Re: squeak: could not find any display driver

stes
In reply to this post by stes

I've also built a squeak version 4.16.7 on Solaris:

   runtime/squeak4                                
4.16.7,5.11:20200331T091358Z

It turns out that this 4.16.7 version (unlike the one from squeakvm.org) is
not issueing a "could not find any display driver" either on virtual
oVirtEngine (KVM) machines.  Anyway this was not a big issue as with the
older sqeuakvm.org vm, it was possible to set the DISPLAY and launch it
anyway.

In any case with the Squeak image Squeak4.6-15102.image  it seems to work
perfectly fine (32 bit).

So both 32 bit (version 4) and 64 bit (version 5 images) work.





--
Sent from: http://forum.world.st/Smalltalk-VM-Beginners-f3068605.html
_______________________________________________
VM-beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/vm-beginners