Saving Code (not publishing): How?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Saving Code (not publishing): How?

Hunter-2
I'm not understanding how I should save\manage my code, given there is
no image.  The documentation states the following, but attempting this
only results in a 'There is no connection a database' error, which
sounds like it has more to do with publishing, which I'm far from
ready to commit to. Clearly I'm way off base here.

Saving Code

Saving your application in a repository (also called publishing) is
the preferred way to store your code. WebVelocity does not normally
save source code in files (though there is a way).

For the most part, you know when you need to save, or publish, your
code, because you’ve been editing it. As a visual reminder, the
Changes link on the WebVelocity Launcher page appears red when changes
have been made but not yet published.

To publish your code:

   1. Go to the WebVelocity Application Editor.
   2. Select Publish from the Actions menu.

In the Publish dialog, set the version number (1.0 is the default for
a first publish), and enter a brief comment to describe this version.
You can change the blessing level, though the default Development is
often used for code that's in-progress. When all options gave been
set, click OK.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Mark Roberts
On 3/2/2010 12:44 PM, Hunter wrote:
> I'm not understanding how I should save\manage my code, given there is
> no image.  The documentation states the following, but attempting this
> only results in a 'There is no connection a database' error, which
> sounds like it has more to do with publishing, which I'm far from
> ready to commit to. Clearly I'm way off base here.
>    

The idea in WebVelocity is that rather than saving your entire image as
a snapshot, and rather than saving your application code in files
(neither of which are under any form of source code control), you save
your code by publishing to the code repository. By default, WebVelocity
has a private, local repository that you can use, so there's no
'commitment' involved. You are not making your work public. The work
"publish" is a bit misleading in this context. It is meant to suggest
that regardless of whether you are saving a few changes in your local
repository, or making your entire application available in a public one,
the steps are pretty much the same.

The error message (which should probably read "There is no connection to
a database") suggests that WebVelocity is not finding the database. Have
you changed your connection profile? Also, what machine/OS/version/etc.
are you using?

M. Roberts
Cincom Systems, Inc.



--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Mark Roberts
In reply to this post by Hunter-2
Pardon, there's a typo in my last message: it should say "the word
'publish' ...".

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Geert Claes
Administrator
In reply to this post by Mark Roberts
M. Downing Roberts wrote
The idea in WebVelocity is that rather than saving your entire image as
a snapshot, and rather than saving your application code in files
(neither of which are under any form of source code control), you save
your code by publishing to the code repository. By default, WebVelocity
has a private, local repository that you can use, so there's no
'commitment' involved. You are not making your work public. The word
"publish" is a bit misleading in this context. It is meant to suggest
that regardless of whether you are saving a few changes in your local
repository, or making your entire application available in a public one,
the steps are pretty much the same.

The error message (which should probably read "There is no connection to
a database") suggests that WebVelocity is not finding the database. Have
you changed your connection profile? Also, what machine/OS/version/etc.
are you using?
Hi Robert, where can I find more info about this whole save, publish, repository and database concept?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Mark Roberts
Hi Geert,

> where can I find more info about this whole save, publish, repository and database concept?
>    

The WebVelocity documentation itself covers this. Have a look at the
topic: Documentation > Application Development > Managing Source Code

If any particular point seems unclear, just let us know and we can amend
the documentation.

Thanks,

M. Roberts
Cincom Systems, Inc.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
Mark -

I don't have my original text regarding 'Saving Code' where I provided
machine info etc that came in via AOL - sorry  - I won't use that
route in the future. To me it isn't so much a matter of where I am in
the UI, because I'll be wherever you want me to be. I'm just trying
'save' my code (methods, classes, etc), but get the 'There is no
connection to a database' error and the suggestions I've received so
far don't seem to foot to something I can do specifically. I've
createda PostgreSQL database, complete with data. Supposedly my
database configuration works, the 'test login' works. Then I generated
(map) just a few classes. I want to save this, and future work too. My
exact steps are: 'Open Browser', click on my loaded application
'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
receive 'There is no connection a database'.

This is really stressing me out. I'm a long time Smalltalker, but I
can't even get to the Smalltalk part of what I'd like to do.  I
thought Webvelocity would be the better route, but I'm wondering if
just native Squeak\Seaside would be easier???


On Mar 2, 5:34 pm, "Mark D. Roberts" <[hidden email]> wrote:

> Hi Geert,
>
> > where can I find more info about this whole save, publish, repository and database concept?
>
> The WebVelocity documentation itself covers this. Have a look at the
> topic: Documentation > Application Development > Managing Source Code
>
> If any particular point seems unclear, just let us know and we can amend
> the documentation.
>
> Thanks,
>
> M. Roberts
> Cincom Systems, Inc.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

jarober
What platform are you on?  If it's Windows, try putting the SqlLite dll's in the Windows\System32 directory


On Mar 29, 2010, at 12:05 AM, Hunter wrote:

> Mark -
>
> I don't have my original text regarding 'Saving Code' where I provided
> machine info etc that came in via AOL - sorry  - I won't use that
> route in the future. To me it isn't so much a matter of where I am in
> the UI, because I'll be wherever you want me to be. I'm just trying
> 'save' my code (methods, classes, etc), but get the 'There is no
> connection to a database' error and the suggestions I've received so
> far don't seem to foot to something I can do specifically. I've
> createda PostgreSQL database, complete with data. Supposedly my
> database configuration works, the 'test login' works. Then I generated
> (map) just a few classes. I want to save this, and future work too. My
> exact steps are: 'Open Browser', click on my loaded application
> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> receive 'There is no connection a database'.
>
> This is really stressing me out. I'm a long time Smalltalker, but I
> can't even get to the Smalltalk part of what I'd like to do.  I
> thought Webvelocity would be the better route, but I'm wondering if
> just native Squeak\Seaside would be easier???
>
>
> On Mar 2, 5:34 pm, "Mark D. Roberts" <[hidden email]> wrote:
>> Hi Geert,
>>
>>> where can I find more info about this whole save, publish, repository and database concept?
>>
>> The WebVelocity documentation itself covers this. Have a look at the
>> topic: Documentation > Application Development > Managing Source Code
>>
>> If any particular point seems unclear, just let us know and we can amend
>> the documentation.
>>
>> Thanks,
>>
>> M. Roberts
>> Cincom Systems, Inc.
>
> --
> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> To post to this group, send email to [hidden email].
> To unsubscribe from this group, send email to [hidden email].
> For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
>

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Mark Roberts
In reply to this post by Hunter-2
On 3/29/2010 1:05 PM, Hunter wrote:

> I'm just trying
> 'save' my code (methods, classes, etc), but get the 'There is no
> connection to a database' error and the suggestions I've received so
> far don't seem to foot to something I can do specifically. I've
> createda PostgreSQL database, complete with data. Supposedly my
> database configuration works, the 'test login' works. Then I generated
> (map) just a few classes. I want to save this, and future work too. My
> exact steps are: 'Open Browser', click on my loaded application
> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> receive 'There is no connection a database'.
>    

Maybe you've already checked this over, but just to make sure...

When you open the "Repositories" menu on the main page, what's selected?
"Personal"? When you select "edit" for the currently selected
repository, what are the connection settings in the "Edit Repository"
dialog?

In WebVelocity 1.0, the code for your application and its data are
stored in distinct databases. The application code that you publish goes
into a repository, and this is set using the "Repositories" menu on the
main page. By default, WebVelocity uses a SQLite database called
"Personal", and this should just be configured and ready to go when you
launch. That is, SQLite is bundled with WebVelocity and no manual
configuration is necessary, unless you want to save your code in a
different repository. If you changed this setting to a different
database, or the configuration is messed up somehow, then you may need
to change it back. You can also create new code repositories using the
"New" menu.

Your application data, on the other hand, goes into a separate database
that is configured from the "Database" menu in the Application Editor.
It sounds like you have that configured correctly for your application,
but perhaps somewhere along the line the repository that you have
selected for code storage got confused somehow.

So, I'd say double check that first.

Regards,

M. Roberts
Cincom Systems, Inc.


--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Alan Knight
On Mar 29, 1:26 am, "Mark D. Roberts" <[hidden email]> wrote:

> On 3/29/2010 1:05 PM, Hunter wrote:
>
> > I'm just trying
> > 'save' my code (methods, classes, etc), but get the 'There is no
> > connection to a database' error and the suggestions I've received so
> > far don't seem to foot to something I can do specifically. I've
> > createda PostgreSQL database, complete with data. Supposedly my
> > database configuration works, the 'test login' works. Then I generated
> > (map) just a few classes. I want to save this, and future work too. My
> > exact steps are: 'Open Browser', click on my loaded application
> > 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> > receive 'There is no connection a database'.
>
> Maybe you've already checked this over, but just to make sure...
>
> When you open the "Repositories" menu on the main page, what's selected?
> "Personal"? When you select "edit" for the currently selected
> repository, what are the connection settings in the "Edit Repository"
> dialog?
>
> In WebVelocity 1.0, the code for your application and its data are
> stored in distinct databases. The application code that you publish goes
> into a repository, and this is set using the "Repositories" menu on the
> main page. By default, WebVelocity uses a SQLite database called
> "Personal", and this should just be configured and ready to go when you
> launch. That is, SQLite is bundled with WebVelocity and no manual
> configuration is necessary, unless you want to save your code in a
> different repository. If you changed this setting to a different
> database, or the configuration is messed up somehow, then you may need
> to change it back. You can also create new code repositories using the
> "New" menu.
>
> Your application data, on the other hand, goes into a separate database
> that is configured from the "Database" menu in the Application Editor.
> It sounds like you have that configured correctly for your application,
> but perhaps somewhere along the line the repository that you have
> selected for code storage got confused somehow.
>
> So, I'd say double check that first.
>
> Regards,
>
> M. Roberts
> Cincom Systems, Inc.

I'll also mention that if you just want to save out parcels, that's
done by the "Deploy" option. So, the normal method for keeping track
of your code is to "publish" it in your own local sqlite database.
It's not really publishing in the sense that anyone else can see it,
that's just the terminology for committing to the source control
system. For deploying it, rather than save the image, you can save out
parcels which are then loaded automatically into the runtime image
when it starts up.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
In reply to this post by jarober
Still working on this issue. I suspect it is related to possibly not
finding sqlite.  When I attempt to publish,  the following error is
displayed:
‘There is no connection a database’
OS:
Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
1
Database Configuration:
Platform: PostgreSQL
Mappings: Schema1
Host: localhost
Port: 5432
Database: SICTEST
Schema: public
Username: postgres
Repository:
Name: Personal
Platform: SQLite 3
Database: personal.db

The only sqlite dll I could find was on my backup drive, so I copied
that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
to C:\Program Files (x86)\Common Files. I added this to the path  -
still no luck. Suggestions?


On Mar 28, 11:40 pm, James Robertson <[hidden email]> wrote:

> What platform are you on?  If it's Windows, try putting the SqlLite dll's in the Windows\System32 directory
>
> On Mar 29, 2010, at 12:05 AM, Hunter wrote:
>
>
>
> > Mark -
>
> > I don't have my original text regarding 'Saving Code' where I provided
> > machine info etc that came in via AOL - sorry  - I won't use that
> > route in the future. To me it isn't so much a matter of where I am in
> > the UI, because I'll be wherever you want me to be. I'm just trying
> > 'save' my code (methods, classes, etc), but get the 'There is no
> > connection to a database' error and the suggestions I've received so
> > far don't seem to foot to something I can do specifically. I've
> > createda PostgreSQL database, complete with data. Supposedly my
> > database configuration works, the 'test login' works. Then I generated
> > (map) just a few classes. I want to save this, and future work too. My
> > exact steps are: 'Open Browser', click on my loaded application
> > 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> > receive 'There is no connection a database'.
>
> > This is really stressing me out. I'm a long time Smalltalker, but I
> > can't even get to the Smalltalk part of what I'd like to do.  I
> > thought Webvelocity would be the better route, but I'm wondering if
> > just native Squeak\Seaside would be easier???
>
> > On Mar 2, 5:34 pm, "Mark D. Roberts" <[hidden email]> wrote:
> >> Hi Geert,
>
> >>> where can I find more info about this whole save, publish, repository and database concept?
>
> >> The WebVelocity documentation itself covers this. Have a look at the
> >> topic: Documentation > Application Development > Managing Source Code
>
> >> If any particular point seems unclear, just let us know and we can amend
> >> the documentation.
>
> >> Thanks,
>
> >> M. Roberts
> >> Cincom Systems, Inc.
>
> > --
> > You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to [hidden email].
> > For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
In reply to this post by Mark Roberts
Still working on this issue. I suspect it is related to possibly not
finding sqlite.  When I attempt to publish,  the following error is
displayed:
‘There is no connection a database’
OS:
Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
1
Database Configuration:
Platform: PostgreSQL
Mappings: Schema1
Host: localhost
Port: 5432
Database: SICTEST
Schema: public
Username: postgres
Repository:
Name: Personal
Platform: SQLite 3
Database: personal.db

The only sqlite dll I could find was on my backup drive, so I copied
that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
to C:\Program Files (x86)\Common Files. I added this to the path  -
still no luck. Suggestions?


On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:

> On 3/29/2010 1:05 PM, Hunter wrote:
>
> > I'm just trying
> > 'save' my code (methods, classes, etc), but get the 'There is no
> > connection to a database' error and the suggestions I've received so
> > far don't seem to foot to something I can do specifically. I've
> > createda PostgreSQL database, complete with data. Supposedly my
> > database configuration works, the 'test login' works. Then I generated
> > (map) just a few classes. I want to save this, and future work too. My
> > exact steps are: 'Open Browser', click on my loaded application
> > 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> > receive 'There is no connection a database'.
>
> Maybe you've already checked this over, but just to make sure...
>
> When you open the "Repositories" menu on the main page, what's selected?
> "Personal"? When you select "edit" for the currently selected
> repository, what are the connection settings in the "Edit Repository"
> dialog?
>
> In WebVelocity 1.0, the code for your application and its data are
> stored in distinct databases. The application code that you publish goes
> into a repository, and this is set using the "Repositories" menu on the
> main page. By default, WebVelocity uses a SQLite database called
> "Personal", and this should just be configured and ready to go when you
> launch. That is, SQLite is bundled with WebVelocity and no manual
> configuration is necessary, unless you want to save your code in a
> different repository. If you changed this setting to a different
> database, or the configuration is messed up somehow, then you may need
> to change it back. You can also create new code repositories using the
> "New" menu.
>
> Your application data, on the other hand, goes into a separate database
> that is configured from the "Database" menu in the Application Editor.
> It sounds like you have that configured correctly for your application,
> but perhaps somewhere along the line the repository that you have
> selected for code storage got confused somehow.
>
> So, I'd say double check that first.
>
> Regards,
>
> M. Roberts
> Cincom Systems, Inc.

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

jarober
try putting it into Windows\system32


On Apr 10, 2010, at 11:18 PM, Hunter wrote:

> Still working on this issue. I suspect it is related to possibly not
> finding sqlite.  When I attempt to publish,  the following error is
> displayed:
> ‘There is no connection a database’
> OS:
> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
> 1
> Database Configuration:
> Platform: PostgreSQL
> Mappings: Schema1
> Host: localhost
> Port: 5432
> Database: SICTEST
> Schema: public
> Username: postgres
> Repository:
> Name: Personal
> Platform: SQLite 3
> Database: personal.db
>
> The only sqlite dll I could find was on my backup drive, so I copied
> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> to C:\Program Files (x86)\Common Files. I added this to the path  -
> still no luck. Suggestions?
>
>
> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
>> On 3/29/2010 1:05 PM, Hunter wrote:
>>
>>> I'm just trying
>>> 'save' my code (methods, classes, etc), but get the 'There is no
>>> connection to a database' error and the suggestions I've received so
>>> far don't seem to foot to something I can do specifically. I've
>>> createda PostgreSQL database, complete with data. Supposedly my
>>> database configuration works, the 'test login' works. Then I generated
>>> (map) just a few classes. I want to save this, and future work too. My
>>> exact steps are: 'Open Browser', click on my loaded application
>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
>>> receive 'There is no connection a database'.
>>
>> Maybe you've already checked this over, but just to make sure...
>>
>> When you open the "Repositories" menu on the main page, what's selected?
>> "Personal"? When you select "edit" for the currently selected
>> repository, what are the connection settings in the "Edit Repository"
>> dialog?
>>
>> In WebVelocity 1.0, the code for your application and its data are
>> stored in distinct databases. The application code that you publish goes
>> into a repository, and this is set using the "Repositories" menu on the
>> main page. By default, WebVelocity uses a SQLite database called
>> "Personal", and this should just be configured and ready to go when you
>> launch. That is, SQLite is bundled with WebVelocity and no manual
>> configuration is necessary, unless you want to save your code in a
>> different repository. If you changed this setting to a different
>> database, or the configuration is messed up somehow, then you may need
>> to change it back. You can also create new code repositories using the
>> "New" menu.
>>
>> Your application data, on the other hand, goes into a separate database
>> that is configured from the "Database" menu in the Application Editor.
>> It sounds like you have that configured correctly for your application,
>> but perhaps somewhere along the line the repository that you have
>> selected for code storage got confused somehow.
>>
>> So, I'd say double check that first.
>>
>> Regards,
>>
>> M. Roberts
>> Cincom Systems, Inc.
>
> --
> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> To post to this group, send email to [hidden email].
> To unsubscribe from this group, send email to [hidden email].
> For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
>

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
Just tried that and shutdown Webvelocity, relaunched Webvelocity,
defined database, mapped some classes - tried to publish: same error.
Seems sqlite isn't installed properly. Is there a way to test that
independent of Webvelocity?

On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:

> try putting it into Windows\system32
>
> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
>
>
> > Still working on this issue. I suspect it is related to possibly not
> > finding sqlite.  When I attempt to publish,  the following error is
> > displayed:
> > ‘There is no connection a database’
> > OS:
> > Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
> > 1
> > Database Configuration:
> > Platform: PostgreSQL
> > Mappings: Schema1
> > Host: localhost
> > Port: 5432
> > Database: SICTEST
> > Schema: public
> > Username: postgres
> > Repository:
> > Name: Personal
> > Platform: SQLite 3
> > Database: personal.db
>
> > The only sqlite dll I could find was on my backup drive, so I copied
> > that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> > to C:\Program Files (x86)\Common Files. I added this to the path  -
> > still no luck. Suggestions?
>
> > On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
> >> On 3/29/2010 1:05 PM, Hunter wrote:
>
> >>> I'm just trying
> >>> 'save' my code (methods, classes, etc), but get the 'There is no
> >>> connection to a database' error and the suggestions I've received so
> >>> far don't seem to foot to something I can do specifically. I've
> >>> createda PostgreSQL database, complete with data. Supposedly my
> >>> database configuration works, the 'test login' works. Then I generated
> >>> (map) just a few classes. I want to save this, and future work too. My
> >>> exact steps are: 'Open Browser', click on my loaded application
> >>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> >>> receive 'There is no connection a database'.
>
> >> Maybe you've already checked this over, but just to make sure...
>
> >> When you open the "Repositories" menu on the main page, what's selected?
> >> "Personal"? When you select "edit" for the currently selected
> >> repository, what are the connection settings in the "Edit Repository"
> >> dialog?
>
> >> In WebVelocity 1.0, the code for your application and its data are
> >> stored in distinct databases. The application code that you publish goes
> >> into a repository, and this is set using the "Repositories" menu on the
> >> main page. By default, WebVelocity uses a SQLite database called
> >> "Personal", and this should just be configured and ready to go when you
> >> launch. That is, SQLite is bundled with WebVelocity and no manual
> >> configuration is necessary, unless you want to save your code in a
> >> different repository. If you changed this setting to a different
> >> database, or the configuration is messed up somehow, then you may need
> >> to change it back. You can also create new code repositories using the
> >> "New" menu.
>
> >> Your application data, on the other hand, goes into a separate database
> >> that is configured from the "Database" menu in the Application Editor.
> >> It sounds like you have that configured correctly for your application,
> >> but perhaps somewhere along the line the repository that you have
> >> selected for code storage got confused somehow.
>
> >> So, I'd say double check that first.
>
> >> Regards,
>
> >> M. Roberts
> >> Cincom Systems, Inc.
>
> > --
> > You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to [hidden email].
> > For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

jarober
well, you could fire up vwnc, and load the SQLlite driver, and see if it works

On Apr 11, 2010, at 10:51 AM, Hunter wrote:

> Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> defined database, mapped some classes - tried to publish: same error.
> Seems sqlite isn't installed properly. Is there a way to test that
> independent of Webvelocity?
>
> On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
>> try putting it into Windows\system32
>>
>> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>>
>>
>>
>>> Still working on this issue. I suspect it is related to possibly not
>>> finding sqlite.  When I attempt to publish,  the following error is
>>> displayed:
>>> ‘There is no connection a database’
>>> OS:
>>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
>>> 1
>>> Database Configuration:
>>> Platform: PostgreSQL
>>> Mappings: Schema1
>>> Host: localhost
>>> Port: 5432
>>> Database: SICTEST
>>> Schema: public
>>> Username: postgres
>>> Repository:
>>> Name: Personal
>>> Platform: SQLite 3
>>> Database: personal.db
>>
>>> The only sqlite dll I could find was on my backup drive, so I copied
>>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
>>> to C:\Program Files (x86)\Common Files. I added this to the path  -
>>> still no luck. Suggestions?
>>
>>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
>>>> On 3/29/2010 1:05 PM, Hunter wrote:
>>
>>>>> I'm just trying
>>>>> 'save' my code (methods, classes, etc), but get the 'There is no
>>>>> connection to a database' error and the suggestions I've received so
>>>>> far don't seem to foot to something I can do specifically. I've
>>>>> createda PostgreSQL database, complete with data. Supposedly my
>>>>> database configuration works, the 'test login' works. Then I generated
>>>>> (map) just a few classes. I want to save this, and future work too. My
>>>>> exact steps are: 'Open Browser', click on my loaded application
>>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
>>>>> receive 'There is no connection a database'.
>>
>>>> Maybe you've already checked this over, but just to make sure...
>>
>>>> When you open the "Repositories" menu on the main page, what's selected?
>>>> "Personal"? When you select "edit" for the currently selected
>>>> repository, what are the connection settings in the "Edit Repository"
>>>> dialog?
>>
>>>> In WebVelocity 1.0, the code for your application and its data are
>>>> stored in distinct databases. The application code that you publish goes
>>>> into a repository, and this is set using the "Repositories" menu on the
>>>> main page. By default, WebVelocity uses a SQLite database called
>>>> "Personal", and this should just be configured and ready to go when you
>>>> launch. That is, SQLite is bundled with WebVelocity and no manual
>>>> configuration is necessary, unless you want to save your code in a
>>>> different repository. If you changed this setting to a different
>>>> database, or the configuration is messed up somehow, then you may need
>>>> to change it back. You can also create new code repositories using the
>>>> "New" menu.
>>
>>>> Your application data, on the other hand, goes into a separate database
>>>> that is configured from the "Database" menu in the Application Editor.
>>>> It sounds like you have that configured correctly for your application,
>>>> but perhaps somewhere along the line the repository that you have
>>>> selected for code storage got confused somehow.
>>
>>>> So, I'd say double check that first.
>>
>>>> Regards,
>>
>>>> M. Roberts
>>>> Cincom Systems, Inc.
>>
>>> --
>>> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
>>> To post to this group, send email to [hidden email].
>>> To unsubscribe from this group, send email to [hidden email].
>>> For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>>
>> - Show quoted text -
>
> --
> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> To post to this group, send email to [hidden email].
> To unsubscribe from this group, send email to [hidden email].
> For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
>

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
VWNC? VisualWorks ...?

On Apr 11, 10:38 am, James Robertson <[hidden email]> wrote:

> well, you could fire up vwnc, and load the SQLlite driver, and see if it works
>
> On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>
>
>
> > Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> > defined database, mapped some classes - tried to publish: same error.
> > Seems sqlite isn't installed properly. Is there a way to test that
> > independent of Webvelocity?
>
> > On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
> >> try putting it into Windows\system32
>
> >> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
> >>> Still working on this issue. I suspect it is related to possibly not
> >>> finding sqlite.  When I attempt to publish,  the following error is
> >>> displayed:
> >>> ‘There is no connection a database’
> >>> OS:
> >>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
> >>> 1
> >>> Database Configuration:
> >>> Platform: PostgreSQL
> >>> Mappings: Schema1
> >>> Host: localhost
> >>> Port: 5432
> >>> Database: SICTEST
> >>> Schema: public
> >>> Username: postgres
> >>> Repository:
> >>> Name: Personal
> >>> Platform: SQLite 3
> >>> Database: personal.db
>
> >>> The only sqlite dll I could find was on my backup drive, so I copied
> >>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> >>> to C:\Program Files (x86)\Common Files. I added this to the path  -
> >>> still no luck. Suggestions?
>
> >>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
> >>>> On 3/29/2010 1:05 PM, Hunter wrote:
>
> >>>>> I'm just trying
> >>>>> 'save' my code (methods, classes, etc), but get the 'There is no
> >>>>> connection to a database' error and the suggestions I've received so
> >>>>> far don't seem to foot to something I can do specifically. I've
> >>>>> createda PostgreSQL database, complete with data. Supposedly my
> >>>>> database configuration works, the 'test login' works. Then I generated
> >>>>> (map) just a few classes. I want to save this, and future work too. My
> >>>>> exact steps are: 'Open Browser', click on my loaded application
> >>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> >>>>> receive 'There is no connection a database'.
>
> >>>> Maybe you've already checked this over, but just to make sure...
>
> >>>> When you open the "Repositories" menu on the main page, what's selected?
> >>>> "Personal"? When you select "edit" for the currently selected
> >>>> repository, what are the connection settings in the "Edit Repository"
> >>>> dialog?
>
> >>>> In WebVelocity 1.0, the code for your application and its data are
> >>>> stored in distinct databases. The application code that you publish goes
> >>>> into a repository, and this is set using the "Repositories" menu on the
> >>>> main page. By default, WebVelocity uses a SQLite database called
> >>>> "Personal", and this should just be configured and ready to go when you
> >>>> launch. That is, SQLite is bundled with WebVelocity and no manual
> >>>> configuration is necessary, unless you want to save your code in a
> >>>> different repository. If you changed this setting to a different
> >>>> database, or the configuration is messed up somehow, then you may need
> >>>> to change it back. You can also create new code repositories using the
> >>>> "New" menu.
>
> >>>> Your application data, on the other hand, goes into a separate database
> >>>> that is configured from the "Database" menu in the Application Editor.
> >>>> It sounds like you have that configured correctly for your application,
> >>>> but perhaps somewhere along the line the repository that you have
> >>>> selected for code storage got confused somehow.
>
> >>>> So, I'd say double check that first.
>
> >>>> Regards,
>
> >>>> M. Roberts
> >>>> Cincom Systems, Inc.
>
> >>> --
> >>> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> >>> To post to this group, send email to [hidden email].
> >>> To unsubscribe from this group, send email to [hidden email].
> >>> For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>
> >> - Show quoted text -
>
> > --
> > You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to [hidden email].
> > For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Mark Roberts
On 4/12/2010 3:37 AM, Hunter wrote:
> VWNC? VisualWorks ...?
>    
VWNC = VisualWorks Non-Commercial

http://www.cincomsmalltalk.com/userblogs/cincom/smalltalk.ssp

M

> On Apr 11, 10:38 am, James Robertson<[hidden email]>  wrote:
>    
>> well, you could fire up vwnc, and load the SQLlite driver, and see if it works
>>
>> On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>>
>>
>>
>>      
>>> Just tried that and shutdown Webvelocity, relaunched Webvelocity,
>>> defined database, mapped some classes - tried to publish: same error.
>>> Seems sqlite isn't installed properly. Is there a way to test that
>>> independent of Webvelocity?
>>>        
>>      
>>> On Apr 11, 1:10 am, James Robertson<[hidden email]>  wrote:
>>>        
>>>> try putting it into Windows\system32
>>>>          
>>      
>>>> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>>>>          
>>      
>>>>> Still working on this issue. I suspect it is related to possibly not
>>>>> finding sqlite.  When I attempt to publish,  the following error is
>>>>> displayed:
>>>>> ‘There is no connection a database’
>>>>> OS:
>>>>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
>>>>> 1
>>>>> Database Configuration:
>>>>> Platform: PostgreSQL
>>>>> Mappings: Schema1
>>>>> Host: localhost
>>>>> Port: 5432
>>>>> Database: SICTEST
>>>>> Schema: public
>>>>> Username: postgres
>>>>> Repository:
>>>>> Name: Personal
>>>>> Platform: SQLite 3
>>>>> Database: personal.db
>>>>>            
>>      
>>>>> The only sqlite dll I could find was on my backup drive, so I copied
>>>>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
>>>>> to C:\Program Files (x86)\Common Files. I added this to the path  -
>>>>> still no luck. Suggestions?
>>>>>            
>>      
>>>>> On Mar 29, 12:26 am, "Mark D. Roberts"<[hidden email]>  wrote:
>>>>>            
>>>>>> On 3/29/2010 1:05 PM, Hunter wrote:
>>>>>>              
>>      
>>>>>>> I'm just trying
>>>>>>> 'save' my code (methods, classes, etc), but get the 'There is no
>>>>>>> connection to a database' error and the suggestions I've received so
>>>>>>> far don't seem to foot to something I can do specifically. I've
>>>>>>> createda PostgreSQL database, complete with data. Supposedly my
>>>>>>> database configuration works, the 'test login' works. Then I generated
>>>>>>> (map) just a few classes. I want to save this, and future work too. My
>>>>>>> exact steps are: 'Open Browser', click on my loaded application
>>>>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
>>>>>>> receive 'There is no connection a database'.
>>>>>>>                
>>      
>>>>>> Maybe you've already checked this over, but just to make sure...
>>>>>>              
>>      
>>>>>> When you open the "Repositories" menu on the main page, what's selected?
>>>>>> "Personal"? When you select "edit" for the currently selected
>>>>>> repository, what are the connection settings in the "Edit Repository"
>>>>>> dialog?
>>>>>>              
>>      
>>>>>> In WebVelocity 1.0, the code for your application and its data are
>>>>>> stored in distinct databases. The application code that you publish goes
>>>>>> into a repository, and this is set using the "Repositories" menu on the
>>>>>> main page. By default, WebVelocity uses a SQLite database called
>>>>>> "Personal", and this should just be configured and ready to go when you
>>>>>> launch. That is, SQLite is bundled with WebVelocity and no manual
>>>>>> configuration is necessary, unless you want to save your code in a
>>>>>> different repository. If you changed this setting to a different
>>>>>> database, or the configuration is messed up somehow, then you may need
>>>>>> to change it back. You can also create new code repositories using the
>>>>>> "New" menu.
>>>>>>              
>>      
>>>>>> Your application data, on the other hand, goes into a separate database
>>>>>> that is configured from the "Database" menu in the Application Editor.
>>>>>> It sounds like you have that configured correctly for your application,
>>>>>> but perhaps somewhere along the line the repository that you have
>>>>>> selected for code storage got confused somehow.
>>>>>>              
>>      
>>>>>> So, I'd say double check that first.
>>>>>>              
>>      
>>>>>> Regards,
>>>>>>              
>>      
>>>>>> M. Roberts
>>>>>> Cincom Systems, Inc.
>>>>>>              
>>      
>>>>> --
>>>>> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
>>>>> To post to this group, send email to [hidden email].
>>>>> To unsubscribe from this group, send email to [hidden email].
>>>>> For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>>>>>            
>>      
>>>> - Show quoted text -
>>>>          
>>      
>>> --
>>> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
>>> To post to this group, send email to [hidden email].
>>> To unsubscribe from this group, send email to [hidden email].
>>> For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>>>        
>> - Show quoted text -
>>      
>    

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

John McKeon
In reply to this post by Hunter-2
This is a shot in the dark but...
Did you try putting the dll in the Windows directory (instead of system32)? The SQLite3Interface class def points to that directory and then the system32 directory so that might work.

I think you run into issues where 64 bit windows redirects references to system32 to the SysWOW64 directory that can cause problems.

John


On Sun, Apr 11, 2010 at 2:37 PM, Hunter <[hidden email]> wrote:
VWNC? VisualWorks ...?

On Apr 11, 10:38 am, James Robertson <[hidden email]> wrote:
> well, you could fire up vwnc, and load the SQLlite driver, and see if it works
>
> On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>
>
>
> > Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> > defined database, mapped some classes - tried to publish: same error.
> > Seems sqlite isn't installed properly. Is there a way to test that
> > independent of Webvelocity?
>
> > On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
> >> try putting it into Windows\system32
>
> >> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
> >>> Still working on this issue. I suspect it is related to possibly not
> >>> finding sqlite.  When I attempt to publish,  the following error is
> >>> displayed:
> >>> ‘There is no connection a database’
> >>> OS:
> >>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service Pack
> >>> 1
> >>> Database Configuration:
> >>> Platform: PostgreSQL
> >>> Mappings: Schema1
> >>> Host: localhost
> >>> Port: 5432
> >>> Database: SICTEST
> >>> Schema: public
> >>> Username: postgres
> >>> Repository:
> >>> Name: Personal
> >>> Platform: SQLite 3
> >>> Database: personal.db
>
> >>> The only sqlite dll I could find was on my backup drive, so I copied
> >>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> >>> to C:\Program Files (x86)\Common Files. I added this to the path  -
> >>> still no luck. Suggestions?
>
> >>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
> >>>> On 3/29/2010 1:05 PM, Hunter wrote:
>
> >>>>> I'm just trying
> >>>>> 'save' my code (methods, classes, etc), but get the 'There is no
> >>>>> connection to a database' error and the suggestions I've received so
> >>>>> far don't seem to foot to something I can do specifically. I've
> >>>>> createda PostgreSQL database, complete with data. Supposedly my
> >>>>> database configuration works, the 'test login' works. Then I generated
> >>>>> (map) just a few classes. I want to save this, and future work too. My
> >>>>> exact steps are: 'Open Browser', click on my loaded application
> >>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form this I
> >>>>> receive 'There is no connection a database'.
>
> >>>> Maybe you've already checked this over, but just to make sure...
>
> >>>> When you open the "Repositories" menu on the main page, what's selected?
> >>>> "Personal"? When you select "edit" for the currently selected
> >>>> repository, what are the connection settings in the "Edit Repository"
> >>>> dialog?
>
> >>>> In WebVelocity 1.0, the code for your application and its data are
> >>>> stored in distinct databases. The application code that you publish goes
> >>>> into a repository, and this is set using the "Repositories" menu on the
> >>>> main page. By default, WebVelocity uses a SQLite database called
> >>>> "Personal", and this should just be configured and ready to go when you
> >>>> launch. That is, SQLite is bundled with WebVelocity and no manual
> >>>> configuration is necessary, unless you want to save your code in a
> >>>> different repository. If you changed this setting to a different
> >>>> database, or the configuration is messed up somehow, then you may need
> >>>> to change it back. You can also create new code repositories using the
> >>>> "New" menu.
>
> >>>> Your application data, on the other hand, goes into a separate database
> >>>> that is configured from the "Database" menu in the Application Editor.
> >>>> It sounds like you have that configured correctly for your application,
> >>>> but perhaps somewhere along the line the repository that you have
> >>>> selected for code storage got confused somehow.
>
> >>>> So, I'd say double check that first.
>
> >>>> Regards,
>
> >>>> M. Roberts
> >>>> Cincom Systems, Inc.
>
> >>> --
> >>> You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> >>> To post to this group, send email to [hidden email].
> >>> To unsubscribe from this group, send email to [hidden email].
> >>> For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>
> >> - Show quoted text -
>
> > --
> > You received this message because you are subscribed to the Google Groups "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to [hidden email].
> > For more options, visit this group athttp://groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.




--
http://jmck.seasidehosting.st

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
I moved sqlite3.dll to the C:\Windows directory. Same results.  Where
does sqlite come from anyway? Is it available by default or did
installing WebVelocity also install sqlite? If so, maybe I need ot
reinstall WebVelocity.  Although the message ‘There is no connection a
database’ really isn't very insightful to me - so maybe this has
nothing to do with sqlite.


On Apr 11, 7:11 pm, John McKeon <[hidden email]> wrote:

> This is a shot in the dark but...
> Did you try putting the dll in the Windows directory (instead of system32)?
> The SQLite3Interface class def points to that directory and then the
> system32 directory so that might work.
>
> I think you run into issues where 64 bit windows redirects references to
> system32 to the SysWOW64 directory that can cause problems.
>
> John
>
>
>
>
>
> On Sun, Apr 11, 2010 at 2:37 PM, Hunter <[hidden email]> wrote:
> > VWNC? VisualWorks ...?
>
> > On Apr 11, 10:38 am, James Robertson <[hidden email]> wrote:
> > > well, you could fire up vwnc, and load the SQLlite driver, and see if it
> > works
>
> > > On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>
> > > > Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> > > > defined database, mapped some classes - tried to publish: same error.
> > > > Seems sqlite isn't installed properly. Is there a way to test that
> > > > independent of Webvelocity?
>
> > > > On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
> > > >> try putting it into Windows\system32
>
> > > >> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
> > > >>> Still working on this issue. I suspect it is related to possibly not
> > > >>> finding sqlite.  When I attempt to publish,  the following error is
> > > >>> displayed:
> > > >>> ‘There is no connection a database’
> > > >>> OS:
> > > >>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service
> > Pack
> > > >>> 1
> > > >>> Database Configuration:
> > > >>> Platform: PostgreSQL
> > > >>> Mappings: Schema1
> > > >>> Host: localhost
> > > >>> Port: 5432
> > > >>> Database: SICTEST
> > > >>> Schema: public
> > > >>> Username: postgres
> > > >>> Repository:
> > > >>> Name: Personal
> > > >>> Platform: SQLite 3
> > > >>> Database: personal.db
>
> > > >>> The only sqlite dll I could find was on my backup drive, so I copied
> > > >>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> > > >>> to C:\Program Files (x86)\Common Files. I added this to the path  -
> > > >>> still no luck. Suggestions?
>
> > > >>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
> > > >>>> On 3/29/2010 1:05 PM, Hunter wrote:
>
> > > >>>>> I'm just trying
> > > >>>>> 'save' my code (methods, classes, etc), but get the 'There is no
> > > >>>>> connection to a database' error and the suggestions I've received
> > so
> > > >>>>> far don't seem to foot to something I can do specifically. I've
> > > >>>>> createda PostgreSQL database, complete with data. Supposedly my
> > > >>>>> database configuration works, the 'test login' works. Then I
> > generated
> > > >>>>> (map) just a few classes. I want to save this, and future work too.
> > My
> > > >>>>> exact steps are: 'Open Browser', click on my loaded application
> > > >>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form
> > this I
> > > >>>>> receive 'There is no connection a database'.
>
> > > >>>> Maybe you've already checked this over, but just to make sure...
>
> > > >>>> When you open the "Repositories" menu on the main page, what's
> > selected?
> > > >>>> "Personal"? When you select "edit" for the currently selected
> > > >>>> repository, what are the connection settings in the "Edit
> > Repository"
> > > >>>> dialog?
>
> > > >>>> In WebVelocity 1.0, the code for your application and its data are
> > > >>>> stored in distinct databases. The application code that you publish
> > goes
> > > >>>> into a repository, and this is set using the "Repositories" menu on
> > the
> > > >>>> main page. By default, WebVelocity uses a SQLite database called
> > > >>>> "Personal", and this should just be configured and ready to go when
> > you
> > > >>>> launch. That is, SQLite is bundled with WebVelocity and no manual
> > > >>>> configuration is necessary, unless you want to save your code in a
> > > >>>> different repository. If you changed this setting to a different
> > > >>>> database, or the configuration is messed up somehow, then you may
> > need
> > > >>>> to change it back. You can also create new code repositories using
> > the
> > > >>>> "New" menu.
>
> > > >>>> Your application data, on the other hand, goes into a separate
> > database
> > > >>>> that is configured from the "Database" menu in the Application
> > Editor.
> > > >>>> It sounds like you have that configured correctly for your
> > application,
> > > >>>> but perhaps somewhere along the line the repository that you have
> > > >>>> selected for code storage got confused somehow.
>
> > > >>>> So, I'd say double check that first.
>
> > > >>>> Regards,
>
> > > >>>> M. Roberts
> > > >>>> Cincom Systems, Inc.
>
> > > >>> --
> > > >>> You received this message because you are subscribed to the Google
> > Groups "WebVelocity" group.
> > > >>> To post to this group, send email to [hidden email].
> > > >>> To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > > >>> For more options, visit this group athttp://
> > groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>
> > > >> - Show quoted text -
>
> > > > --
> > > > You received this message because you are subscribed to the Google
> > Groups "WebVelocity" group.
> > > > To post to this group, send email to [hidden email].
> > > > To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > > > For more options, visit this group athttp://
> > groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> > > - Show quoted text -
>
> > --
> > You received this message because you are subscribed to the Google Groups
> > "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > For more options, visit this group at
> >http://groups.google.com/group/webvelocity?hl=en.
>
> --http://jmck.seasidehosting.st- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

John McKeon

On Sun, Apr 11, 2010 at 11:39 PM, Hunter <[hidden email]> wrote:
I moved sqlite3.dll to the C:\Windows directory. Same results.  Where
does sqlite come from anyway? Is it available by default or did
installing WebVelocity also install sqlite? If so, maybe I need ot
reinstall WebVelocity.

It should get installed with Webvelocity at the very least, in the WebVelocity subdirectory. Though I can rename the one in the system32 directory and get the same problem you report.
Have you tried putting the dll in the SysWOW64 directory?
If all else fails (and it appears to have), make a PostgreSql repository. Just create a DB with the admin tool, then use the New>Repository menu to connect to it.
 
 Although the message ‘There is no connection a
database’ really isn't very insightful to me - so maybe this has
nothing to do with sqlite.


On Apr 11, 7:11 pm, John McKeon <[hidden email]> wrote:
> This is a shot in the dark but...
> Did you try putting the dll in the Windows directory (instead of system32)?
> The SQLite3Interface class def points to that directory and then the
> system32 directory so that might work.
>
> I think you run into issues where 64 bit windows redirects references to
> system32 to the SysWOW64 directory that can cause problems.
>
> John
>
>
>
>
>
> On Sun, Apr 11, 2010 at 2:37 PM, Hunter <[hidden email]> wrote:
> > VWNC? VisualWorks ...?
>
> > On Apr 11, 10:38 am, James Robertson <[hidden email]> wrote:
> > > well, you could fire up vwnc, and load the SQLlite driver, and see if it
> > works
>
> > > On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>
> > > > Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> > > > defined database, mapped some classes - tried to publish: same error.
> > > > Seems sqlite isn't installed properly. Is there a way to test that
> > > > independent of Webvelocity?
>
> > > > On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
> > > >> try putting it into Windows\system32
>
> > > >> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
> > > >>> Still working on this issue. I suspect it is related to possibly not
> > > >>> finding sqlite.  When I attempt to publish,  the following error is
> > > >>> displayed:
> > > >>> ‘There is no connection a database’
> > > >>> OS:
> > > >>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service
> > Pack
> > > >>> 1
> > > >>> Database Configuration:
> > > >>> Platform: PostgreSQL
> > > >>> Mappings: Schema1
> > > >>> Host: localhost
> > > >>> Port: 5432
> > > >>> Database: SICTEST
> > > >>> Schema: public
> > > >>> Username: postgres
> > > >>> Repository:
> > > >>> Name: Personal
> > > >>> Platform: SQLite 3
> > > >>> Database: personal.db
>
> > > >>> The only sqlite dll I could find was on my backup drive, so I copied
> > > >>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00 AM )
> > > >>> to C:\Program Files (x86)\Common Files. I added this to the path  -
> > > >>> still no luck. Suggestions?
>
> > > >>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]> wrote:
> > > >>>> On 3/29/2010 1:05 PM, Hunter wrote:
>
> > > >>>>> I'm just trying
> > > >>>>> 'save' my code (methods, classes, etc), but get the 'There is no
> > > >>>>> connection to a database' error and the suggestions I've received
> > so
> > > >>>>> far don't seem to foot to something I can do specifically. I've
> > > >>>>> createda PostgreSQL database, complete with data. Supposedly my
> > > >>>>> database configuration works, the 'test login' works. Then I
> > generated
> > > >>>>> (map) just a few classes. I want to save this, and future work too.
> > My
> > > >>>>> exact steps are: 'Open Browser', click on my loaded application
> > > >>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form
> > this I
> > > >>>>> receive 'There is no connection a database'.
>
> > > >>>> Maybe you've already checked this over, but just to make sure...
>
> > > >>>> When you open the "Repositories" menu on the main page, what's
> > selected?
> > > >>>> "Personal"? When you select "edit" for the currently selected
> > > >>>> repository, what are the connection settings in the "Edit
> > Repository"
> > > >>>> dialog?
>
> > > >>>> In WebVelocity 1.0, the code for your application and its data are
> > > >>>> stored in distinct databases. The application code that you publish
> > goes
> > > >>>> into a repository, and this is set using the "Repositories" menu on
> > the
> > > >>>> main page. By default, WebVelocity uses a SQLite database called
> > > >>>> "Personal", and this should just be configured and ready to go when
> > you
> > > >>>> launch. That is, SQLite is bundled with WebVelocity and no manual
> > > >>>> configuration is necessary, unless you want to save your code in a
> > > >>>> different repository. If you changed this setting to a different
> > > >>>> database, or the configuration is messed up somehow, then you may
> > need
> > > >>>> to change it back. You can also create new code repositories using
> > the
> > > >>>> "New" menu.
>
> > > >>>> Your application data, on the other hand, goes into a separate
> > database
> > > >>>> that is configured from the "Database" menu in the Application
> > Editor.
> > > >>>> It sounds like you have that configured correctly for your
> > application,
> > > >>>> but perhaps somewhere along the line the repository that you have
> > > >>>> selected for code storage got confused somehow.
>
> > > >>>> So, I'd say double check that first.
>
> > > >>>> Regards,
>
> > > >>>> M. Roberts
> > > >>>> Cincom Systems, Inc.
>
> > > >>> --
> > > >>> You received this message because you are subscribed to the Google
> > Groups "WebVelocity" group.
> > > >>> To post to this group, send email to [hidden email].
> > > >>> To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > > >>> For more options, visit this group athttp://
> > groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>
> > > >> - Show quoted text -
>
> > > > --
> > > > You received this message because you are subscribed to the Google
> > Groups "WebVelocity" group.
> > > > To post to this group, send email to [hidden email].
> > > > To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > > > For more options, visit this group athttp://
> > groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> > > - Show quoted text -
>
> > --
> > You received this message because you are subscribed to the Google Groups
> > "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > For more options, visit this group at
> >http://groups.google.com/group/webvelocity?hl=en.
>
> --http://jmck.seasidehosting.st- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.




--
http://jmck.seasidehosting.st

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saving Code (not publishing): How?

Hunter-2
Ok, I've tried placing sqlite3.dll in SysWOW64. Same results. There
must be something about Vista and pathing that I'm not getting. So I
took your suggestion to go away from the defaul sqlite and use a
Postgresql database as a respository (I thought this might be less
desireable and also didn't want whatever was causing the sqlite issue
to cause other issues down the line if I didn't solve it). It works! I
can actually start working in Smalltalk! Thank you! Thank you!

On Apr 11, 11:13 pm, John McKeon <[hidden email]> wrote:

> On Sun, Apr 11, 2010 at 11:39 PM, Hunter <[hidden email]> wrote:
> > I moved sqlite3.dll to the C:\Windows directory. Same results.  Where
> > does sqlite come from anyway? Is it available by default or did
> > installing WebVelocity also install sqlite? If so, maybe I need ot
> > reinstall WebVelocity.
>
> It should get installed with Webvelocity at the very least, in the
> WebVelocity subdirectory. Though I can rename the one in the system32
> directory and get the same problem you report.
> Have you tried putting the dll in the SysWOW64 directory?
> If all else fails (and it appears to have), make a PostgreSql repository.
> Just create a DB with the admin tool, then use the New>Repository menu to
> connect to it.
>
>
>
>
>
> >  Although the message ‘There is no connection a
> > database’ really isn't very insightful to me - so maybe this has
> > nothing to do with sqlite.
>
> > On Apr 11, 7:11 pm, John McKeon <[hidden email]> wrote:
> > > This is a shot in the dark but...
> > > Did you try putting the dll in the Windows directory (instead of
> > system32)?
> > > The SQLite3Interface class def points to that directory and then the
> > > system32 directory so that might work.
>
> > > I think you run into issues where 64 bit windows redirects references to
> > > system32 to the SysWOW64 directory that can cause problems.
>
> > > John
>
> > > On Sun, Apr 11, 2010 at 2:37 PM, Hunter <[hidden email]> wrote:
> > > > VWNC? VisualWorks ...?
>
> > > > On Apr 11, 10:38 am, James Robertson <[hidden email]> wrote:
> > > > > well, you could fire up vwnc, and load the SQLlite driver, and see if
> > it
> > > > works
>
> > > > > On Apr 11, 2010, at 10:51 AM, Hunter wrote:
>
> > > > > > Just tried that and shutdown Webvelocity, relaunched Webvelocity,
> > > > > > defined database, mapped some classes - tried to publish: same
> > error.
> > > > > > Seems sqlite isn't installed properly. Is there a way to test that
> > > > > > independent of Webvelocity?
>
> > > > > > On Apr 11, 1:10 am, James Robertson <[hidden email]> wrote:
> > > > > >> try putting it into Windows\system32
>
> > > > > >> On Apr 10, 2010, at 11:18 PM, Hunter wrote:
>
> > > > > >>> Still working on this issue. I suspect it is related to possibly
> > not
> > > > > >>> finding sqlite.  When I attempt to publish,  the following error
> > is
> > > > > >>> displayed:
> > > > > >>> ‘There is no connection a database’
> > > > > >>> OS:
> > > > > >>> Microsoft Windows Vista Home Premium Edition (x86 64-bit) Service
> > > > Pack
> > > > > >>> 1
> > > > > >>> Database Configuration:
> > > > > >>> Platform: PostgreSQL
> > > > > >>> Mappings: Schema1
> > > > > >>> Host: localhost
> > > > > >>> Port: 5432
> > > > > >>> Database: SICTEST
> > > > > >>> Schema: public
> > > > > >>> Username: postgres
> > > > > >>> Repository:
> > > > > >>> Name: Personal
> > > > > >>> Platform: SQLite 3
> > > > > >>> Database: personal.db
>
> > > > > >>> The only sqlite dll I could find was on my backup drive, so I
> > copied
> > > > > >>> that file (sqlite3.dll  254 KB dated ‎May ‎14, ‎2009, ‏‎6:04:00
> > AM )
> > > > > >>> to C:\Program Files (x86)\Common Files. I added this to the path
> >  -
> > > > > >>> still no luck. Suggestions?
>
> > > > > >>> On Mar 29, 12:26 am, "Mark D. Roberts" <[hidden email]>
> > wrote:
> > > > > >>>> On 3/29/2010 1:05 PM, Hunter wrote:
>
> > > > > >>>>> I'm just trying
> > > > > >>>>> 'save' my code (methods, classes, etc), but get the 'There is
> > no
> > > > > >>>>> connection to a database' error and the suggestions I've
> > received
> > > > so
> > > > > >>>>> far don't seem to foot to something I can do specifically. I've
> > > > > >>>>> createda PostgreSQL database, complete with data. Supposedly my
> > > > > >>>>> database configuration works, the 'test login' works. Then I
> > > > generated
> > > > > >>>>> (map) just a few classes. I want to save this, and future work
> > too.
> > > > My
> > > > > >>>>> exact steps are: 'Open Browser', click on my loaded application
> > > > > >>>>> 'ShawInvestmentCompany', select Actions\Publish, click OK. Form
> > > > this I
> > > > > >>>>> receive 'There is no connection a database'.
>
> > > > > >>>> Maybe you've already checked this over, but just to make sure...
>
> > > > > >>>> When you open the "Repositories" menu on the main page, what's
> > > > selected?
> > > > > >>>> "Personal"? When you select "edit" for the currently selected
> > > > > >>>> repository, what are the connection settings in the "Edit
> > > > Repository"
> > > > > >>>> dialog?
>
> > > > > >>>> In WebVelocity 1.0, the code for your application and its data
> > are
> > > > > >>>> stored in distinct databases. The application code that you
> > publish
> > > > goes
> > > > > >>>> into a repository, and this is set using the "Repositories" menu
> > on
> > > > the
> > > > > >>>> main page. By default, WebVelocity uses a SQLite database called
> > > > > >>>> "Personal", and this should just be configured and ready to go
> > when
> > > > you
> > > > > >>>> launch. That is, SQLite is bundled with WebVelocity and no
> > manual
> > > > > >>>> configuration is necessary, unless you want to save your code in
> > a
> > > > > >>>> different repository. If you changed this setting to a different
> > > > > >>>> database, or the configuration is messed up somehow, then you
> > may
> > > > need
> > > > > >>>> to change it back. You can also create new code repositories
> > using
> > > > the
> > > > > >>>> "New" menu.
>
> > > > > >>>> Your application data, on the other hand, goes into a separate
> > > > database
> > > > > >>>> that is configured from the "Database" menu in the Application
> > > > Editor.
> > > > > >>>> It sounds like you have that configured correctly for your
> > > > application,
> > > > > >>>> but perhaps somewhere along the line the repository that you
> > have
> > > > > >>>> selected for code storage got confused somehow.
>
> > > > > >>>> So, I'd say double check that first.
>
> > > > > >>>> Regards,
>
> > > > > >>>> M. Roberts
> > > > > >>>> Cincom Systems, Inc.
>
> > > > > >>> --
> > > > > >>> You received this message because you are subscribed to the
> > Google
> > > > Groups "WebVelocity" group.
> > > > > >>> To post to this group, send email to
> > [hidden email].
> > > > > >>> To unsubscribe from this group, send email to
> > > > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > <webvelocity%2Bunsubscribe@googlegr­oups.com>
> > > > .
> > > > > >>> For more options, visit this group athttp://
> > > > groups.google.com/group/webvelocity?hl=en.-Hide quoted text -
>
> > > > > >> - Show quoted text -
>
> > > > > > --
> > > > > > You received this message because you are subscribed to the Google
> > > > Groups "WebVelocity" group.
> > > > > > To post to this group, send email to [hidden email].
> > > > > > To unsubscribe from this group, send email to
> > > > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > <webvelocity%2Bunsubscribe@googlegr­oups.com>
> > > > .
> > > > > > For more options, visit this group athttp://
> > > > groups.google.com/group/webvelocity?hl=en.- Hide quoted text -
>
> > > > > - Show quoted text -
>
> > > > --
> > > > You received this message because you are subscribed to the Google
> > Groups
> > > > "WebVelocity" group.
> > > > To post to this group, send email to [hidden email].
> > > > To unsubscribe from this group, send email to
> > > > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > <webvelocity%2Bunsubscribe@googlegr­oups.com>
> > > > .
> > > > For more options, visit this group at
> > > >http://groups.google.com/group/webvelocity?hl=en.
>
> > > --http://jmck.seasidehosting.st-Hide quoted text -
>
> > > - Show quoted text -
>
> > --
> > You received this message because you are subscribed to the Google Groups
> > "WebVelocity" group.
> > To post to this group, send email to [hidden email].
> > To unsubscribe from this group, send email to
> > [hidden email]<webvelocity%2Bunsubscribe@googlegr­oups.com>
> > .
> > For more options, visit this group at
> >http://groups.google.com/group/webvelocity?hl=en.
>
> --http://jmck.seasidehosting.st- Hide quoted text -
>
> - Show quoted text -

--
You received this message because you are subscribed to the Google Groups "WebVelocity" group.
To post to this group, send email to [hidden email].
To unsubscribe from this group, send email to [hidden email].
For more options, visit this group at http://groups.google.com/group/webvelocity?hl=en.

12
Loading...