[Test][Squeak5.2a][Metacello] Installation causes VM crash

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

[Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
Hello

The installation of Metacello causes a VM crash.

http://wiki.squeak.org/squeak/6157
https://github.com/Metacello/metacello


"Get the Metacello configuration (for Squeak users)"
Installer gemsource
    project: 'metacello';
    addPackage: 'ConfigurationOfMetacello';
    install.


"Result : OK"



"Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
symbolic version"
((Smalltalk at: #ConfigurationOfMetacello) project
  version: #'previewBootstrap') load.

"Result : OK"

"Load the Preview version of Metacello from GitHub"
(Smalltalk at: #Metacello) new
  configuration: 'MetacelloPreview';
  version: #stable;
  repository: 'github://Metacello/metacello:configuration';
  load.

"CRASH"

"Now load latest version of Metacello"
(Smalltalk at: #Metacello) new
  baseline: 'Metacello';
  repository: 'github://Metacello/metacello:master/repository';
  get.
(Smalltalk at: #Metacello) new
  baseline: 'Metacello';
  repository: 'github://Metacello/metacello:master/repository';
  load.


Regards
Hannes

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Levente Uzonyi
You're probably experiencing this issue: https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
Please confirm if that's the case. In general, it helps if you give a bit more information about the crash (VM, image, etc).
Also I suggest you use Installer ensureRecentMetacello to load Metacello
instead of that snippet, because that snippet breaks WebClient and
SqueakSSL by loading an older, incompatible version of them.

Levente

On Wed, 4 Jul 2018, H. Hirzel wrote:

> Hello
>
> The installation of Metacello causes a VM crash.
>
> http://wiki.squeak.org/squeak/6157
> https://github.com/Metacello/metacello
>
>
> "Get the Metacello configuration (for Squeak users)"
> Installer gemsource
>    project: 'metacello';
>    addPackage: 'ConfigurationOfMetacello';
>    install.
>
>
> "Result : OK"
>
>
>
> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
> symbolic version"
> ((Smalltalk at: #ConfigurationOfMetacello) project
>  version: #'previewBootstrap') load.
>
> "Result : OK"
>
> "Load the Preview version of Metacello from GitHub"
> (Smalltalk at: #Metacello) new
>  configuration: 'MetacelloPreview';
>  version: #stable;
>  repository: 'github://Metacello/metacello:configuration';
>  load.
>
> "CRASH"
>
> "Now load latest version of Metacello"
> (Smalltalk at: #Metacello) new
>  baseline: 'Metacello';
>  repository: 'github://Metacello/metacello:master/repository';
>  get.
> (Smalltalk at: #Metacello) new
>  baseline: 'Metacello';
>  repository: 'github://Metacello/metacello:master/repository';
>  load.
>
>
> Regards
> Hannes

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
Thank you for the feedback.

You refer to issue
https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
The answer is: Maybe it is the same, but I use a 32bit image, see below.

I was using the installation script from
https://github.com/Metacello/metacello
Squeak section.

I did not know that I have to go for

    Installer ensureRecentMetacello

That is actually much better from a user point of view.

But it causes a instant VM crash.


Image information is below

--Hannes


Image
-----
/media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
Squeak5.2alpha
latest update: #18134
Current Change Set: Unnamed1
Image format 6521 (32 bit)

Virtual Machine
---------------
/media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives VMMaker.oscog-eem.2361]
Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
platform sources revision VM: 201804030952
https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
CoInterpreter VMMaker.oscog-eem.2361 uuid:
7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018



On 7/4/18, Levente Uzonyi <[hidden email]> wrote:

> You're probably experiencing this issue:
> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
> Please confirm if that's the case. In general, it helps if you give a bit
> more information about the crash (VM, image, etc).
> Also I suggest you use Installer ensureRecentMetacello to load Metacello
> instead of that snippet, because that snippet breaks WebClient and
> SqueakSSL by loading an older, incompatible version of them.
>
> Levente
>
> On Wed, 4 Jul 2018, H. Hirzel wrote:
>
>> Hello
>>
>> The installation of Metacello causes a VM crash.
>>
>> http://wiki.squeak.org/squeak/6157
>> https://github.com/Metacello/metacello
>>
>>
>> "Get the Metacello configuration (for Squeak users)"
>> Installer gemsource
>>    project: 'metacello';
>>    addPackage: 'ConfigurationOfMetacello';
>>    install.
>>
>>
>> "Result : OK"
>>
>>
>>
>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>> symbolic version"
>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>  version: #'previewBootstrap') load.
>>
>> "Result : OK"
>>
>> "Load the Preview version of Metacello from GitHub"
>> (Smalltalk at: #Metacello) new
>>  configuration: 'MetacelloPreview';
>>  version: #stable;
>>  repository: 'github://Metacello/metacello:configuration';
>>  load.
>>
>> "CRASH"
>>
>> "Now load latest version of Metacello"
>> (Smalltalk at: #Metacello) new
>>  baseline: 'Metacello';
>>  repository: 'github://Metacello/metacello:master/repository';
>>  get.
>> (Smalltalk at: #Metacello) new
>>  baseline: 'Metacello';
>>  repository: 'github://Metacello/metacello:master/repository';
>>  load.
>>
>>
>> Regards
>> Hannes
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Levente Uzonyi
On Wed, 4 Jul 2018, H. Hirzel wrote:

> Thank you for the feedback.
>
> You refer to issue
> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
> The answer is: Maybe it is the same, but I use a 32bit image, see below.

Do you use linux? If yes, which version?

Levente

>
> I was using the installation script from
> https://github.com/Metacello/metacello
> Squeak section.
>
> I did not know that I have to go for
>
>    Installer ensureRecentMetacello
>
> That is actually much better from a user point of view.
>
> But it causes a instant VM crash.
>
>
> Image information is below
>
> --Hannes
>
>
> Image
> -----
> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
> Squeak5.2alpha
> latest update: #18134
> Current Change Set: Unnamed1
> Image format 6521 (32 bit)
>
> Virtual Machine
> ---------------
> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives VMMaker.oscog-eem.2361]
> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
> platform sources revision VM: 201804030952
> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
> CoInterpreter VMMaker.oscog-eem.2361 uuid:
> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>
>
>
> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>> You're probably experiencing this issue:
>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>> Please confirm if that's the case. In general, it helps if you give a bit
>> more information about the crash (VM, image, etc).
>> Also I suggest you use Installer ensureRecentMetacello to load Metacello
>> instead of that snippet, because that snippet breaks WebClient and
>> SqueakSSL by loading an older, incompatible version of them.
>>
>> Levente
>>
>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>
>>> Hello
>>>
>>> The installation of Metacello causes a VM crash.
>>>
>>> http://wiki.squeak.org/squeak/6157
>>> https://github.com/Metacello/metacello
>>>
>>>
>>> "Get the Metacello configuration (for Squeak users)"
>>> Installer gemsource
>>>    project: 'metacello';
>>>    addPackage: 'ConfigurationOfMetacello';
>>>    install.
>>>
>>>
>>> "Result : OK"
>>>
>>>
>>>
>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>> symbolic version"
>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>  version: #'previewBootstrap') load.
>>>
>>> "Result : OK"
>>>
>>> "Load the Preview version of Metacello from GitHub"
>>> (Smalltalk at: #Metacello) new
>>>  configuration: 'MetacelloPreview';
>>>  version: #stable;
>>>  repository: 'github://Metacello/metacello:configuration';
>>>  load.
>>>
>>> "CRASH"
>>>
>>> "Now load latest version of Metacello"
>>> (Smalltalk at: #Metacello) new
>>>  baseline: 'Metacello';
>>>  repository: 'github://Metacello/metacello:master/repository';
>>>  get.
>>> (Smalltalk at: #Metacello) new
>>>  baseline: 'Metacello';
>>>  repository: 'github://Metacello/metacello:master/repository';
>>>  load.
>>>
>>>
>>> Regards
>>> Hannes
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Levente Uzonyi
Well, now I see that you use linux, though I still don't know which.
Actually it doesn't really matter. What matters is which version of libssl
is installed on your machine.
I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
with 1.0.2 and 1.1.

Levente

On Wed, 4 Jul 2018, Levente Uzonyi wrote:

> On Wed, 4 Jul 2018, H. Hirzel wrote:
>
>> Thank you for the feedback.
>>
>> You refer to issue
>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>> The answer is: Maybe it is the same, but I use a 32bit image, see below.
>
> Do you use linux? If yes, which version?
>
> Levente
>
>>
>> I was using the installation script from
>> https://github.com/Metacello/metacello
>> Squeak section.
>>
>> I did not know that I have to go for
>>
>>    Installer ensureRecentMetacello
>>
>> That is actually much better from a user point of view.
>>
>> But it causes a instant VM crash.
>>
>>
>> Image information is below
>>
>> --Hannes
>>
>>
>> Image
>> -----
>>
> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>> Squeak5.2alpha
>> latest update: #18134
>> Current Change Set: Unnamed1
>> Image format 6521 (32 bit)
>>
>> Virtual Machine
>> ---------------
>>
> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
> VMMaker.oscog-eem.2361]
>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>> platform sources revision VM: 201804030952
>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>
>>
>>
>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>> You're probably experiencing this issue:
>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>> Please confirm if that's the case. In general, it helps if you give a bit
>>> more information about the crash (VM, image, etc).
>>> Also I suggest you use Installer ensureRecentMetacello to load Metacello
>>> instead of that snippet, because that snippet breaks WebClient and
>>> SqueakSSL by loading an older, incompatible version of them.
>>>
>>> Levente
>>>
>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>
>>>> Hello
>>>>
>>>> The installation of Metacello causes a VM crash.
>>>>
>>>> http://wiki.squeak.org/squeak/6157
>>>> https://github.com/Metacello/metacello
>>>>
>>>>
>>>> "Get the Metacello configuration (for Squeak users)"
>>>> Installer gemsource
>>>>    project: 'metacello';
>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>    install.
>>>>
>>>>
>>>> "Result : OK"
>>>>
>>>>
>>>>
>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>> symbolic version"
>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>  version: #'previewBootstrap') load.
>>>>
>>>> "Result : OK"
>>>>
>>>> "Load the Preview version of Metacello from GitHub"
>>>> (Smalltalk at: #Metacello) new
>>>>  configuration: 'MetacelloPreview';
>>>>  version: #stable;
>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>  load.
>>>>
>>>> "CRASH"
>>>>
>>>> "Now load latest version of Metacello"
>>>> (Smalltalk at: #Metacello) new
>>>>  baseline: 'Metacello';
>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>  get.
>>>> (Smalltalk at: #Metacello) new
>>>>  baseline: 'Metacello';
>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>  load.
>>>>
>>>>
>>>> Regards
>>>> Hannes
>>>
>>>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
Yes it is Linux, Ubuntu based, 14.04
and libssl has

$ openssl version -a
OpenSSL 1.0.1f 6 Jan 2014
built on: Thu Mar 19 15:10:04 UTC 2015
platform: debian-i386

So we can consider this to be a known error and ask for a later version of Linux

Thank you.
--Hannes

On 7/4/18, Levente Uzonyi <[hidden email]> wrote:

> Well, now I see that you use linux, though I still don't know which.
> Actually it doesn't really matter. What matters is which version of libssl
> is installed on your machine.
> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
> with 1.0.2 and 1.1.
>
> Levente
>
> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>
>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>
>>> Thank you for the feedback.
>>>
>>> You refer to issue
>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>> The answer is: Maybe it is the same, but I use a 32bit image, see below.
>>
>> Do you use linux? If yes, which version?
>>
>> Levente
>>
>>>
>>> I was using the installation script from
>>> https://github.com/Metacello/metacello
>>> Squeak section.
>>>
>>> I did not know that I have to go for
>>>
>>>    Installer ensureRecentMetacello
>>>
>>> That is actually much better from a user point of view.
>>>
>>> But it causes a instant VM crash.
>>>
>>>
>>> Image information is below
>>>
>>> --Hannes
>>>
>>>
>>> Image
>>> -----
>>>
>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>> Squeak5.2alpha
>>> latest update: #18134
>>> Current Change Set: Unnamed1
>>> Image format 6521 (32 bit)
>>>
>>> Virtual Machine
>>> ---------------
>>>
>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>> VMMaker.oscog-eem.2361]
>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>> platform sources revision VM: 201804030952
>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>
>>>
>>>
>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>> You're probably experiencing this issue:
>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>> Please confirm if that's the case. In general, it helps if you give a
>>>> bit
>>>> more information about the crash (VM, image, etc).
>>>> Also I suggest you use Installer ensureRecentMetacello to load Metacello
>>>> instead of that snippet, because that snippet breaks WebClient and
>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>
>>>> Levente
>>>>
>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>
>>>>> Hello
>>>>>
>>>>> The installation of Metacello causes a VM crash.
>>>>>
>>>>> http://wiki.squeak.org/squeak/6157
>>>>> https://github.com/Metacello/metacello
>>>>>
>>>>>
>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>> Installer gemsource
>>>>>    project: 'metacello';
>>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>>    install.
>>>>>
>>>>>
>>>>> "Result : OK"
>>>>>
>>>>>
>>>>>
>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>> symbolic version"
>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>  version: #'previewBootstrap') load.
>>>>>
>>>>> "Result : OK"
>>>>>
>>>>> "Load the Preview version of Metacello from GitHub"
>>>>> (Smalltalk at: #Metacello) new
>>>>>  configuration: 'MetacelloPreview';
>>>>>  version: #stable;
>>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>>  load.
>>>>>
>>>>> "CRASH"
>>>>>
>>>>> "Now load latest version of Metacello"
>>>>> (Smalltalk at: #Metacello) new
>>>>>  baseline: 'Metacello';
>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>  get.
>>>>> (Smalltalk at: #Metacello) new
>>>>>  baseline: 'Metacello';
>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>  load.
>>>>>
>>>>>
>>>>> Regards
>>>>> Hannes
>>>>
>>>>
>>
>>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
I followed
https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/

and got the ssl version (full info below)
1.0.2l

It still crashes.

--Hannes


openssl version -a
OpenSSL 1.0.2l  25 May 2017
built on: reproducible build, date unspecified
platform: linux-elf
options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int) blowfish(idx)
compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
-DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
-fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
-DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
-DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
-DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM


On 7/5/18, H. Hirzel <[hidden email]> wrote:

> Yes it is Linux, Ubuntu based, 14.04
> and libssl has
>
> $ openssl version -a
> OpenSSL 1.0.1f 6 Jan 2014
> built on: Thu Mar 19 15:10:04 UTC 2015
> platform: debian-i386
>
> So we can consider this to be a known error and ask for a later version of
> Linux
>
> Thank you.
> --Hannes
>
> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>> Well, now I see that you use linux, though I still don't know which.
>> Actually it doesn't really matter. What matters is which version of
>> libssl
>> is installed on your machine.
>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>> with 1.0.2 and 1.1.
>>
>> Levente
>>
>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>
>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>
>>>> Thank you for the feedback.
>>>>
>>>> You refer to issue
>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>> below.
>>>
>>> Do you use linux? If yes, which version?
>>>
>>> Levente
>>>
>>>>
>>>> I was using the installation script from
>>>> https://github.com/Metacello/metacello
>>>> Squeak section.
>>>>
>>>> I did not know that I have to go for
>>>>
>>>>    Installer ensureRecentMetacello
>>>>
>>>> That is actually much better from a user point of view.
>>>>
>>>> But it causes a instant VM crash.
>>>>
>>>>
>>>> Image information is below
>>>>
>>>> --Hannes
>>>>
>>>>
>>>> Image
>>>> -----
>>>>
>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>> Squeak5.2alpha
>>>> latest update: #18134
>>>> Current Change Set: Unnamed1
>>>> Image format 6521 (32 bit)
>>>>
>>>> Virtual Machine
>>>> ---------------
>>>>
>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>> VMMaker.oscog-eem.2361]
>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>> platform sources revision VM: 201804030952
>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>
>>>>
>>>>
>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>> You're probably experiencing this issue:
>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>> Please confirm if that's the case. In general, it helps if you give a
>>>>> bit
>>>>> more information about the crash (VM, image, etc).
>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>> Metacello
>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>
>>>>> Levente
>>>>>
>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>
>>>>>> Hello
>>>>>>
>>>>>> The installation of Metacello causes a VM crash.
>>>>>>
>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>> https://github.com/Metacello/metacello
>>>>>>
>>>>>>
>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>> Installer gemsource
>>>>>>    project: 'metacello';
>>>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>>>    install.
>>>>>>
>>>>>>
>>>>>> "Result : OK"
>>>>>>
>>>>>>
>>>>>>
>>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>>> symbolic version"
>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>  version: #'previewBootstrap') load.
>>>>>>
>>>>>> "Result : OK"
>>>>>>
>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>> (Smalltalk at: #Metacello) new
>>>>>>  configuration: 'MetacelloPreview';
>>>>>>  version: #stable;
>>>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>>>  load.
>>>>>>
>>>>>> "CRASH"
>>>>>>
>>>>>> "Now load latest version of Metacello"
>>>>>> (Smalltalk at: #Metacello) new
>>>>>>  baseline: 'Metacello';
>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>  get.
>>>>>> (Smalltalk at: #Metacello) new
>>>>>>  baseline: 'Metacello';
>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>  load.
>>>>>>
>>>>>>
>>>>>> Regards
>>>>>> Hannes
>>>>>
>>>>>
>>>
>>>
>>
>>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Levente Uzonyi
You probably still have 1.0.1 installed.

Levente

On Thu, 5 Jul 2018, H. Hirzel wrote:

> I followed
> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>
> and got the ssl version (full info below)
> 1.0.2l
>
> It still crashes.
>
> --Hannes
>
>
> openssl version -a
> OpenSSL 1.0.2l  25 May 2017
> built on: reproducible build, date unspecified
> platform: linux-elf
> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int) blowfish(idx)
> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>
>
> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>> Yes it is Linux, Ubuntu based, 14.04
>> and libssl has
>>
>> $ openssl version -a
>> OpenSSL 1.0.1f 6 Jan 2014
>> built on: Thu Mar 19 15:10:04 UTC 2015
>> platform: debian-i386
>>
>> So we can consider this to be a known error and ask for a later version of
>> Linux
>>
>> Thank you.
>> --Hannes
>>
>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>> Well, now I see that you use linux, though I still don't know which.
>>> Actually it doesn't really matter. What matters is which version of
>>> libssl
>>> is installed on your machine.
>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>> with 1.0.2 and 1.1.
>>>
>>> Levente
>>>
>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>
>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>
>>>>> Thank you for the feedback.
>>>>>
>>>>> You refer to issue
>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>> below.
>>>>
>>>> Do you use linux? If yes, which version?
>>>>
>>>> Levente
>>>>
>>>>>
>>>>> I was using the installation script from
>>>>> https://github.com/Metacello/metacello
>>>>> Squeak section.
>>>>>
>>>>> I did not know that I have to go for
>>>>>
>>>>>    Installer ensureRecentMetacello
>>>>>
>>>>> That is actually much better from a user point of view.
>>>>>
>>>>> But it causes a instant VM crash.
>>>>>
>>>>>
>>>>> Image information is below
>>>>>
>>>>> --Hannes
>>>>>
>>>>>
>>>>> Image
>>>>> -----
>>>>>
>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>> Squeak5.2alpha
>>>>> latest update: #18134
>>>>> Current Change Set: Unnamed1
>>>>> Image format 6521 (32 bit)
>>>>>
>>>>> Virtual Machine
>>>>> ---------------
>>>>>
>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>> VMMaker.oscog-eem.2361]
>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>> platform sources revision VM: 201804030952
>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>
>>>>>
>>>>>
>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>> You're probably experiencing this issue:
>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>> Please confirm if that's the case. In general, it helps if you give a
>>>>>> bit
>>>>>> more information about the crash (VM, image, etc).
>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>> Metacello
>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>
>>>>>> Levente
>>>>>>
>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>
>>>>>>> Hello
>>>>>>>
>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>
>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>> https://github.com/Metacello/metacello
>>>>>>>
>>>>>>>
>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>> Installer gemsource
>>>>>>>    project: 'metacello';
>>>>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>>>>    install.
>>>>>>>
>>>>>>>
>>>>>>> "Result : OK"
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>>>> symbolic version"
>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>  version: #'previewBootstrap') load.
>>>>>>>
>>>>>>> "Result : OK"
>>>>>>>
>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>  configuration: 'MetacelloPreview';
>>>>>>>  version: #stable;
>>>>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>>>>  load.
>>>>>>>
>>>>>>> "CRASH"
>>>>>>>
>>>>>>> "Now load latest version of Metacello"
>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>  baseline: 'Metacello';
>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>  get.
>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>  baseline: 'Metacello';
>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>  load.
>>>>>>>
>>>>>>>
>>>>>>> Regards
>>>>>>> Hannes
>>>>>>
>>>>>>
>>>>
>>>>
>>>
>>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
You mean though I get

openssl version -a
1.0.2l

How would I then remove 1.0.1?


On 7/5/18, Levente Uzonyi <[hidden email]> wrote:

> You probably still have 1.0.1 installed.
>
> Levente
>
> On Thu, 5 Jul 2018, H. Hirzel wrote:
>
>> I followed
>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>
>> and got the ssl version (full info below)
>> 1.0.2l
>>
>> It still crashes.
>>
>> --Hannes
>>
>>
>> openssl version -a
>> OpenSSL 1.0.2l  25 May 2017
>> built on: reproducible build, date unspecified
>> platform: linux-elf
>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>> blowfish(idx)
>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>
>>
>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>> Yes it is Linux, Ubuntu based, 14.04
>>> and libssl has
>>>
>>> $ openssl version -a
>>> OpenSSL 1.0.1f 6 Jan 2014
>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>> platform: debian-i386
>>>
>>> So we can consider this to be a known error and ask for a later version
>>> of
>>> Linux
>>>
>>> Thank you.
>>> --Hannes
>>>
>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>> Well, now I see that you use linux, though I still don't know which.
>>>> Actually it doesn't really matter. What matters is which version of
>>>> libssl
>>>> is installed on your machine.
>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>>> with 1.0.2 and 1.1.
>>>>
>>>> Levente
>>>>
>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>
>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>
>>>>>> Thank you for the feedback.
>>>>>>
>>>>>> You refer to issue
>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>> below.
>>>>>
>>>>> Do you use linux? If yes, which version?
>>>>>
>>>>> Levente
>>>>>
>>>>>>
>>>>>> I was using the installation script from
>>>>>> https://github.com/Metacello/metacello
>>>>>> Squeak section.
>>>>>>
>>>>>> I did not know that I have to go for
>>>>>>
>>>>>>    Installer ensureRecentMetacello
>>>>>>
>>>>>> That is actually much better from a user point of view.
>>>>>>
>>>>>> But it causes a instant VM crash.
>>>>>>
>>>>>>
>>>>>> Image information is below
>>>>>>
>>>>>> --Hannes
>>>>>>
>>>>>>
>>>>>> Image
>>>>>> -----
>>>>>>
>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>> Squeak5.2alpha
>>>>>> latest update: #18134
>>>>>> Current Change Set: Unnamed1
>>>>>> Image format 6521 (32 bit)
>>>>>>
>>>>>> Virtual Machine
>>>>>> ---------------
>>>>>>
>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>> VMMaker.oscog-eem.2361]
>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>> platform sources revision VM: 201804030952
>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>> You're probably experiencing this issue:
>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>> Please confirm if that's the case. In general, it helps if you give a
>>>>>>> bit
>>>>>>> more information about the crash (VM, image, etc).
>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>> Metacello
>>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>
>>>>>>> Levente
>>>>>>>
>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>
>>>>>>>> Hello
>>>>>>>>
>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>
>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>
>>>>>>>>
>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>> Installer gemsource
>>>>>>>>    project: 'metacello';
>>>>>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>>>>>    install.
>>>>>>>>
>>>>>>>>
>>>>>>>> "Result : OK"
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>>>>> symbolic version"
>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>  version: #'previewBootstrap') load.
>>>>>>>>
>>>>>>>> "Result : OK"
>>>>>>>>
>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>  configuration: 'MetacelloPreview';
>>>>>>>>  version: #stable;
>>>>>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>>>>>  load.
>>>>>>>>
>>>>>>>> "CRASH"
>>>>>>>>
>>>>>>>> "Now load latest version of Metacello"
>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>  baseline: 'Metacello';
>>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>  get.
>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>  baseline: 'Metacello';
>>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>  load.
>>>>>>>>
>>>>>>>>
>>>>>>>> Regards
>>>>>>>> Hannes
>>>>>>>
>>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Levente Uzonyi
On Thu, 5 Jul 2018, H. Hirzel wrote:

> You mean though I get
>
> openssl version -a
> 1.0.2l
>
> How would I then remove 1.0.1?

To find out what you have installed:

$ aptitude search libssl1 | grep ^i

or if you don't have aptitude installed:

$ apt search libssl1 | grep installed

To remove libssl1.0.0, which you should only do if the self-compiled 1.0.2
satisfies all package dependencies and you're willing to update it from
time to time yourself:

$ sudo apt remove libssl1.0.0

Levente

>
>
> On 7/5/18, Levente Uzonyi <[hidden email]> wrote:
>> You probably still have 1.0.1 installed.
>>
>> Levente
>>
>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>
>>> I followed
>>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>>
>>> and got the ssl version (full info below)
>>> 1.0.2l
>>>
>>> It still crashes.
>>>
>>> --Hannes
>>>
>>>
>>> openssl version -a
>>> OpenSSL 1.0.2l  25 May 2017
>>> built on: reproducible build, date unspecified
>>> platform: linux-elf
>>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>>> blowfish(idx)
>>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>>
>>>
>>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>>> Yes it is Linux, Ubuntu based, 14.04
>>>> and libssl has
>>>>
>>>> $ openssl version -a
>>>> OpenSSL 1.0.1f 6 Jan 2014
>>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>>> platform: debian-i386
>>>>
>>>> So we can consider this to be a known error and ask for a later version
>>>> of
>>>> Linux
>>>>
>>>> Thank you.
>>>> --Hannes
>>>>
>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>> Well, now I see that you use linux, though I still don't know which.
>>>>> Actually it doesn't really matter. What matters is which version of
>>>>> libssl
>>>>> is installed on your machine.
>>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>>>> with 1.0.2 and 1.1.
>>>>>
>>>>> Levente
>>>>>
>>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>>
>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>
>>>>>>> Thank you for the feedback.
>>>>>>>
>>>>>>> You refer to issue
>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>>> below.
>>>>>>
>>>>>> Do you use linux? If yes, which version?
>>>>>>
>>>>>> Levente
>>>>>>
>>>>>>>
>>>>>>> I was using the installation script from
>>>>>>> https://github.com/Metacello/metacello
>>>>>>> Squeak section.
>>>>>>>
>>>>>>> I did not know that I have to go for
>>>>>>>
>>>>>>>    Installer ensureRecentMetacello
>>>>>>>
>>>>>>> That is actually much better from a user point of view.
>>>>>>>
>>>>>>> But it causes a instant VM crash.
>>>>>>>
>>>>>>>
>>>>>>> Image information is below
>>>>>>>
>>>>>>> --Hannes
>>>>>>>
>>>>>>>
>>>>>>> Image
>>>>>>> -----
>>>>>>>
>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>>> Squeak5.2alpha
>>>>>>> latest update: #18134
>>>>>>> Current Change Set: Unnamed1
>>>>>>> Image format 6521 (32 bit)
>>>>>>>
>>>>>>> Virtual Machine
>>>>>>> ---------------
>>>>>>>
>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>>> VMMaker.oscog-eem.2361]
>>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>>> platform sources revision VM: 201804030952
>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>> You're probably experiencing this issue:
>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>> Please confirm if that's the case. In general, it helps if you give a
>>>>>>>> bit
>>>>>>>> more information about the crash (VM, image, etc).
>>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>>> Metacello
>>>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>>
>>>>>>>> Levente
>>>>>>>>
>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>
>>>>>>>>> Hello
>>>>>>>>>
>>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>>
>>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>>> Installer gemsource
>>>>>>>>>    project: 'metacello';
>>>>>>>>>    addPackage: 'ConfigurationOfMetacello';
>>>>>>>>>    install.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Result : OK"
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>>>>>> symbolic version"
>>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>>  version: #'previewBootstrap') load.
>>>>>>>>>
>>>>>>>>> "Result : OK"
>>>>>>>>>
>>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>  configuration: 'MetacelloPreview';
>>>>>>>>>  version: #stable;
>>>>>>>>>  repository: 'github://Metacello/metacello:configuration';
>>>>>>>>>  load.
>>>>>>>>>
>>>>>>>>> "CRASH"
>>>>>>>>>
>>>>>>>>> "Now load latest version of Metacello"
>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>  baseline: 'Metacello';
>>>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>  get.
>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>  baseline: 'Metacello';
>>>>>>>>>  repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>  load.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Regards
>>>>>>>>> Hannes
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Tobias Pape
Hi all


Can you test with a new vm? I have a change in 97b799c  (opensmalltalk-vm) that could simply fix that.

Best regards
        -Tobias


> On 05.07.2018, at 01:28, Levente Uzonyi <[hidden email]> wrote:
>
> On Thu, 5 Jul 2018, H. Hirzel wrote:
>
>> You mean though I get
>>
>> openssl version -a
>> 1.0.2l
>>
>> How would I then remove 1.0.1?
>
> To find out what you have installed:
>
> $ aptitude search libssl1 | grep ^i
>
> or if you don't have aptitude installed:
>
> $ apt search libssl1 | grep installed
>
> To remove libssl1.0.0, which you should only do if the self-compiled 1.0.2 satisfies all package dependencies and you're willing to update it from time to time yourself:
>
> $ sudo apt remove libssl1.0.0
>
> Levente
>
>>
>>
>> On 7/5/18, Levente Uzonyi <[hidden email]> wrote:
>>> You probably still have 1.0.1 installed.
>>>
>>> Levente
>>>
>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>
>>>> I followed
>>>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>>>
>>>> and got the ssl version (full info below)
>>>> 1.0.2l
>>>>
>>>> It still crashes.
>>>>
>>>> --Hannes
>>>>
>>>>
>>>> openssl version -a
>>>> OpenSSL 1.0.2l  25 May 2017
>>>> built on: reproducible build, date unspecified
>>>> platform: linux-elf
>>>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>>>> blowfish(idx)
>>>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>>>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>>>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>>>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>>>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>>>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>>>
>>>>
>>>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>>>> Yes it is Linux, Ubuntu based, 14.04
>>>>> and libssl has
>>>>>
>>>>> $ openssl version -a
>>>>> OpenSSL 1.0.1f 6 Jan 2014
>>>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>>>> platform: debian-i386
>>>>>
>>>>> So we can consider this to be a known error and ask for a later version
>>>>> of
>>>>> Linux
>>>>>
>>>>> Thank you.
>>>>> --Hannes
>>>>>
>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>> Well, now I see that you use linux, though I still don't know which.
>>>>>> Actually it doesn't really matter. What matters is which version of
>>>>>> libssl
>>>>>> is installed on your machine.
>>>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>>>>> with 1.0.2 and 1.1.
>>>>>>
>>>>>> Levente
>>>>>>
>>>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>>>
>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>
>>>>>>>> Thank you for the feedback.
>>>>>>>>
>>>>>>>> You refer to issue
>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>>>> below.
>>>>>>>
>>>>>>> Do you use linux? If yes, which version?
>>>>>>>
>>>>>>> Levente
>>>>>>>
>>>>>>>>
>>>>>>>> I was using the installation script from
>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>> Squeak section.
>>>>>>>>
>>>>>>>> I did not know that I have to go for
>>>>>>>>
>>>>>>>>   Installer ensureRecentMetacello
>>>>>>>>
>>>>>>>> That is actually much better from a user point of view.
>>>>>>>>
>>>>>>>> But it causes a instant VM crash.
>>>>>>>>
>>>>>>>>
>>>>>>>> Image information is below
>>>>>>>>
>>>>>>>> --Hannes
>>>>>>>>
>>>>>>>>
>>>>>>>> Image
>>>>>>>> -----
>>>>>>>>
>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>>>> Squeak5.2alpha
>>>>>>>> latest update: #18134
>>>>>>>> Current Change Set: Unnamed1
>>>>>>>> Image format 6521 (32 bit)
>>>>>>>>
>>>>>>>> Virtual Machine
>>>>>>>> ---------------
>>>>>>>>
>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>>>> VMMaker.oscog-eem.2361]
>>>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>>>> platform sources revision VM: 201804030952
>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue Apr
>>>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>>> You're probably experiencing this issue:
>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>> Please confirm if that's the case. In general, it helps if you give a
>>>>>>>>> bit
>>>>>>>>> more information about the crash (VM, image, etc).
>>>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>>>> Metacello
>>>>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>>>
>>>>>>>>> Levente
>>>>>>>>>
>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>
>>>>>>>>>> Hello
>>>>>>>>>>
>>>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>>>
>>>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>>>> Installer gemsource
>>>>>>>>>>   project: 'metacello';
>>>>>>>>>>   addPackage: 'ConfigurationOfMetacello';
>>>>>>>>>>   install.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> "Result : OK"
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> "Bootstrap Metacello Preview, using mcz files (#'previewBootstrap'
>>>>>>>>>> symbolic version"
>>>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>>> version: #'previewBootstrap') load.
>>>>>>>>>>
>>>>>>>>>> "Result : OK"
>>>>>>>>>>
>>>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>> configuration: 'MetacelloPreview';
>>>>>>>>>> version: #stable;
>>>>>>>>>> repository: 'github://Metacello/metacello:configuration';
>>>>>>>>>> load.
>>>>>>>>>>
>>>>>>>>>> "CRASH"
>>>>>>>>>>
>>>>>>>>>> "Now load latest version of Metacello"
>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>> get.
>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>> load.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Regards
>>>>>>>>>> Hannes
>>>>>>>>>
>>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>
>>>
>


Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
Hi Tobias

A quick answer! Great!

Where do I get this VM and how do I replace it in the All-In-One? This
is what I am using for testing
(Linux)

http://files.squeak.org/trunk/Squeak5.2alpha-18138-32bit/

Regards
Hannes

On 7/6/18, Tobias Pape <[hidden email]> wrote:

> Hi all
>
>
> Can you test with a new vm? I have a change in 97b799c  (opensmalltalk-vm)
> that could simply fix that.
>
> Best regards
> -Tobias
>
>
>> On 05.07.2018, at 01:28, Levente Uzonyi <[hidden email]> wrote:
>>
>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>
>>> You mean though I get
>>>
>>> openssl version -a
>>> 1.0.2l
>>>
>>> How would I then remove 1.0.1?
>>
>> To find out what you have installed:
>>
>> $ aptitude search libssl1 | grep ^i
>>
>> or if you don't have aptitude installed:
>>
>> $ apt search libssl1 | grep installed
>>
>> To remove libssl1.0.0, which you should only do if the self-compiled 1.0.2
>> satisfies all package dependencies and you're willing to update it from
>> time to time yourself:
>>
>> $ sudo apt remove libssl1.0.0
>>
>> Levente
>>
>>>
>>>
>>> On 7/5/18, Levente Uzonyi <[hidden email]> wrote:
>>>> You probably still have 1.0.1 installed.
>>>>
>>>> Levente
>>>>
>>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>>
>>>>> I followed
>>>>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>>>>
>>>>> and got the ssl version (full info below)
>>>>> 1.0.2l
>>>>>
>>>>> It still crashes.
>>>>>
>>>>> --Hannes
>>>>>
>>>>>
>>>>> openssl version -a
>>>>> OpenSSL 1.0.2l  25 May 2017
>>>>> built on: reproducible build, date unspecified
>>>>> platform: linux-elf
>>>>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>>>>> blowfish(idx)
>>>>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>>>>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>>>>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>>>>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>>>>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>>>>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>>>>
>>>>>
>>>>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>>>>> Yes it is Linux, Ubuntu based, 14.04
>>>>>> and libssl has
>>>>>>
>>>>>> $ openssl version -a
>>>>>> OpenSSL 1.0.1f 6 Jan 2014
>>>>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>>>>> platform: debian-i386
>>>>>>
>>>>>> So we can consider this to be a known error and ask for a later
>>>>>> version
>>>>>> of
>>>>>> Linux
>>>>>>
>>>>>> Thank you.
>>>>>> --Hannes
>>>>>>
>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>> Well, now I see that you use linux, though I still don't know which.
>>>>>>> Actually it doesn't really matter. What matters is which version of
>>>>>>> libssl
>>>>>>> is installed on your machine.
>>>>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>>>>>> with 1.0.2 and 1.1.
>>>>>>>
>>>>>>> Levente
>>>>>>>
>>>>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>>>>
>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>
>>>>>>>>> Thank you for the feedback.
>>>>>>>>>
>>>>>>>>> You refer to issue
>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>>>>> below.
>>>>>>>>
>>>>>>>> Do you use linux? If yes, which version?
>>>>>>>>
>>>>>>>> Levente
>>>>>>>>
>>>>>>>>>
>>>>>>>>> I was using the installation script from
>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>> Squeak section.
>>>>>>>>>
>>>>>>>>> I did not know that I have to go for
>>>>>>>>>
>>>>>>>>>   Installer ensureRecentMetacello
>>>>>>>>>
>>>>>>>>> That is actually much better from a user point of view.
>>>>>>>>>
>>>>>>>>> But it causes a instant VM crash.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Image information is below
>>>>>>>>>
>>>>>>>>> --Hannes
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Image
>>>>>>>>> -----
>>>>>>>>>
>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>>>>> Squeak5.2alpha
>>>>>>>>> latest update: #18134
>>>>>>>>> Current Change Set: Unnamed1
>>>>>>>>> Image format 6521 (32 bit)
>>>>>>>>>
>>>>>>>>> Virtual Machine
>>>>>>>>> ---------------
>>>>>>>>>
>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>>>>> VMMaker.oscog-eem.2361]
>>>>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>>>>> platform sources revision VM: 201804030952
>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue
>>>>>>>>> Apr
>>>>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>>>> You're probably experiencing this issue:
>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>>> Please confirm if that's the case. In general, it helps if you
>>>>>>>>>> give a
>>>>>>>>>> bit
>>>>>>>>>> more information about the crash (VM, image, etc).
>>>>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>>>>> Metacello
>>>>>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>>>>
>>>>>>>>>> Levente
>>>>>>>>>>
>>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>>
>>>>>>>>>>> Hello
>>>>>>>>>>>
>>>>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>>>>
>>>>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>>>>> Installer gemsource
>>>>>>>>>>>   project: 'metacello';
>>>>>>>>>>>   addPackage: 'ConfigurationOfMetacello';
>>>>>>>>>>>   install.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> "Bootstrap Metacello Preview, using mcz files
>>>>>>>>>>> (#'previewBootstrap'
>>>>>>>>>>> symbolic version"
>>>>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>>>> version: #'previewBootstrap') load.
>>>>>>>>>>>
>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>
>>>>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>> configuration: 'MetacelloPreview';
>>>>>>>>>>> version: #stable;
>>>>>>>>>>> repository: 'github://Metacello/metacello:configuration';
>>>>>>>>>>> load.
>>>>>>>>>>>
>>>>>>>>>>> "CRASH"
>>>>>>>>>>>
>>>>>>>>>>> "Now load latest version of Metacello"
>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>> get.
>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>> load.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Regards
>>>>>>>>>>> Hannes
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>
>>>>
>>
>
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Tobias Pape
Hi Hannes,

> On 06.07.2018, at 12:01, H. Hirzel <[hidden email]> wrote:
>
> Hi Tobias
>
> A quick answer! Great!
>
> Where do I get this VM and how do I replace it in the All-In-One? This
> is what I am using for testing
> (Linux)
>
> http://files.squeak.org/trunk/Squeak5.2alpha-18138-32bit/

use the image from there and a vm from here:

https://bintray.com/opensmalltalk/vm/cog/201807060950#files
for example this:
        https://bintray.com/opensmalltalk/vm/download_file?file_path=squeak.cog.spur_linux32x86_201807060950.tar.gz
or this (64bit):
        https://bintray.com/opensmalltalk/vm/download_file?file_path=squeak.cog.spur_linux64x64_201807060950.tar.gz


Best regards
        -Tobias

>
> Regards
> Hannes
>
> On 7/6/18, Tobias Pape <[hidden email]> wrote:
>> Hi all
>>
>>
>> Can you test with a new vm? I have a change in 97b799c  (opensmalltalk-vm)
>> that could simply fix that.
>>
>> Best regards
>> -Tobias
>>
>>
>>> On 05.07.2018, at 01:28, Levente Uzonyi <[hidden email]> wrote:
>>>
>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>
>>>> You mean though I get
>>>>
>>>> openssl version -a
>>>> 1.0.2l
>>>>
>>>> How would I then remove 1.0.1?
>>>
>>> To find out what you have installed:
>>>
>>> $ aptitude search libssl1 | grep ^i
>>>
>>> or if you don't have aptitude installed:
>>>
>>> $ apt search libssl1 | grep installed
>>>
>>> To remove libssl1.0.0, which you should only do if the self-compiled 1.0.2
>>> satisfies all package dependencies and you're willing to update it from
>>> time to time yourself:
>>>
>>> $ sudo apt remove libssl1.0.0
>>>
>>> Levente
>>>
>>>>
>>>>
>>>> On 7/5/18, Levente Uzonyi <[hidden email]> wrote:
>>>>> You probably still have 1.0.1 installed.
>>>>>
>>>>> Levente
>>>>>
>>>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>>>
>>>>>> I followed
>>>>>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>>>>>
>>>>>> and got the ssl version (full info below)
>>>>>> 1.0.2l
>>>>>>
>>>>>> It still crashes.
>>>>>>
>>>>>> --Hannes
>>>>>>
>>>>>>
>>>>>> openssl version -a
>>>>>> OpenSSL 1.0.2l  25 May 2017
>>>>>> built on: reproducible build, date unspecified
>>>>>> platform: linux-elf
>>>>>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>>>>>> blowfish(idx)
>>>>>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>>>>>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>>>>>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>>>>>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>>>>>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>>>>>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>>>>>
>>>>>>
>>>>>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>>>>>> Yes it is Linux, Ubuntu based, 14.04
>>>>>>> and libssl has
>>>>>>>
>>>>>>> $ openssl version -a
>>>>>>> OpenSSL 1.0.1f 6 Jan 2014
>>>>>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>>>>>> platform: debian-i386
>>>>>>>
>>>>>>> So we can consider this to be a known error and ask for a later
>>>>>>> version
>>>>>>> of
>>>>>>> Linux
>>>>>>>
>>>>>>> Thank you.
>>>>>>> --Hannes
>>>>>>>
>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>> Well, now I see that you use linux, though I still don't know which.
>>>>>>>> Actually it doesn't really matter. What matters is which version of
>>>>>>>> libssl
>>>>>>>> is installed on your machine.
>>>>>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but works
>>>>>>>> with 1.0.2 and 1.1.
>>>>>>>>
>>>>>>>> Levente
>>>>>>>>
>>>>>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>>>>>
>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>
>>>>>>>>>> Thank you for the feedback.
>>>>>>>>>>
>>>>>>>>>> You refer to issue
>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>>>>>> below.
>>>>>>>>>
>>>>>>>>> Do you use linux? If yes, which version?
>>>>>>>>>
>>>>>>>>> Levente
>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> I was using the installation script from
>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>> Squeak section.
>>>>>>>>>>
>>>>>>>>>> I did not know that I have to go for
>>>>>>>>>>
>>>>>>>>>>  Installer ensureRecentMetacello
>>>>>>>>>>
>>>>>>>>>> That is actually much better from a user point of view.
>>>>>>>>>>
>>>>>>>>>> But it causes a instant VM crash.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Image information is below
>>>>>>>>>>
>>>>>>>>>> --Hannes
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Image
>>>>>>>>>> -----
>>>>>>>>>>
>>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>>>>>> Squeak5.2alpha
>>>>>>>>>> latest update: #18134
>>>>>>>>>> Current Change Set: Unnamed1
>>>>>>>>>> Image format 6521 (32 bit)
>>>>>>>>>>
>>>>>>>>>> Virtual Machine
>>>>>>>>>> ---------------
>>>>>>>>>>
>>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>>>>>> VMMaker.oscog-eem.2361]
>>>>>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>>>>>> platform sources revision VM: 201804030952
>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue
>>>>>>>>>> Apr
>>>>>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins: 201804030952
>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>>>>> You're probably experiencing this issue:
>>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>>>> Please confirm if that's the case. In general, it helps if you
>>>>>>>>>>> give a
>>>>>>>>>>> bit
>>>>>>>>>>> more information about the crash (VM, image, etc).
>>>>>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>>>>>> Metacello
>>>>>>>>>>> instead of that snippet, because that snippet breaks WebClient and
>>>>>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>>>>>
>>>>>>>>>>> Levente
>>>>>>>>>>>
>>>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hello
>>>>>>>>>>>>
>>>>>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>>>>>
>>>>>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>>>>>> Installer gemsource
>>>>>>>>>>>>  project: 'metacello';
>>>>>>>>>>>>  addPackage: 'ConfigurationOfMetacello';
>>>>>>>>>>>>  install.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Bootstrap Metacello Preview, using mcz files
>>>>>>>>>>>> (#'previewBootstrap'
>>>>>>>>>>>> symbolic version"
>>>>>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>>>>> version: #'previewBootstrap') load.
>>>>>>>>>>>>
>>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>>
>>>>>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>> configuration: 'MetacelloPreview';
>>>>>>>>>>>> version: #stable;
>>>>>>>>>>>> repository: 'github://Metacello/metacello:configuration';
>>>>>>>>>>>> load.
>>>>>>>>>>>>
>>>>>>>>>>>> "CRASH"
>>>>>>>>>>>>
>>>>>>>>>>>> "Now load latest version of Metacello"
>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>>> get.
>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>>> load.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Regards
>>>>>>>>>>>> Hannes
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>
>>>>>
>>>
>>
>>
>>
>


Reply | Threaded
Open this post in threaded view
|

Re: [Test][Squeak5.2a][Metacello] Installation causes VM crash

Hannes Hirzel
I replaced in

    /Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686

the content what the screen shot shows.

Then in Squeak in a workspace I did

    Installer ensureRecentMetacello.


Result: OK, i.e. on VM crash.

Vielen Dank!

--Hannes

On 7/6/18, Tobias Pape <[hidden email]> wrote:

> Hi Hannes,
>
>> On 06.07.2018, at 12:01, H. Hirzel <[hidden email]> wrote:
>>
>> Hi Tobias
>>
>> A quick answer! Great!
>>
>> Where do I get this VM and how do I replace it in the All-In-One? This
>> is what I am using for testing
>> (Linux)
>>
>> http://files.squeak.org/trunk/Squeak5.2alpha-18138-32bit/
>
> use the image from there and a vm from here:
>
> https://bintray.com/opensmalltalk/vm/cog/201807060950#files
> for example this:
> https://bintray.com/opensmalltalk/vm/download_file?file_path=squeak.cog.spur_linux32x86_201807060950.tar.gz
> or this (64bit):
> https://bintray.com/opensmalltalk/vm/download_file?file_path=squeak.cog.spur_linux64x64_201807060950.tar.gz
>
>
> Best regards
> -Tobias
>>
>> Regards
>> Hannes
>>
>> On 7/6/18, Tobias Pape <[hidden email]> wrote:
>>> Hi all
>>>
>>>
>>> Can you test with a new vm? I have a change in 97b799c
>>> (opensmalltalk-vm)
>>> that could simply fix that.
>>>
>>> Best regards
>>> -Tobias
>>>
>>>
>>>> On 05.07.2018, at 01:28, Levente Uzonyi <[hidden email]> wrote:
>>>>
>>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>>
>>>>> You mean though I get
>>>>>
>>>>> openssl version -a
>>>>> 1.0.2l
>>>>>
>>>>> How would I then remove 1.0.1?
>>>>
>>>> To find out what you have installed:
>>>>
>>>> $ aptitude search libssl1 | grep ^i
>>>>
>>>> or if you don't have aptitude installed:
>>>>
>>>> $ apt search libssl1 | grep installed
>>>>
>>>> To remove libssl1.0.0, which you should only do if the self-compiled
>>>> 1.0.2
>>>> satisfies all package dependencies and you're willing to update it from
>>>> time to time yourself:
>>>>
>>>> $ sudo apt remove libssl1.0.0
>>>>
>>>> Levente
>>>>
>>>>>
>>>>>
>>>>> On 7/5/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>> You probably still have 1.0.1 installed.
>>>>>>
>>>>>> Levente
>>>>>>
>>>>>> On Thu, 5 Jul 2018, H. Hirzel wrote:
>>>>>>
>>>>>>> I followed
>>>>>>> https://www.miguelvallejo.com/updating-to-openssl-1-0-2g-on-ubuntu-server-12-04-14-04-lts-to-stop-cve-2016-0800-drown-attack/
>>>>>>>
>>>>>>> and got the ssl version (full info below)
>>>>>>> 1.0.2l
>>>>>>>
>>>>>>> It still crashes.
>>>>>>>
>>>>>>> --Hannes
>>>>>>>
>>>>>>>
>>>>>>> openssl version -a
>>>>>>> OpenSSL 1.0.2l  25 May 2017
>>>>>>> built on: reproducible build, date unspecified
>>>>>>> platform: linux-elf
>>>>>>> options:  bn(64,32) rc4(8x,mmx) des(ptr,risc1,16,long) idea(int)
>>>>>>> blowfish(idx)
>>>>>>> compiler: gcc -I. -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT
>>>>>>> -DDSO_DLFCN -DHAVE_DLFCN_H -Wa,--noexecstack -DL_ENDIAN -O3
>>>>>>> -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS
>>>>>>> -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
>>>>>>> -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM
>>>>>>> -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM
>>>>>>>
>>>>>>>
>>>>>>> On 7/5/18, H. Hirzel <[hidden email]> wrote:
>>>>>>>> Yes it is Linux, Ubuntu based, 14.04
>>>>>>>> and libssl has
>>>>>>>>
>>>>>>>> $ openssl version -a
>>>>>>>> OpenSSL 1.0.1f 6 Jan 2014
>>>>>>>> built on: Thu Mar 19 15:10:04 UTC 2015
>>>>>>>> platform: debian-i386
>>>>>>>>
>>>>>>>> So we can consider this to be a known error and ask for a later
>>>>>>>> version
>>>>>>>> of
>>>>>>>> Linux
>>>>>>>>
>>>>>>>> Thank you.
>>>>>>>> --Hannes
>>>>>>>>
>>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>>> Well, now I see that you use linux, though I still don't know
>>>>>>>>> which.
>>>>>>>>> Actually it doesn't really matter. What matters is which version of
>>>>>>>>> libssl
>>>>>>>>> is installed on your machine.
>>>>>>>>> I found that the SqueakSSL plugin crashes with libssl1.0.0 but
>>>>>>>>> works
>>>>>>>>> with 1.0.2 and 1.1.
>>>>>>>>>
>>>>>>>>> Levente
>>>>>>>>>
>>>>>>>>> On Wed, 4 Jul 2018, Levente Uzonyi wrote:
>>>>>>>>>
>>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>>
>>>>>>>>>>> Thank you for the feedback.
>>>>>>>>>>>
>>>>>>>>>>> You refer to issue
>>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>>>> The answer is: Maybe it is the same, but I use a 32bit image, see
>>>>>>>>>>> below.
>>>>>>>>>>
>>>>>>>>>> Do you use linux? If yes, which version?
>>>>>>>>>>
>>>>>>>>>> Levente
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> I was using the installation script from
>>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>>> Squeak section.
>>>>>>>>>>>
>>>>>>>>>>> I did not know that I have to go for
>>>>>>>>>>>
>>>>>>>>>>>  Installer ensureRecentMetacello
>>>>>>>>>>>
>>>>>>>>>>> That is actually much better from a user point of view.
>>>>>>>>>>>
>>>>>>>>>>> But it causes a instant VM crash.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Image information is below
>>>>>>>>>>>
>>>>>>>>>>> --Hannes
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Image
>>>>>>>>>>> -----
>>>>>>>>>>>
>>>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Resources/Squeak5.2alpha-18134-32bit.image
>>>>>>>>>>> Squeak5.2alpha
>>>>>>>>>>> latest update: #18134
>>>>>>>>>>> Current Change Set: Unnamed1
>>>>>>>>>>> Image format 6521 (32 bit)
>>>>>>>>>>>
>>>>>>>>>>> Virtual Machine
>>>>>>>>>>> ---------------
>>>>>>>>>>>
>>>>>>>>>> /media/user/data-ext4/Smtk/4-test-images/Squeak5.2a_latest/Squeak5.2alpha-18134-32bit-All-in-One.app/Contents/Linux-i686/lib/squeak/5.0-201804030952/squeak
>>>>>>>>>>> Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives
>>>>>>>>>> VMMaker.oscog-eem.2361]
>>>>>>>>>>> Unix built on Apr  3 2018 17:17:33 Compiler: 4.8.4
>>>>>>>>>>> platform sources revision VM: 201804030952
>>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Tue
>>>>>>>>>>> Apr
>>>>>>>>>>> 3 11:52:19 2018 +0200 $ CommitHash: 29f50cf $ Plugins:
>>>>>>>>>>> 201804030952
>>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
>>>>>>>>>>> CoInterpreter VMMaker.oscog-eem.2361 uuid:
>>>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>>>> StackToRegisterMappingCogit VMMaker.oscog-eem.2361 uuid:
>>>>>>>>>>> 7ca2f89a-de70-422f-b92b-54f91ac4e47b Apr  3 2018
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On 7/4/18, Levente Uzonyi <[hidden email]> wrote:
>>>>>>>>>>>> You're probably experiencing this issue:
>>>>>>>>>>>> https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/260
>>>>>>>>>>>> Please confirm if that's the case. In general, it helps if you
>>>>>>>>>>>> give a
>>>>>>>>>>>> bit
>>>>>>>>>>>> more information about the crash (VM, image, etc).
>>>>>>>>>>>> Also I suggest you use Installer ensureRecentMetacello to load
>>>>>>>>>>>> Metacello
>>>>>>>>>>>> instead of that snippet, because that snippet breaks WebClient
>>>>>>>>>>>> and
>>>>>>>>>>>> SqueakSSL by loading an older, incompatible version of them.
>>>>>>>>>>>>
>>>>>>>>>>>> Levente
>>>>>>>>>>>>
>>>>>>>>>>>> On Wed, 4 Jul 2018, H. Hirzel wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Hello
>>>>>>>>>>>>>
>>>>>>>>>>>>> The installation of Metacello causes a VM crash.
>>>>>>>>>>>>>
>>>>>>>>>>>>> http://wiki.squeak.org/squeak/6157
>>>>>>>>>>>>> https://github.com/Metacello/metacello
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Get the Metacello configuration (for Squeak users)"
>>>>>>>>>>>>> Installer gemsource
>>>>>>>>>>>>>  project: 'metacello';
>>>>>>>>>>>>>  addPackage: 'ConfigurationOfMetacello';
>>>>>>>>>>>>>  install.
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Bootstrap Metacello Preview, using mcz files
>>>>>>>>>>>>> (#'previewBootstrap'
>>>>>>>>>>>>> symbolic version"
>>>>>>>>>>>>> ((Smalltalk at: #ConfigurationOfMetacello) project
>>>>>>>>>>>>> version: #'previewBootstrap') load.
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Result : OK"
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Load the Preview version of Metacello from GitHub"
>>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>>> configuration: 'MetacelloPreview';
>>>>>>>>>>>>> version: #stable;
>>>>>>>>>>>>> repository: 'github://Metacello/metacello:configuration';
>>>>>>>>>>>>> load.
>>>>>>>>>>>>>
>>>>>>>>>>>>> "CRASH"
>>>>>>>>>>>>>
>>>>>>>>>>>>> "Now load latest version of Metacello"
>>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>>>> get.
>>>>>>>>>>>>> (Smalltalk at: #Metacello) new
>>>>>>>>>>>>> baseline: 'Metacello';
>>>>>>>>>>>>> repository: 'github://Metacello/metacello:master/repository';
>>>>>>>>>>>>> load.
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Regards
>>>>>>>>>>>>> Hannes
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>>
>>>>
>>>
>>>
>>>
>>
>
>
>