Unrecognized web browser

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unrecognized web browser

Albert Wagner-2

After clicking on a URL in Squeak I received a popup:

"There is no Web browser installed but the URL was copied to the clipboard:     http://lists.squeakfoundation.org/mailman/listinfo/beginners"

I am running on Linux MX and my default web browser is Waterfox.  All other URLs are OK  with that.  What can I do to inform Squeak that I do have a browser installed?


_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
jrm
Reply | Threaded
Open this post in threaded view
|

Re: Unrecognized web browser

jrm
Hi Albert,
Which version of Squeak are you using?
Can you send me instructions so I can try to reproduce the problem?
There is a lot I don't know about Squeak, but I will help you if I can.
-jrm


On Sun, Aug 23, 2020 at 6:01 PM Albert Wagner <[hidden email]> wrote:

After clicking on a URL in Squeak I received a popup:

"There is no Web browser installed but the URL was copied to the clipboard:     http://lists.squeakfoundation.org/mailman/listinfo/beginners"

I am running on Linux MX and my default web browser is Waterfox.  All other URLs are OK  with that.  What can I do to inform Squeak that I do have a browser installed?

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners


--
John-Reed Maffeo

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|

Re: Unrecognized web browser

Christoph Thiede

Hi Albert, hi John,


@John: You can reproduce the issue, for instance, by opening "Squeak Help" from the Help menu in the docking bar. Then click the link to the Squeak homepage.



Squeak forms its own subsystem that sparsely communicates with the host system (such as Linux). When it says "there is no web browser installed", it does not speak about the Browser you have installed in your host system but about the Browsers that are installed within Squeak. By default, Squeak does not contain any web browser, but there are several implementations available:
  • You could try Scamper for a pure-Squeak web browser implementation; but be warned, unfortunately, it does only support very basic web pages (forget about complicated CSS, YouTube, or JavaScript) and is very slow.
  • Another approach is MagicMouse which actually runs a Chromium instance in the host systems and renders the results in Squeak. Pro: Supports every web page and has reasonable speed. Con: No pure Squeak implementation, so you won't be able to benefit from Squeak's typical interactivity and explorability when browsing the web. But's is a really cool concept.
  • And if your only wish is to open the link in your host system, in the big darkness outside of Squeak, you could load ExternalWebBrowser (available on Squeak Map via the Tools Menu). It creates a connection to the host system and opens any clicked URL there.

Please let me know if you have further questions!

Best,
Christoph


Von: Beginners <[hidden email]> im Auftrag von John-Reed Maffeo <[hidden email]>
Gesendet: Montag, 24. August 2020 03:38 Uhr
An: A friendly place to get answers to even the most basic questions about Squeak.
Betreff: Re: [Newbies] Unrecognized web browser
 
Hi Albert,
Which version of Squeak are you using?
Can you send me instructions so I can try to reproduce the problem?
There is a lot I don't know about Squeak, but I will help you if I can.
-jrm


On Sun, Aug 23, 2020 at 6:01 PM Albert Wagner <[hidden email]> wrote:

After clicking on a URL in Squeak I received a popup:

"There is no Web browser installed but the URL was copied to the clipboard:     http://lists.squeakfoundation.org/mailman/listinfo/beginners"

I am running on Linux MX and my default web browser is Waterfox.  All other URLs are OK  with that.  What can I do to inform Squeak that I do have a browser installed?

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners


--
John-Reed Maffeo

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners