printf not working on 5.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

printf not working on 5.0

Joseph Alotta
Greetings,

I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but
the compiler can’t find it.

'%8.1f' class ==>  ByteString


'%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:


Help!


Sincerely,

Joe.





_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: printf not working on 5.0

Ron Teitelbaum
Hi Joe,

I'm not aware of printf  is it this: http://www.squeaksource.com/Printf/ 

Ron

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Joseph Alotta
Sent: Wednesday, August 10, 2016 12:19 PM
To: [hidden email]
Subject: [Newbies] printf not working on 5.0

Greetings,

I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but the compiler can’t find it.

'%8.1f' class ==>  ByteString


'%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:


Help!


Sincerely,

Joe.





_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Joseph Alotta
yes, that is the one.


> On Aug 10, 2016, at 2:19 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:
>
> Hi Joe,
>
> I'm not aware of printf  is it this: http://www.squeaksource.com/Printf/ 
>
> Ron
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Joseph Alotta
> Sent: Wednesday, August 10, 2016 12:19 PM
> To: [hidden email]
> Subject: [Newbies] printf not working on 5.0
>
> Greetings,
>
> I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but the compiler can’t find it.
>
> '%8.1f' class ==>  ByteString
>
>
> '%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:
>
>
> Help!
>
>
> Sincerely,
>
> Joe.
>
>
>
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910362.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Ron Teitelbaum

So you are all set now?

 

Ron

 

yes, that is the one.


> On Aug 10, 2016, at 2:19 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:
>
> Hi Joe,
>
> I'm not aware of printf  is it this: http://www.squeaksource.com/Printf/ 
>
> Ron
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Joseph Alotta
> Sent: Wednesday, August 10, 2016 12:19 PM
> To: [hidden email]
> Subject: [Newbies] printf not working on 5.0
>
> Greetings,
>
> I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but the compiler can’t find it.
>
> '%8.1f' class ==>  ByteString
>
>
> '%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:
>
>
> Help!
>
>
> Sincerely,
>
> Joe.
>
>
>
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910362.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

 


View this message in context: Re: printf not working on 5.0

Sent from the Squeak - Beginners mailing list archive at Nabble.com.


_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Joseph Alotta
No. I already have the code. But the system can't find the method.  

Sent from my iPhone 

On Aug 10, 2016, at 4:38 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:

So you are all set now?

 

Ron

 

yes, that is the one.


> On Aug 10, 2016, at 2:19 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:
>
> Hi Joe,
>
> I'm not aware of printf  is it this: http://www.squeaksource.com/Printf/ 
>
> Ron
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Joseph Alotta
> Sent: Wednesday, August 10, 2016 12:19 PM
> To: [hidden email]
> Subject: [Newbies] printf not working on 5.0
>
> Greetings,
>
> I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but the compiler can’t find it.
>
> '%8.1f' class ==>  ByteString
>
>
> '%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:
>
>
> Help!
>
>
> Sincerely,
>
> Joe.
>
>
>
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910362.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

 


View this message in context: Re: printf not working on 5.0

Sent from the Squeak - Beginners mailing list archive at Nabble.com.

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners



If you reply to this email, your message will be added to the discussion below:
http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910376.html
To start a new topic under Squeak - Beginners, email [hidden email]
To unsubscribe from Squeak - Beginners, click here.
NAML
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Joseph Alotta
In reply to this post by Ron Teitelbaum
Somehow the code was hooked into ByteString, but I can’t see where or how.

Maybe there is a part that I forgot to copy.  Is it possible that the package makes modification to ByteString somewhere?

Sincerely,

Joe.


> On Aug 10, 2016, at 4:38 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:
>
> So you are all set now?
>
>  
>
> Ron
>
>  
>
> yes, that is the one.
>
>
>
> > On Aug 10, 2016, at 2:19 PM, Ron Teitelbaum [via Smalltalk] <[hidden email]> wrote:
> >
> > Hi Joe,
> >
> > I'm not aware of printf  is it this: http://www.squeaksource.com/Printf/ 
> >
> > Ron
> >
> > -----Original Message-----
> > From: [hidden email] [mailto:[hidden email]] On Behalf Of Joseph Alotta
> > Sent: Wednesday, August 10, 2016 12:19 PM
> > To: [hidden email]
> > Subject: [Newbies] printf not working on 5.0
> >
> > Greetings,
> >
> > I was using printf extensively, but when I migrated to 5.0 printf does not work.  I filed out the package and filed it back in, but the compiler can’t find it.
> >
> > '%8.1f' class ==>  ByteString
> >
> >
> > '%6.2e' printf: 412.343434 >>  MessageNotUnderstood: ByteString>>printf:
> >
> >
> > Help!
> >
> >
> > Sincerely,
> >
> > Joe.
> >
> >
> >
> >
> >
> > _______________________________________________
> > Beginners mailing list
> > [hidden email]
> > http://lists.squeakfoundation.org/mailman/listinfo/beginners
> >
> > _______________________________________________
> > Beginners mailing list
> > [hidden email]
> > http://lists.squeakfoundation.org/mailman/listinfo/beginners
> >
> >
> > If you reply to this email, your message will be added to the discussion below:
> > http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910362.html
> > To start a new topic under Squeak - Beginners, email [hidden email]
> > To unsubscribe from Squeak - Beginners, click here.
> > NAML
>
>  
>
> View this message in context: Re: printf not working on 5.0
>
> Sent from the Squeak - Beginners mailing list archive at Nabble.com.
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910376.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Bert Freudenberg
On Thu, Aug 11, 2016 at 1:44 AM, Joseph Alotta <[hidden email]> wrote:
Somehow the code was hooked into ByteString, but I can’t see where or how.

Maybe there is a part that I forgot to copy.  Is it possible that the package makes modification to ByteString somewhere?

Yes, of course. The package defines various extension methods.

This is probably the easiest way to install it:
 
Installer ss project: 'Printf'; install: 'Printf'

- Bert - 


_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Joseph Alotta
Hi Bert,

Thank you for the magic incantation.  It worked.  What will I do when I don’t have someone to tell me what the magic words are?

I filed out the code from 4.3 and filed in the same code into 5.0.  Did it miss a part?  It is all in one project area or is there parts in other places in the image?

How would I debug something like this going forward?


Sincerely,

Joe.


> On Aug 11, 2016, at 4:20 AM, Bert Freudenberg [via Smalltalk] <[hidden email]> wrote:
>
> On Thu, Aug 11, 2016 at 1:44 AM, Joseph Alotta <[hidden email]> wrote:
> Somehow the code was hooked into ByteString, but I can’t see where or how.
>
> Maybe there is a part that I forgot to copy.  Is it possible that the package makes modification to ByteString somewhere?
>
> Yes, of course. The package defines various extension methods.
>
> This is probably the easiest way to install it:
>  
> Installer ss project: 'Printf'; install: 'Printf'
>
> - Bert -
>
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910433.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Bert Freudenberg
On Thu, Aug 11, 2016 at 5:16 PM, Joseph Alotta <[hidden email]> wrote:
Hi Bert,

Thank you for the magic incantation.  It worked.  What will I do when I don’t have someone to tell me what the magic words are?

I filed out the code from 4.3 and filed in the same code into 5.0.  Did it miss a part?  It is all in one project area or is there parts in other places in the image?

How would I debug something like this going forward?

No need to debug, you simply need to learn how to use Monticello, our preferred source code versioning system. Changesets have pretty much fallen out of style.

Maybe someone else can supply better pointers to tutorials, but here are some:


- Bert -

_______________________________________________
Beginners mailing list
[hidden email]
http://lists.squeakfoundation.org/mailman/listinfo/beginners
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: printf not working on 5.0

Joseph Alotta
okay, thanks.  i will watch them.


> On Aug 12, 2016, at 3:57 AM, Bert Freudenberg [via Smalltalk] <[hidden email]> wrote:
>
> On Thu, Aug 11, 2016 at 5:16 PM, Joseph Alotta <[hidden email]> wrote:
> Hi Bert,
>
> Thank you for the magic incantation.  It worked.  What will I do when I don’t have someone to tell me what the magic words are?
>
> I filed out the code from 4.3 and filed in the same code into 5.0.  Did it miss a part?  It is all in one project area or is there parts in other places in the image?
>
> How would I debug something like this going forward?
>
> No need to debug, you simply need to learn how to use Monticello, our preferred source code versioning system. Changesets have pretty much fallen out of style.
>
> Maybe someone else can supply better pointers to tutorials, but here are some:
>
> http://www.wiresong.ca/monticello/v1/docs/
> http://squeakbyexample.org/
> https://www.hpi.uni-potsdam.de/hirschfeld/trac/SqueakCommunityProjects/wiki/squeak_screencasts
> https://www.youtube.com/watch?v=LMlzD5LSBx4
>
> - Bert -
>
> _______________________________________________
> Beginners mailing list
> [hidden email]
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
>
>
> If you reply to this email, your message will be added to the discussion below:
> http://forum.world.st/printf-not-working-on-5-0-tp4910343p4910663.html
> To start a new topic under Squeak - Beginners, email [hidden email]
> To unsubscribe from Squeak - Beginners, click here.
> NAML

Loading...